Annonce

Écrire une réponse

Veuillez écrire votre message et l'envoyer

Cliquez dans la zone sombre de l'image pour envoyer votre message.

Retour

Résumé de la discussion (messages les plus récents en premier)

grodid
2013-01-26 18:54:05

Oui, merci Zaphod, ça marche maintenant très bien sur ma galerie de test privée. Super !

Cdt, G.

Zaphod
2013-01-26 18:10:08

J'ai mis à jour pour Piwigo 2.4... ça devrait marcher.
Si tu peux confirmer que tout fonctionne correctement.

grodid
2013-01-15 09:10:57

flop25 a écrit:

pourquoi s'énerver ?
j'ai mis "'la même chose'" entre guillemets. Je m'inquiète juste de voir un utilisateur se poser des questions et avoir l'air perdu : est-ce mauvais ? C’est pour ça que je t'aide et te réponds sur le fond -cf mon msg précédent-

Non, ne t'inquiète pas, je ne me suis pas énervé du tout (le mail ne permet pas souvent de lire l'humeur de celui qui l'écrit ;-), j'apprécie beaucoup la réactivité et le suivi de toute la communauté Piwigo, et, comme j'ai compris qu'il fallait tester et retester, j'ai ajouté mon petit bout d'info à propos du thème de base.

Une suggestion, au moins pour la 2ème URL vers ton site de démo : pourquoi ne pas mettre, dans le menu des thèmes, le titre du thème en plus de la vignette ? Enfin, quelque chose comme cela ... Et aussi, un bandeau qui donnerait la liste des plugins actifs à un moment donné (ou pour un thème donné) ?

Mais j'admire le site de démo, j'aimerai bien arriver à faire quelque chose d'aussi attractif. Et tes réponses m'ont ouvert les yeux sur plusieurs mécanismes des thèmes.

Merci,   cdt,   Gilbert.

flop25
2013-01-14 22:33:37

pourquoi s'énerver ?
j'ai mis "'la même chose'" entre guillemets. Je m'inquiète juste de voir un utilisateur se poser des questions et avoir l'air perdu : est-ce mauvais ? C’est pour ça que je t'aide et te réponds sur le fond -cf mon msg précédent-

grodid
2013-01-14 22:30:43

flop25 a écrit:

grodid a écrit:

flop25 a écrit:

@grodid mais quell idée de vouloir mettre du Gthumb dans des thèmes qui n'en ont aucun besoin
^_^

Bon, je sais bien que tu essaies de dire ça pour rigoler, mais je n'en suis pas si sur.

je  te charie sur le fait que tu postes deux fois 'la même chose' c'est tout ; oui dans le fond tu as un 'problème' j'ai vu

Ben non, je n'ai pas posté 2 fois la même chose : hier tu m'as répondu à propos de 'Stripped & Columns',
et aujourd'hui c'est du 'Stripped-Galleria' qu'il s'agit ... ;;-(( Et, pour t'éviter des inquiétudes, GThumb est peut-être incompatible avec ces 2 là, mais marche très bien avec le thème de base 'Stripped' ... C'est comme ça !

Bonne soirée,   Cdt,   Gilbert.

flop25
2013-01-14 22:13:00

grodid a écrit:

flop25 a écrit:

@grodid mais quell idée de vouloir mettre du Gthumb dans des thèmes qui n'en ont aucun besoin
^_^

Bon, je sais bien que tu essaies de dire ça pour rigoler, mais je n'en suis pas si sur.

je  te charie sur le fait que tu postes deux fois 'la même chose' c'est tout ; oui dans le fond tu as un 'problème' j'ai vu

grodid a écrit:

A dire vrai, ce que vous nous proposez est tellement riche qu'on s'y perd ...

Honnêtement c'est plutôt moyen, surtout quand on considère la qualité

grodid a écrit:

Et quand je passe d'un thème à l'autre, il n'y a pas de lumière rouge pour me dire que je fais une bêtise (ce n'est pas un reproche), surtout quand on ne sait pas à priori ce qui pourrait être incompatible.

et il n'y en aura jamais à part éventuellement si un grand plugin super connu est incompatible avec le thème. Parce qu'avec le nombre de combinaison plugin/thème et rajoutons aussi les template-extension...

grodid a écrit:

Ce dont on peut rêver, pour un plugin 'NBC ThemeChanger++' (attention, 'ThemeChanger' c'est déjà très chouette !), ce serait de pouvoir définir, pour un album donné, une association du genre 'Dark + Autosize + GThumb, avec téléchargement', puis pour un autre on lui associerait plutôt 'Stripped-Galleria, sans téléchargement possible', et ainsi de suite.

là c'est du multi-galerie ça sort du cadre du plugin qui se veut juste simple.

PS : Tiens, pendant que j'y suis, une suggestion : pour chaque thème, ne pourrait-on trouver une galerie 'typique' que le client potentiel pourrait aller visiter pour se rendre compte, et pour laquelle l'auteur aurait choisi les plugins les mieux adaptés (ou, au moins, un petit menu dans le coin pourrait permettre d'aller les lister) ? Pour l'heure, c'est pas facile de se rendre compte, avec une seule vignette sur la présentation de l'extension retenue, de ce qu'elle recèle réellement comme merveilles. J'ai navigué à travers beaucoup des démos présentées (chouettes), mais je ne sais pas souvent quels sont les plugins ou astuces utilisés pour réaliser telle ou telle présentation spéciale - et c'est un peu frustrant. Bon, j'espère avoir été clair :-))

je t'avouerai que je ne sais pas pourquoi ça ne se fait pas : du coup, j'ai mis ça sur mon site perso, http://www.planete-flop.fr/blog/les-ext … ur-piwigo/ http://www.planete-flop.fr/sandbox/demo_piwigo/

grodid
2013-01-14 21:59:36

flop25 a écrit:

@grodid mais quell idée de vouloir mettre du Gthumb dans des thèmes qui n'en ont aucun besoin
^_^

Bon, je sais bien que tu essaies de dire ça pour rigoler, mais je n'en suis pas si sur.

Alors je m'explique : je suis en train, sur ma galerie piwigo.com, d'expérimenter sur les thèmes zet les plugins pour trouver ce qui me va bien. A dire vrai, ce que vous nous proposez est tellement riche qu'on s'y perd ... Ceci dit, il y a des thèmes qui ont besoin d'un peu d'accompagnement, et j'ai choisi 'dark' pour thème de base, agrémenté de 'autosize' et 'GThumb+' comme plugins.

Et quand je passe d'un thème à l'autre, il n'y a pas de lumière rouge pour me dire que je fais une bêtise (ce n'est pas un reproche), surtout quand on ne sait pas à priori ce qui pourrait être incompatible. Ce dont on peut rêver, pour un plugin 'NBC ThemeChanger++' (attention, 'ThemeChanger' c'est déjà très chouette !), ce serait de pouvoir définir, pour un album donné, une association du genre 'Dark + Autosize + GThumb, avec téléchargement', puis pour un autre on lui associerait plutôt 'Stripped-Galleria, sans téléchargement possible', et ainsi de suite.

Pour l'instant c'est pas comme ça, donc il y a des pépins ...

Ceci dit, c'est déjà pas mal, une fois de plus. Si par hasard je n'étais pas content, je n'ai qu'à m'y mettre ...

Vous savez très bien que plus on offre de possibilités aux utilisateurs, plus on leur titille l'imagination, et plus ils en re-demandent, en retour.

Merci pour votre suivi et votre accueil, en tout cas,   Cdt,   G.

PS : Tiens, pendant que j'y suis, une suggestion : pour chaque thème, ne pourrait-on trouver une galerie 'typique' que le client potentiel pourrait aller visiter pour se rendre compte, et pour laquelle l'auteur aurait choisi les plugins les mieux adaptés (ou, au moins, un petit menu dans le coin pourrait permettre d'aller les lister) ? Pour l'heure, c'est pas facile de se rendre compte, avec une seule vignette sur la présentation de l'extension retenue, de ce qu'elle recèle réellement comme merveilles. J'ai navigué à travers beaucoup des démos présentées (chouettes), mais je ne sais pas souvent quels sont les plugins ou astuces utilisés pour réaliser telle ou telle présentation spéciale - et c'est un peu frustrant. Bon, j'espère avoir été clair :-))

flop25
2013-01-14 21:28:49

@grodid mais quell idée de vouloir mettre du Gthumb dans des thèmes qui n'en ont aucun besoin
^_^

Zaphod
2013-01-14 21:13:06

Ah oui Gthumb est totalement incompatible avec stripped-galleria, car les deux doivent chercher à remplacer la page de thumbnails.

grodid
2013-01-14 21:03:44

Zaphod a écrit:

Bonjour,

Tu as bien fait de m'envoyer un MP en plus, ces temps-ci je ne passe que très rarement sur le forum.

Pour stripped-slide, ça n'a pas été mis à jour en 2.4.
Ca n'est pas super difficile à faire sur le principe, et c'est sur ma liste de choses à faire...
Je ne peux pas donner de date, par contre, mais j'essaie de faire ça pour bientôt.

OK, merci, j'attendrai patiemment.

Pour stripped-galleria, par contre, ça devrait marcher.
Tu utilises quoi comme plugins ?
Peut-être que certains ne sont pas compatibles.
L'intégration du code javascript de galleria dans piwigo est assez instable (disons qu'il y a pas mal de causes qui peuvent mener au fait que ça ne marche pas).

C'est bien vu : c'était GThumb qui semait la pagaille, maintenant ça marche bien.
Voir : http://grodid.piwigo.com/index?/category/103

Merci,  Cdt,   G.

Zaphod
2013-01-13 23:30:17

Bonjour,

Tu as bien fait de m'envoyer un MP en plus, ces temps-ci je ne passe que très rarement sur le forum.

Pour stripped-slide, ça n'a pas été mis à jour en 2.4.
Ca n'est pas super difficile à faire sur le principe, et c'est sur ma liste de choses à faire...
Je ne peux pas donner de date, par contre, mais j'essaie de faire ça pour bientôt.

Pour stripped-galleria, par contre, ça devrait marcher.
Tu utilises quoi comme plugins ?
Peut-être que certains ne sont pas compatibles.
L'intégration du code javascript de galleria dans piwigo est assez instable (disons qu'il y a pas mal de causes qui peuvent mener au fait que ça ne marche pas).

Par exemple, si tu utilises des caractères exotiques dans les commentaires.
Tu peux essayer par exemple de faire un album avec une photo, sans titre ni commentaire, voir si ça marche là dessus.

grodid
2013-01-10 15:28:57

Bonjour,

Plutôt qu'un MP à Zaphod, j'ai préféré le forum pour que tout le monde en profite et me procure d'autres avis. Bien, ces 2 thèmes m'intéressent, au moins pour expérimenter,  mais, ma galerie étant sous PWG 2.4.6 :
- Stripped-Slide n'est pas disponible
- Stripped-Galleria n'a pas l'air fonctionnel : un essai rapide m'a donné un bandeau d'images vertical (et non horizontal) sans miniatures en dessous.

Comme je suis têtu, je suis allé sur la galerie test de Zaphod
http://www.audreyetjulien.fr/test/?theme=stripped-slide
(citée ici :  http://fr.piwigo.org/forum/post.php?tid … qid=179177).

Ce lien conduit à une galerie horizontale qui ressemble à du 'stripped-slide', mais avec juste des cases vides à la place des clichés. Il faut reconnaître que pour l'instant, le menu 'thème de l'interface' ne propose PAS 'stripped-slide'.

Par contre, dans ce même menu, la sélection du thème 'stripped-galleria' conduit bien à l'effet souhaité.

Donc : comment avoir 'stripped-galleria' sous 2.4.6 ?
Et : comment avoir 'stripped-slide', qui marche, et sous 2.4.6 ?

Respect pour tout le boulot déjà accompli, en passant ...

Merci, Cordialement,   G.

Pied de page des forums

Propulsé par FluxBB

github twitter newsletter Faire un don Piwigo.org © 2002-2022 · Contact