Annonce

Écrire une réponse

Veuillez écrire votre message et l'envoyer

Cliquez dans la zone sombre de l'image pour envoyer votre message.

Retour

Résumé de la discussion (messages les plus récents en premier)

nicolas
2010-04-20 15:13:00

vincent3569 a écrit:

une démo au téléphone peut-être (j'ai également des outils pour faire du netmeeting avancé, histoire de partager mon PC) ? si OK -> MP.

Pas besoin d'aller jusque là. On peut peut-être se contenter d'un échange par messagerie instantannée : msn, jabber,... Mon contact est mon email située sur mon profil.

vincent3569
2010-04-20 09:00:23

VDigital a écrit:

Autant j'arrivais encore à suivre mais là. :-/

Tu ne voudrais pas nous ré-expliquer ça en plusieurs topics un par problème et essaie d'être simple, clair, compréhensible, avec des copies d'écran et des exemples.

Pourtant, j'y mets du coeur, mais visiblement par post interposé, ça ne passe pas bien.

est-ce que ce point là est clair :

2- en 2.1.0
les fonctions de tris [edit : des photos] sont éclatées [edit : sont présentes en doublon] entre les menus config/catégories/gérer/éditer et config/catégories/gérer/éditer/rangs.
=> c'est très confusant
du coup, je propose 2 solutions :
- soit les options de tri restent sur config/catégories/gérer/éditer et il faut les supprimer de config/catégories/gérer/éditer/rangs (ce menu ne sert alors qu'à faire le tri manuel par rang)
- soit les options de tri restent sur config/catégories/gérer/éditer/rangs et il faut alors supprimer le blocs [edit : ordre de tri] du menu config/catégories/gérer/éditer et renomer le menu [edit : config/catégories/gérer/éditer/rangs] en config/catégories/gérer/éditer/tris

pour le 3-, je ne sais pas comment expliquer de manière plus claire.
une démo au téléphone peut-être (j'ai également des outils pour faire du netmeeting avancé, histoire de partager mon PC) ? si OK -> MP.

nicolas
2010-04-16 21:05:31

VDigital a écrit:

Autant j'arrivais encore à suivre mais là. :-/

Tu ne voudrais pas nous ré-expliquer ça en plusieurs topics un par problème et essaie d'être simple, clair, compréhensible, avec des copies d'écran et des exemples.

ça me rassure que tu ne comprennes pas non plus. Bon en même temps, je n'avais pas compris ton explication de ce que voulais vincent3569.

VDigital
2010-04-16 17:31:22

Autant j'arrivais encore à suivre mais là. :-/

Tu ne voudrais pas nous ré-expliquer ça en plusieurs topics un par problème et essaie d'être simple, clair, compréhensible, avec des copies d'écran et des exemples.

vincent3569
2010-04-16 15:13:55

en fait, j'en profite pour découvrir pas mal de "problèmes" sur les tris et ce, dès la 2.0.9.

1- en 2.0.9 :
- en admin, je modifie le rang des photos.
- sur la partie visiteur, ce tri n'est pas visible
=> la cause probable : j'ai supprimé les icônes de tri sur ma galerie et doit y avoir un tri par défaut qui est positionné, non modifiable, et qui ne respecte pas le tri imposé en admin.

2- j'avais espéré résoudre le problème décrit ci-dessus en décochant la case "Utiliser l'ordre de tri des images par défaut (défini dans le fichier de configuration)" du menu config/catégories/gérer/éditer, mais ce bouton se recoche automatiquement lors de la sauvegarde
=> ls 2 pbs sont peut-être liés

je n'ai pas constaté ces problèmes avec la 2.1.0
- le tri par défaut de la partie publique = le tri fait par l'admin
- je peux bien décocher la case "Utiliser l'ordre de tri des images par défaut (défini dans le fichier de configuration)"
=> le tri par rang est bien visible correctement sur la partie publique, même si je désactive l'icone "tri".
=> le tri par rang est bien visible correctement sur la partie publique, même si je désactive l'icone "tri".

2- en 2.1.0
les fonctions de tris sont éclatées entre les menus config/catégories/gérer/éditer et config/catégories/gérer/éditer/rangs.
=> c'est très confusant
du coup, je propose 2 solutions :
- soit les options de tri restent sur config/catégories/gérer/éditer et il faut les supprimer de config/catégories/gérer/éditer/rangs (ce menu ne sert alors qu'à faire le tri manuel par rang)
- soit les options de tri restent sur config/catégories/gérer/éditer/rangs et il faut alors supprimer le blocs du menu config/catégories/gérer/éditer et renomer le menu en config/catégories/gérer/éditer/tris

3- correspondant à ma remontée initiale :
l'affichage des vignettes sur config/catégories/gérer/éditer/rangs ne reflète pas la réalité du tri choisi.
un exemple pour illustrer :
exemple 1
- je vais sur le tri manuel, je déplace manuellement 2 photos (j'ai un tri par rang)
- je modifie le tri en "par date d'ajout" : l'ordre des vignettes est bien modifié sur la galerie mais par sur config/catégories/gérer/éditer/rangs (cer dernier reste ad vitam aeteram sur le tri manuel effectué auparavant)
=> pour moi, l'ordre des vignette affichées devrait refleter la réalité du tri choisi.

tosca
2010-04-16 14:23:19

VDigital a écrit:

Je te conseille de passer à un exercice pratique pour voir concrètement ce que donne l'ajout, et l'impact sur le rang.
Car sur le papier cela semble correct, à l'usage ce n'est pas forcément ce que tout le monde attend.

Même si la solution qui marche dans tous les cas de figure n'existe pas, pour certains utilisateurs, ça n'est pas forcément inintéressant de résoudre 80% des besoins.

VDigital
2010-04-16 12:16:18

Je te conseille de passer à un exercice pratique pour voir concrètement ce que donne l'ajout, et l'impact sur le rang.
Car sur le papier cela semble correct, à l'usage ce n'est pas forcément ce que tout le monde attend.

tosca
2010-04-16 11:41:43

VDigital a écrit:

tri d'origine par Date de création à l'exception des images reclassées qui pourraient s'intercaler.

Ce qui est en principe le cas. Sauf que si tu changes le tri pour revenir à la date de création (par exemple suite à un ajout de nouvelles images) tu perds le rang et même si tu tries par date et rang, le rang ne reclassera que partiellement les images mais jamais où elles ont été positionnées lors du classement.

Impossible à gérer ...

Si tu as 2 champs : "creation date" et "manual order" (renseigné avec un nombre croissant avec des "trous"), pourquoi ne pourrais-tu pas afficher :
- par date de création seule (avec l'heure de préférence, mais il me semble que ça n'a jamais été implémenté)
- par rang seul
- ou par date de création (année-mois-jour, sans l'heure), puis par rang à l'intérieur d'une journée ?

VDigital
2010-04-16 11:28:05

Je vais essayé d'expliquer le comportement espéré par vincent3569 mais qui n'a jamais existé dans Piwigo.

Tri de départ : Date de création.
Reclassement via les Rang. Et en sortie, automatiquement : tri par rang.

Vincent voudrait conserver le tri d'origine par Date de création à l'exception des images reclassées qui pourraient s'intercaler.

Ce qui est en principe le cas. Sauf que si tu changes le tri pour revenir à la date de création (par exemple suite à un ajout de nouvelles images) tu perds le rang et même si tu tries par date et rang, le rang ne reclassera que partiellement les images mais jamais où elles ont été positionnées lors du classement.

Impossible à gérer, et Piwigo n'a jamais fonctionné ainsi, cela n'a rien à voir avec un retour de 2.1RC1

Ceci dit je peux également mal interpréter les messages de vincent3569.

nicolas
2010-04-16 10:54:26

vincent3569 a écrit:

je parlais de l'affichage des images qui n'est pas affecté par un tri manuel autre que rank.

Je ne comprends toujours pas. :-(

VDigital
2010-04-16 07:59:05

Hormis le fait que le tri par rang est forcé dès qu'on valide les changements effectués, pourrais-tu nous dire si le résultat final (affichage dans la galerie) est différent de la 2.0.9.
Pour moi, le comportement est identique.
Le rang est un tri comme un autre.

On peut une fois les images reclassées rechanger le tri de la catégorie en Date de création et Rang si nécessaire.
Mais la validation de la page de reclassement force le tri sur un seul critère le rang.

vincent3569
2010-04-15 23:42:16

nicolas a écrit:

vincent3569 a écrit:

c'est OK : quand on trie manuellement les photos, on passe bien au tri "rank" et l'affichage de la galerie est bien correct.

en revanche : quel est le comportement de Piwigo si je rechange le tri (date d'ajout par ex) ?
en l'état :
  - l'affichage de la galerie prend bien en compte ce nouvel ordre d'affichage
  - le rang des images ne s'en ai pas trouvé modifié : si je retourne sur le tri des images, je retrouve mon tri manuel initial, alors que j'ai changé de méthode de tri entre temps...

je trouve que c'est assez confusant : j'aurais imaginé que le rang était mis à jour en fonction de la méthode de tri appliquée, quitte à modifier ce rang manuellement.

Peux-tu préciser ce qui ne fonctionne pas qu'on tu l'imagines ? De quelle manière as-tu changé l'ordre d'affichage ? Si tu l'as bien changé depuis la page de modification de la catégorie (admin.php?page=cat_modify&cat_id=NN) quand tu retournes sur la page de tri l'ordre choisi est bien gardé.

je parlais de l'affichage des images qui n'est pas affecté par un tri manuel autre que rank.

nicolas
2010-04-13 23:42:30

vincent3569 a écrit:

c'est OK : quand on trie manuellement les photos, on passe bien au tri "rank" et l'affichage de la galerie est bien correct.

en revanche : quel est le comportement de Piwigo si je rechange le tri (date d'ajout par ex) ?
en l'état :
  - l'affichage de la galerie prend bien en compte ce nouvel ordre d'affichage
  - le rang des images ne s'en ai pas trouvé modifié : si je retourne sur le tri des images, je retrouve mon tri manuel initial, alors que j'ai changé de méthode de tri entre temps...

je trouve que c'est assez confusant : j'aurais imaginé que le rang était mis à jour en fonction de la méthode de tri appliquée, quitte à modifier ce rang manuellement.

Peux-tu préciser ce qui ne fonctionne pas qu'on tu l'imagines ? De quelle manière as-tu changé l'ordre d'affichage ? Si tu l'as bien changé depuis la page de modification de la catégorie (admin.php?page=cat_modify&cat_id=NN) quand tu retournes sur la page de tri l'ordre choisi est bien gardé.

ddtddt
2010-04-13 20:38:17

Gotcha a écrit:

@Vincent : (post:139886) tu as un problème quelque part. Vois ce que j'ai chez moi.

idem sur trunk j'ai bien le lien déconexion

Gotcha
2010-04-13 20:21:13

@Vincent : (post:139886) tu as un problème quelque part. Vois ce que j'ai chez moi.

Pied de page des forums

Propulsé par FluxBB

github twitter newsletter Faire un don Piwigo.org © 2002-2022 · Contact