Écrire une réponse

Veuillez écrire votre message et l'envoyer

Cliquez dans la zone sombre de l'image pour envoyer votre message.

Retour

Résumé de la discussion (messages les plus récents en premier)

Joel_C
2019-02-14 18:07:58

Ben voilà! Problème résolu. Les Tag créés sur Digikam apparaissent sur Piwigo et le tour est joué!
Merci!!

Joel_C
2019-02-12 09:38:10

Merci pour ce lien! Une vrai mine!!!
Je creuse de ce pas! ;)

ddtddt
2019-02-12 06:53:44
Joel_C
2019-02-11 22:31:33

Bonsoir, je suis un utilisateur, ancien de Digikam (antérieur à la version 1.0) mais un newbie tout frai de Piwigo.
L'installation du logiciel sur un espace dédié à mes albums photos date de samedi 9 février 2019. < pub>, mon hébergeur est la coopérative Ouvaton </pub>

http://frontwins.fr/Photos/

J'ai téléchargé quelques albums "pour voir" sur mon espace à partir du plug'in Digikam et cela fonctionne bien: en direct ou redimensionnement des photos. Cependant, même si le plugin détecte les métadonnées pendant le téléchargement, aucune ne semble exportée dans Piwigo une fois les photos en ligne. Ni dans mon espace administration, ni visible par les visiteurs.

Me faut il installer une extension adaptée? J'en ai trouvé quelques unes
- La première semble s'adresser aux utilisateurs de feu Picasa (que je trouvais bien foutu à l'époque).
- La seconde intitulée "Advanced Metadata" a sa version la plus récente qui date de 2012. Je ne suis pas sur qu'elle soit adaptée à la version actuelle de Piwigo.
- La troisième "Write Metadata", travaille dans le sens contraire à celui souhaité. Il écrit les méta données issues de Piwigo dans l'image.

quelqu'un aurait une idée à me suggérer?

fcoiffie
2018-02-28 09:43:45

Merci lexapiwi !
Même si j'ai été à l'origine du plugin, j'avoue que c'est l'équipe Digikam qui le maintient pour le garder fonctionnel.
Il faut savoir que le plugin permet également de transférer des vidéos.

Dans les principales demande que j'avais eu, je me souviens d'une demande de pouvoir gérer plusieurs comptes/sites ainsi que de pouvoir créer des albums directement à partir du plugin.

Son code source est accessible ici : https://cgit.kde.org/kipi-plugins.git/tree/piwigo

lexapiwi
2018-02-27 23:29:35

Hello tout le monde !

Tout d'abord un très grand merci à toi fcoiffie. Ton plugin fonctionne à merveille. Je peux uploader des photos avec leur commentaire. Top top.

Dans Digikam et Piwigo, il est possible de rajouter au niveau d'un album. Cette information est je trouve très utile. Elle permet de resituer le contexte en quelques lignes. Pourvoi uploader à la fois les commentaires des photos ainsi que celui de l'album serait top.

Je souhaiterai rejeter un oeil sur le source et essayer de voir si je ne pourrai pas le faire évoluer dans la limite de mes compétence bien sur. Ou est ce que je pourrais je le trouver ?

isaric
2013-04-17 09:33:28

fcoiffie a écrit:

Peux-tu essayer d'envoyer une photo en la redimensionnant (au niveau du plugin Digikam) ?

La photo ("B") a bien été redimensionné 279,6 ko.


Une bizarrerie sur les miniatures, je t'envoie un lien...
La galerie contient 2 photos A.jpg "d'origine" et B.jpg "copie de A", mais lors de l'envoi avec le plugin  j'ai demandé le redimensionnement. Cette fois j'ai la photo et la miniature, mais lorsque je clique sur cette photo pour la voir plus large dans les données de droite (exif...), je ne vois pas la petite miniature, par contre je la vois en pour A.jpg ?

édit :
Cela ne doit pas être une bizarerie, c'est seulement la photo précédente ou suivante qui sont proposées.

Maintenant le plugin marche bien !

fcoiffie
2013-04-16 22:27:35

Pour le caractère '&', je pense que tu es tombé sur un bug de mon plugin et tu dois donc être le premier à utiliser ce caractère dans le login/mot de passe... Va falloir que je regarde et que je corrige ça...

Pour la photo qui a été uploadée, donc, non, ce n'est pas normal qu'elle n'apparaisse pas...
Peux-tu essayer d'envoyer une photo en la redimensionnant (au niveau du plugin Digikam) ?

isaric
2013-04-16 21:29:38

Je peux effectivement me connecter si je change mon nom d'administrateur, si j'enlève le caractère

Code:

&

édit :
Je rencontre ensuite un problème. La photo se trouve bien dans /upload/2013/04/16 (3,6 Mo).
La photo envoyé n’apparaît pas et pas de miniature également.
Les infos du genre exif apparaissent.

Est-ce normal ?

fcoiffie
2013-04-16 17:11:53

Donc, ce sont bien des versions récentes pour lesquels tout devrait marcher correctement...

Une dernière idée : si les login/mot de passe contiennent des caractères particuliers pourrais-tu les modifier pour un test en n'utilisant que des lettres(maj/min) et des chiffres ?
C'est juste pour un test (au cas où un caractère serait mal transmis).

isaric
2013-04-15 12:10:28

fcoiffie a écrit:

Et l'utilisateur utilisé est également bon ?

Oui tout a été fait par copier/coller, aussi, avant d'envoyer la demande de connexion digikam j'ai déconnecté ma session piwigo.

fcoiffie a écrit:

Tu utilises quelle version...?

digikam 4:2.8.0-0ubuntu1
et piwigo-2.5.0.zip

fcoiffie
2013-04-15 11:58:38

Et l'utilisateur utilisé est également bon ? Tu utilises quelle version de Piwigo ?

isaric
2013-04-15 11:23:27

flop25 a écrit:

@isaric
est-ce que la connexion à la partie admin de Piwigo se fait bien ?

Oui sans problème.
Pour limiter l'erreur de saisie de mot de passe, j'ai collé mon MdP pour ouvrir une section admin. sur piwigo, ensuite j'ai collé le même MdP sur exportation/plugin digikam. Mais cela ne change rien au résultat.

flop25
2013-04-15 11:01:13

@isaric
est-ce que la connexion à la partie admin de Piwigo se fait bien ?

fcoiffie
2013-04-15 09:29:08

A priori, la connexion à la gallerie Piwigo fonctionne bien.
Par contre, elle retourne une erreur 999 avec Invalid username/password.

J'ai notifié plg qui aura peut-être une idée sur la cause du problème.

Pied de page des forums

Propulsé par FluxBB

github twitter facebook newsletter Faire un don Piwigo.org © 2002-2019 · Contact