Annonce

Écrire une réponse

Veuillez écrire votre message et l'envoyer

Cliquez dans la zone sombre de l'image pour envoyer votre message.

Retour

Résumé de la discussion (messages les plus récents en premier)

Xavier MDF
2009-08-21 18:06:47

Gotcha a écrit:

Sans thé pour moi, merci.

Merci de passer le sujet en [Résolu] via ton premier message ;-)

Oups 'scuse !

Ce n'est pas moi qui est lancé le topic donc je ne peux pas le résoudre.
A tantot

Gotcha
2009-08-21 00:34:30

Xavier MDF a écrit:

[...]En tout cas je remercie Ddtddt, Gotchat et les autres pour leur aide :)

Sans thé pour moi, merci.

Merci de passer le sujet en [Résolu] via ton premier message ;-)

Xavier MDF
2009-08-20 23:40:58

Youou !!!
ça fonctionne !!!!!
J'avais oublié que j'avais modifier le fichier mysql.inc.php. J'ai effacé les données et du coup l'installation c'est lancé !
Enfin je comprend toujours pas pourquoi ça bloquait auparavant !!

En tout cas je remercie Ddtddt, Gotchat et les autres pour leur aide :)

Affaire à suivre, je vous préviendrai quand je l'aurai pris en main et remplis.

A tantot donc
Xav

Xavier MDF
2009-08-20 22:38:16

Gotcha a écrit:

- * Pour commencer donc, supprimes tes anciens fichiers Piwigo.
OK C EST FAIT.

- * Ensuite, supprimes toutes les tables associées dans ta BDD.
IL N Y AVAIS RIEN DONC JE NAI RIEN FAIS.

- * A présent, sur ton ordi, tu vas créer deux fichiers texte. Un nommé info.txt et l'autre httaccess.txt
POUR INFO.PHP JE L AI CREER AVEC NOTEPAD ET .HTACCESS JE L AVAIS DEJA.

-    o Envoie ces fichiers sur ton serveur à la racine.
OK

-    o Renommes le fichier httaccess.txt en .httaccess (oui, avec le point devant).
DEJA FAIT

- * A la racine de ton serveur, créés un dossier nommé "sessions".
DEJA FAIT

- * L'installation de Piwigo se fera dans un autre dossier que tu nommeras comme bon te semble. (Je préconise un installation dans un sous dossier afin de ne pas être limité pour une page d'accueil externe à Piwigo)
OK

- * Maintenant, envois tes fichiers d'installation de Piwigo dans ton sous dossier.
OK

- Lances l'installation.
PLUS OK VOILA LE RESULTAT : http://mdfphoto.free.fr/photo

Je n'ai toujours rien dans ma BD.
A suivre...

Gotcha
2009-08-19 10:55:39

Chez Free il est vrai que c'est parfois un peu plus compliqué mais on a toujours réussi à faire tourner Piwigo, donc on va commencer par le commencement (y a pas de raison que ça ne fonctionne pas ^^).

- * Pour commencer donc, supprimes tes anciens fichiers Piwigo.
- * Ensuite, supprimes toutes les tables associées dans ta BDD.
- * A présent, sur ton ordi, tu vas créer deux fichiers texte. Un nommé info.txt et l'autre httaccess.txt
-    o Dans info.txt tu écris:

Code:

<?php
// Affiche toutes les informations serveur.
phpinfo();
?>

Renommes le fichiers avec l'extention .php
Ce fichier nous servira au cas où...
-    o Dans httaccess.txt tu écris:

Code:

php 1

-    o Envoie ces fichiers sur ton serveur à la racine.
-    o Renommes le fichier httaccess.txt en .httaccess (oui, avec le point devant).
- * A la racine de ton serveur, créés un dossier nommé "sessions".
- * L'installation de Piwigo se fera dans un autre dossier que tu nommeras comme bon te semble. (Je préconise un installation dans un sous dossier afin de ne pas être limité pour une page d'accueil externe à Piwigo)
- * Maintenant, envois tes fichiers d'installation de Piwigo dans ton sous dossier.
- Lances l'installation.

;-)

Xavier MDF
2009-08-19 09:08:12

Gotcha a écrit:

Ta galerie comport-elles beaucoup de photos ?

Si tu n'en a pas, alors tu effaces tous tes fichiers et ta Base De Données. Tu réinstalles proprement maintenant :-)

Je n'ai jamais pu mettre de photo étant donné que ça n'a jamais fonctionné. J'ai déjà fais plusieurs réinstallations avec ou sans dossier à la racines...
J'aimerai savoir si je dois créer manuellement des tables dans myphpadmin du serveur puisque rien ne s'installe automatiquement ?

Merci

Gotcha
2009-08-18 23:02:32

Ta galerie comport-elles beaucoup de photos ?

Si tu n'en a pas, alors tu effaces tous tes fichiers et ta Base De Données. Tu réinstalles proprement maintenant :-)

Xavier MDF
2009-08-18 17:41:25

Bonjour,

C'est toujours moi !
Bon je sais plus quoi faire...............
voila mon site : mdfphoto.free.fr (si vous êtes fan des messages d'erreurs et si vous savez les décrypter!)

Moi je perds un peu espoir.... pourquoi ça ne fonctionne pas chez moi ????

Gotcha
2009-08-17 20:37:51

Si ta galerie est vide, alors, une simple réinstallation suffira.

flop25
2009-08-17 13:04:54

Xavier MDF a écrit:

Alors j'ai renommé le dossier "sessions" en piwigo car effectivement j'avais laissé "$prefixeTable = 'piwigo_'".

lu
le dossier "sessions" doit être présent à la racine du site !
prefixeTable  correspond simplement au préfixe des tables mysql de piwigo

Si tu n'as pas ces tables c'est que lors de l'installation tu n'as pas précisé de préfixes ou mis un autre

(à la limite tu devrais donner les clé du ftp à un memebre de la team pour t'installer celà normalement ...)
et je précise que oui localhost marche sur free

Xavier MDF
2009-08-17 12:16:37

Alors j'ai renommé le dossier "sessions" en piwigo car effectivement j'avais laissé "$prefixeTable = 'piwigo_'".
Maintenant je n'ai plus l'erreur 403 mais pleins d'autre. La première :

"Warning:  [mysql error 1146] Table 'mdfphoto.piwigo_config' doesn't exist
SELECT param, value
FROM piwigo_config
; in /mnt/142/sda/5/d/mdfphoto/piwigo/include/functions.inc.php on line 918"....

Dans phpmyadmin sur sql.free.fr je n'ai pas de table. Dois-je les créer ?

Gotcha
2009-08-17 11:42:27

Le préfixe de tes table c'est le champs $prefixeTable = 'piwigo_';

Donc dans ta base de données, regardes tout simplement par quoi commence le nom de toutes tes tables. Si ça ne commence pas par "piwigo_" alors note ce que tu as dans ta BDD et modifie ton fichier mysql.inc.php

Mais ça ne résoudra pas le problème de l'erreur 403, du moins, ça m'étonnerai...

Xavier MDF
2009-08-17 11:04:19

De retour de weekend.
J'ai repris les essais :
- j'ai retéléchargé les fichiers,
- ajouté le fichier .htacces
- modifier le fichier mysql...
-créer un dossier sessions à la racine du site
- puis tout transférer par fillezila
et j'obtiens :

"Erreur 403 - Refus de traitement de la requête (Interdit - Forbidden)



Le serveur a compris la requête, mais refuse de la satisfaire.

Une démarche d'authentification n'y fera rien et cette requête ne doit pas être renouvelée. Si la méthode invoquée est différente de HEAD et le serveur souhaite rendre public la raison pour laquelle il refuse le traitement, il le fera dans l'entité liée à cette réponse. Ce code d'état est souvent utilisé lorsque le serveur ne souhaite pas s'étendre sur les raisons pour lesquelles il refuse un accès, ou parce que c'est la seule réponse qui convienne.

Vous tentez d'accéder à une ressource qui vous est interdite.
Il se peut que le compte concerné soit suspendu (Cf. Console de Gestion) "

Voila où j'en suis. Ddtddt tu m'as parler de préfixe de table, je ne sais pas comment les créer dans ma base.
Si vous pouvez continuer à m'aider dans l'installation de pwg je vous en remercie fortement !
A tantot
Xav

Xavier MDF
2009-08-13 10:28:27

ddtddt a écrit:

(tu devrais t'inscrire sur le forum, cela permettrai de t'abonner à la discussion et de recevoir un mél quand il y a une réponse ;-))

C'est fait merci
Je vais partir 4 jours sans ordi donc je reprendrais tout ça lundi.
A tantot
XAv

Xavier MDF
2009-08-13 10:21:11

ddtddt a écrit:

Tu vas également créer un répertoire sessions à la racine de ton site

Ok c'est fait.


ddtddt a écrit:

Tu utilises quoi comme logiciel ?

(est ce que tu mets bien un préfixe de table ?

J'utilise Filezilla. Je ne sais pas comment on met un préfixe de table donc je ne le fais pas !

Pied de page des forums

Propulsé par FluxBB

github twitter newsletter Faire un don Piwigo.org © 2002-2022 · Contact