Annonce

Écrire une réponse

Veuillez écrire votre message et l'envoyer

Cliquez dans la zone sombre de l'image pour envoyer votre message.

Retour

Résumé de la discussion (messages les plus récents en premier)

P@t
2012-01-21 23:17:25

Zaphod a écrit:

Petite question.
Quand on utilise la balise [cat=xx], c'est forcément le template cat.tpl présent dans le plugin qui est utilisé ?
Ou il y a moyen d'imposer un template par le thème (un peu comme dans PWG stuffs ) ?

Oui, c'est le template par défaut... mais on peut facilement imaginer le même système que pour PWG Stuffs. D'autres plugins le font d'ailleurs.

Zaphod
2012-01-21 01:24:48

Petite question.
Quand on utilise la balise [cat=xx], c'est forcément le template cat.tpl présent dans le plugin qui est utilisé ?
Ou il y a moyen d'imposer un template par le thème (un peu comme dans PWG stuffs ) ?

P@t
2011-09-16 10:30:12

plg a écrit:

Je voudrais utiliser des balises [redirect http://...] mais sur des photos et non sur des albums. Histoire d'être redirigé vers une Additional Page quand on clique sur une miniature en fait, mais le [redirect] ne fonctionne pas sur la page picture. Pour quelle raison ? (je le vois bien dans le code, mais je ne comprends pas pourquoi il y a cette condition)

Hum, oui, je n'avais pas prévu d'utiliser cette balise sur une image... mais pourquoi pas, ça peut être intéressant.

plg
2011-09-15 22:28:05

Je voudrais utiliser des balises [redirect http://...] mais sur des photos et non sur des albums. Histoire d'être redirigé vers une Additional Page quand on clique sur une miniature en fait, mais le [redirect] ne fonctionne pas sur la page picture. Pour quelle raison ? (je le vois bien dans le code, mais je ne comprends pas pourquoi il y a cette condition)

P@t
2011-04-02 16:10:45

Je l'ai coché compatible 2.2.0

Eric
2011-04-02 15:56:39

Pour info : J'ai installé Extended Description sur une galerie 2.2.0 même s'il n'est pas donnée compatible. Et, a priori, tout semble bien se passer. Et je ne reproduis pas le pb de popup mentionné précédemment (c'est bien une popup qui s'ouvre).

Je n'ai pas testé toutes les fonctionnalités de ce plugin mais celles de base ([lang]) qui étaient actives sur ma galerie de test fonctionnent. Donc, sauf cas particulier, je pense que c'est OK pour Piwigo 2.2

Eric
2011-03-13 14:58:35

OK, vu !
Mais, là aussi, Extended Description n'est pas encore donné comme compatible 2.2.0-RCx. Donc c'est peut-être un peu normal. Attendre une mise à jour du plugin ;-)

Gotcha
2011-03-13 14:55:01

Je me suis mal exprimé.
Je parle de la balise d'aide à coté du champs à personnaliser (titre, description de l'image) et qui à la forme, l'allure, la couleur d'une balise d'aide de Piwigo mais qui est associée à Extended Description ^^

Eric
2011-03-13 14:04:26

Gotcha a écrit:

Sur la RC4, lorsque l'on clic sur la balise d'aide, au lieu d'ouvrir une pop-up la page vient en remplacement !

:-(

Euh... Et Extended Description là dedans ?

Gotcha
2011-03-13 13:47:36

Sur la RC4, lorsque l'on clic sur la balise d'aide, au lieu d'ouvrir une pop-up la page vient en remplacement !

:-(

plg
2010-12-31 11:37:40

P@t, pourrais-tu ajouter ce morceau de code dans Extended Description, histoire de ne pas purger les recherches utilisées dans un redirect :

Code:

add_event_handler('loc_begin_admin', 'purge_searches');
function purge_searches()
{
  if (isset($_GET['page']) and 'maintenance' == $_GET['page']
      and isset($_GET['action']) and 'search' == $_GET['action'])
  {
     $searches_to_save = array();
     
     $query = '
SELECT
    id,
    comment
  FROM '.CATEGORIES_TABLE.'
  WHERE comment LIKE \'%[redirect search=%\'
;';
     $result = pwg_query($query);
     while ($row = pwg_db_fetch_assoc($result))
     {
        if (preg_match('/redirect search=(\d+)/', $row['comment'], $matches))
        {
          array_push($searches_to_save, $matches[1]);
        }        
     }
     
     $query = '
DELETE
  FROM '.SEARCH_TABLE.'
  WHERE id NOT IN ('.implode(',', $searches_to_save).')
;';
    pwg_query($query);
    
    $redirect_url = get_root_url().'admin.php?page='.$_GET['page'];
    redirect($redirect_url);
  }
}
Zaphod
2010-12-28 00:04:18

En fait il faudrait pouvoir forcer l'affichage d'une catégorie vide.
Le contraire de <!--hidden--> en quelque sorte

Gotcha
2010-12-27 19:55:25

Zaphod a écrit:

Petite question, si on crée une catégorie ping pong de la sorte, il faut toujours que la catégorie ne soit pas vide au départ pour qu'elle soit affichée ?

Je n'ai pas vérifié mais il serait logique que la catégorie ne soit pas visible car le contenu (les photos) sont toujours absentes...

Zaphod
2010-12-27 19:38:49

Petite question, si on crée une catégorie ping pong de la sorte, il faut toujours que la catégorie ne soit pas vide au départ pour qu'elle soit affichée ?

Gotcha
2010-12-27 19:21:33

Merci P@t pour l'implémentation ;-)

Pied de page des forums

Propulsé par FluxBB

github twitter newsletter Faire un don Piwigo.org © 2002-2022 · Contact