Annonce

Écrire une réponse

Veuillez écrire votre message et l'envoyer

Cliquez dans la zone sombre de l'image pour envoyer votre message.

Retour

Résumé de la discussion (messages les plus récents en premier)

grum
2011-06-13 21:38:48

le fichier ./local/css/astat.css existe ?

galixte
2011-06-11 13:42:57

Bonjour,

après la mise à jour de Piwigo 2.1.2 vers 2.2.3 pour ma galerie ainsi que de la dernière version de ce plugin, voici le message qui m'est retourné sous l'interface de gestion de AStat :

Code:

Warning: fopen(./local/css/astat.css) [function.fopen]: failed to open stream: Permission denied in /photos/plugins/GrumPluginClasses/classes/GPCCss.class.inc.php on line 83

Warning: filemtime() [function.filemtime]: stat failed for ././local/css/astat.css in /photos/include/template.class.php on line 1278

Merci de votre soutient.

Galixte.

grolourdo
2011-05-17 20:11:03

parfait merci

grum
2011-05-17 18:53:48

oula...
AStat 2.3.0a, tu as été le cherché sur mon dépôt de test.
Effectivement, sur ce dépôt les versions de Piwigo ne sont pas forcément à jour (mais généralement, dans une branche x.y.z, si le plugin est compatible avec x.y il le sera normallement avec toutes les versions z qui y sont rattachées)

Le plugin est disponible en version 2.3.0 sur le dépôt officiel, il est plus que recommandé :
- d'utiliser les versions du dépôt officiel
- de n'utiliser les versions de tests que sur des galeries de test

grolourdo
2011-05-17 11:58:37

bonjour

je l'ai installé sur ma gallery 2.2.1, astat2 2.3.0a, pas de souci fonctionne nikel. pas contre pas référencé compatible piwigo2.2.1:(

bonne journée

grum
2011-04-25 17:55:52

La version 2.3.0 du plugin est disponible dans le dépôt.

Elle apporte la compatibilité avec Piwigo 2.2

tibtib17
2009-11-26 23:15:21

Bonjour, moi aussi j'ai l'erreur :

Smarty error: unable to read resource: ".../plugins/AStat/admin/astat_admin.tpl" in .../include/smarty/libs/Smarty.class.php on line 1093

J'ai fait une maj automatique, j'ai testé de désinstaller et réinstaller via l'interface admin web, toujours le même problème. J'ai PWG 2.0.6.

Du coup, j'ai téléchargé et installé manuellement et ça a marché. :/

cljosse
2009-11-17 15:41:44

Bah non c'est pas gagné j'étais encore sur la version en piwigo 2.0.5 :-(

Par contre si je commente les lignes suivantes dans le fichier Galerie\admin\include\plugins.class.php:
/*
              if (file_exists($extract_path.'/obsolete.list')
                and $old_files = file($extract_path.'/obsolete.list', FILE_IGNORE_NEW_LINES)
                and !empty($old_files))
              {
              
                array_push($old_files, 'obsolete.list');
                foreach($old_files as $old_file)
                {
                  $path = $extract_path.'/'.$old_file;
                  if (is_file($path))
                  {
                    @unlink($path);
                  }
                  elseif (is_dir($path))
                  {
                    if (!$this->deltree($path))
                    {
                      $this->send_to_trash($path);
                    }
                  }
                }
             
              }
*/
Comme cela était dans la version PIWIGO 2.0.5 la c'est ok. ???

  Le fichier obsolete.list doit il etre présent dans le fichier Zip ???


A+

cljosse
2009-11-17 15:31:17

Ok j'ai trouvé le problème.
En modifiant le fichier Galerie\admin\include\functions.php
comme ceci :
Dans la fonction function fetchRemote(

j'ai rajouté une tempo

line 1964    $timeout=300;
  // Try curl to read remote file
  if (function_exists('curl_init'))
  {
line 1968      $ch = @curl_init();
line 1969      @curl_setopt($ch, CURLOPT_TIMEOUT, $timeout);
line 1970     @curl_setopt($ch, CURLOPT_URL, $src);

Et j'ai  maintenant j'ai bien l'ensemble des fichiers....

A+

cljosse
2009-11-17 10:15:25

Suite....
  Le problème est en version PIWIGO 2.0.6 et non en Version PIWIGO 2.0.5.

   A+

cljosse
2009-11-17 09:35:33

Bonjour.

Effectivement tout à l'air correct.
  Procédure utilisée:

Version piwigo 2.0.6
Utilisation en local avec EasyPhp 3.0, WampServer, EasyPHP 5.3 sur plusieurs Galeries, sinon sur mes sites distants c'est ok.



   Onglet Plugins/Vérifier les mise à jour
           Astat.2
  AStat.2 2.1.0 2.1.1 Mise à jour automatique / Télécharger le fichier

Je clique sur "Mise à jour automatique "
  Je répond OK à la boite de dialogue
Le message info : AStat.2 a été mis à jour avec succès.

Retour sur la liste des plugins
AStat.2      2.1.1 Statistiques avancées (grum@piwigo.org)

J'installe le plugin, je l'active , tout est normal.
Mais lorque je veux modifier la config problème les fichier *.tpl sont absents... d'ou:
Warning: Smarty error: unable to read resource: "C:\Users\Claude\Documents\web\cuiselamotte.free.fr\Galerie\plugins\AStat/admin/astat_admin.tpl" in C:\Users\Claude\Documents\web\cuiselamotte.free.fr\Galerie\include\smarty\libs\Smarty.class.php on line 1093

Vraiment je ne comprend pas!
    J'ai supprimé completement le plugin et installé depuis "Autre plugins disponibles" la sanction est la même.
J'ai téléchargé et dézippé le plugin , la c'est ok, tous les fichiers sont présents.

  Poursuivant mon investigation j'ai édité le fichier main.inc.php, passé la version manuellement à 2.1.0
  J'ai refait une mise à jour, et les fichiers ont de nouveau disparus.

J'ai vérifié avec d'autre plug-ins que AStat, tout est OK.
   
Mais à part ce problème en local le plug-in marche bien.


A+

grum
2009-11-16 21:11:39

je ne comprends pas trop.
l'archive déposée dans les extensions me semble complète...

comment as-tu procédé pour la mise à jour ?

cljosse
2009-11-16 12:21:26

Bonjour.

Suite a une mise à jour (passage de la version 2.1.0 a 2.1.1 (en local) )
Voici les message affichés:

Warning: Smarty error: unable to read resource: "C:\Users\Claude\Documents\web\cl.josse.free.fr\GTEST\plugins\AStat/admin/astat_admin.tpl" in C:\Users\Claude\Documents\web\cl.josse.free.fr\GTEST\include\smarty\libs\Smarty.class.php on line 1093

Warning: Smarty error: unable to read resource: "C:\Users\Claude\Documents\web\cl.josse.free.fr\GTEST\plugins\AStat/admin/astat_admin.tpl" in C:\Users\Claude\Documents\web\cl.josse.free.fr\GTEST\include\smarty\libs\Smarty.class.php on line 1093

Quand je regarde dans le répertoire :
C:\Users\Claude\Documents\web\cl.josse.free.fr\GTEST\plugins\AStat/admin
les fichiers *.tpl manque  !.
Un oublie quelque part ?.

A+

Si je télécharge et dézippe l'extension c'est ok... ???

makno
2009-11-16 08:39:22

Merci pour l'intervention, mais Je viens de l'installer,et je ne peux toujours pas utiliser l'outil de purge

grum
2009-11-16 00:35:14

La version 2.1.1 qui corrige le bug est dispo dans les extensions.

Pied de page des forums

Propulsé par FluxBB

github twitter newsletter Faire un don Piwigo.org © 2002-2022 · Contact