Annonce

Écrire une réponse

Veuillez écrire votre message et l'envoyer

Cliquez dans la zone sombre de l'image pour envoyer votre message.

Retour

Résumé de la discussion (messages les plus récents en premier)

Eric B
2014-09-21 17:47:20

l export KML, c est géré par le plugin ou par l API Google?
Serait il possible d avoir un export GPX aussi?
Cas d utilisation: album geo taggé sur une rando -> l utilisateur exporte le gpx pour le mettre sur son appareil (ex smartphone) pour pouvoir refaire cette rando.
Solution actuelle: passer par des outils tiers pour convertir le KML en GPX.

JlJulien
2012-08-26 00:44:23

Juste en passant pour dire à rvelices que ce plugin est génial. Exactement ce que je cherchais. C'est par lui que je suis arrivé sur piwigo. Donc, heu, ben: merci!

Neutre
2010-12-06 21:19:40

J'ai essayé ce soir, sans succès.
Paut être un pb javascript comme le pense rvelices.
Sinon, je n'ai quasiment touché à rien et quand je remets le fichier picture_map-content.tpl d'origine, le problème est le même (je n'ai modifié que mapTypeId: google.maps.MapTypeId.SATELLITE au lieu de ROADMAP)

cljosse
2010-12-06 13:21:27

Neutre a écrit:

Bonjour,

J'ai un souci avec l'affichage du pointeur.
La transparence a disparu sur la carte "photo" alors que sur la vue "Galerie" l'affichage est correct.
J'ai rechargé le jeu d'icône au cas où il y aurait eu un problème. Sans résultat.
Par exemple là : http://www.lesphotosdejean.fr/picture.p … 00&map
Auriez vous une idée ?

Bonjour.
Code à essayer: dans rules.css

Code:

.gmnoprint {
    background-color: transparent;
}

A+

rvelices
2010-12-06 07:22:14

Neutre a écrit:

J'ai un souci avec l'affichage du pointeur.
La transparence a disparu sur la carte "photo" alors que sur la vue "Galerie" l'affichage est correct.
J'ai rechargé le jeu d'icône au cas où il y aurait eu un problème. Sans résultat.
Par exemple là : http://www.lesphotosdejean.fr/picture.p … 00&map
Auriez vous une idée ?

D'apres moi c'est du soit a d'autres plugins soit aux modifs que vous auriez fait. Je dirais que c'est un pb. de javascript

Neutre
2010-12-05 18:13:24

Bonjour,

J'ai un souci avec l'affichage du pointeur.
La transparence a disparu sur la carte "photo" alors que sur la vue "Galerie" l'affichage est correct.
J'ai rechargé le jeu d'icône au cas où il y aurait eu un problème. Sans résultat.
Par exemple là : http://www.lesphotosdejean.fr/picture.p … 00&map
Auriez vous une idée ?

rescator
2010-03-18 20:10:50

merveilleux...

je suis arrivé à obtenir EXACTEMENT ce que je désirais.

Merci pour l'aide et la réactivité

cljosse
2010-03-18 08:24:52

rescator a écrit:

....mais j'ai pu apporter qqs modifs... grace au wiki.
Par contre je ne lis aucune info au sujet du zoom avec la molette souris sur les cartes "photo"...

Bonjour.

Il suffit d'ajouter dans le template:picture_map_content.tpl
   dans la fonction onLoad
      après l'affectation  de map
le code ci-dessous:
map.addControl(new GLargeMapControl3D(), new GControlPosition(G_ANCHOR_TOP_LEFT, new GSize(20,40)));

Code:

  map.enableScrollWheelZoom();

//  map.addControl(new GLargeMapControl());

A+

rescator
2010-03-17 23:53:21

oui mis a part que je ne comprend pas tout.  ;-)

mais j'ai pu apporter qqs modifs... grace au wiki.

Par contre je ne lis aucune info au sujet du zoom avec la molette souris sur les cartes "photo"...

Gotcha
2010-03-17 22:37:40

Bonsoir,

Un petit tour dans le [wiki] devrait vous aider ;-)

rescator
2010-03-17 21:43:13

bonjour,
je tenais, pour commencer à féliciter toutes les personnes qui font avancer PIWIGO que j'ai découvert il y a 1 mois et que j'ai adopté de suite, après avoir testé une ribambelle de galerie.

Voila mes questions :
quand je clique sur Google map depuis une galerie : http://photos.web-alsace.net/index.php?/category/51

j'ai l'affichage d'une carte en mode "plan", j'aimerais que l'affichage se fasse en mode " mixte"

Est-ce possible ? si oui, comment ?

la seconde :
quand je suis sur une photo de cette galerie : http://photos.web-alsace.net/picture.ph … ategory/51
et que je clique sur google map, toujours même problème, j'aimerai le mode " mixte" et surtout un "zoom" un peu plus puissant.
et cerise sur le gâteau, sur la carte affichée depuis une galerie, on peut zoomer avec la molette de la souris, mais sur une carte affichée depuis une photo, la molette ne fonctionne pas.
Si quelqu'un(e) avait une idée... Je suis preneur

en vous remerciant d'avance pour vos réponses éclairées

(les photos de cette galerie ne valent rien. je le sais... c'était juste une balade de test avec mon logueur GPS et mon appareil photo pour essayer la synchro entre les deux) ;-)

cljosse
2010-03-09 06:57:18

mtgt a écrit:

AArghhh!!

Tant pis, je laissse comme c'est !
ça marche comme ça maintenant

Je ferais les changement au prochain update de RV Maps & Earth si ce n'est pas inclus! ;)

Sinon, j'ai remarqué autre chose :P
Lorsque j'ouvre la galerie (page d'accueil) il n'y a pas les icons du plugin RV Maps & Earth !
Pour les avoir, il faut que je rafraichisse la page, bizarre non!

Bonjour.
Je suis allé voir sur ta page d'acceuil, les liens du plugin sont bien présents.



Tu as raison, de ne pas remodifié pour l'instant, je n'ai pas testé à fond la nouvelle solution.
   Il semblerait que certaines fonctionalités du plugin ne marchent pas avec l'Api ajax loader.

A+

mtgt
2010-03-08 21:31:16

AArghhh!!

Tant pis, je laissse comme c'est !
ça marche comme ça maintenant

Je ferais les changement au prochain update de RV Maps & Earth si ce n'est pas inclus! ;)

Sinon, j'ai remarqué autre chose :P
Lorsque j'ouvre la galerie (page d'accueil) il n'y a pas les icons du plugin RV Maps & Earth !
Pour les avoir, il faut que je rafraichisse la page, bizarre non!

cljosse
2010-03-08 15:03:13

Une autre méthode existe pour pouvoir utiliser la mini carte avec le bouton 3D Earth:

Utiliser  Google Ajax API Loader.
   Je ne connais pas les effets de bord de l'Ajax API Loader.
Mais je donne quand même la procédure pour ajouter le bouton 3D avec Google Ajax API Loader.

Restaurer la dernière version de rv_gmaps.

Ajouter le code dans map.tpl et picture_map_content.tpl après la denier lien "css".

<link href="{$PLUGIN_ROOT_URL}/template/windows_13/themes/alphacube.css" rel="stylesheet" type="text/css" />

Code:

<script src="http://www.google.com/jsapi?key={$GMAPS_API_KEY}" type="text/javascript" ></script>
<script type="text/javascript">
var mylang={ldelim}"language" :"{$lang_info.code}"};
{literal}
google.load("maps", "2.160", mylang );

ensuite ajouter le code bouton earth apres :

    var map = new GMap2( mapElement );  si   picture_map_content.tpl
ou         map = new GMap2( mapElement );  si map.tpl

Code:

  map.addMapType( G_PHYSICAL_MAP );
  map.addMapType(G_SATELLITE_3D_MAP);

map.addControl(new GLargeMapControl3D());

Pourquoi faire compliquer quand on peu faire simple :-)


A+
|edit] Je fais les tests avant de valider cette solution. en attendant, la solution précédente me semble plus souple.[/edit]

Gotcha
2010-03-08 12:37:06

Merci, je regarde dès que j'ai un moment à y consacrer.

;-)

Pied de page des forums

Propulsé par FluxBB

github twitter newsletter Faire un don Piwigo.org © 2002-2020 · Contact