•  » Installation
  •  » [Résolu] mise à jour ne fonctionne pas (SFR)

#1 2010-05-19 10:20:58

samuel
Invité

[Résolu] mise à jour ne fonctionne pas (SFR)

Bonjour,

je suis hébergé sur SFR, et je n'arrive pas à faire la mise à jour vers le 2.1.

En cliquant sur "Administration > Spéciales > Plugins >  Autres plugins disponibles", je tombe sur l'erreur: 500 Internal server error.
J'installe donc le plugins Piwigo AutoUpdgrade manuellement. installation ok, mais quand je clique dessus, je tombe à nouveau sur cette fichue erreur 500.

Pas découragé pour un sous, je me lance dans la mise à jour manuelle (http://fr.piwigo.org/basics/upgrade_manual). Là, je bute à l'étape 3: si j'ouvre upgrade.php, comme indiqué, j'ai le message suivant: No upgrade required, the database structure is up to date.
Si j'ouvre prep21up.php comme suggéré, ca m'affiche tout un tas de warning:
Warning: php_uname() has been disabled for security reasons in /var/www/s/sa/sam/samuel.ronayette.perso.sfr.fr/public_html/photos/prep21up.php  on line 4
Warning: Cannot modify header information - headers already sent by (output started at /var/www/s/sa/sam/samuel.ronayette.perso.sfr.fr/public_html/photos/prep21up.php:4) in /var/www/s/sa/sam/samuel.ronayette.perso.sfr.fr/public_html/photos/prep21up.php on line 234

Des idées? Le probleme vient-il de mon hébergeur?

Merci pour vos conseils

Samuel

#2 2010-05-19 10:24:42

VDigital
Former Piwigo Team
Paris (FR)
2005-05-04
15124

Re: [Résolu] mise à jour ne fonctionne pas (SFR)

Warning: php_uname() has been disabled for security reasons

Merci SFR...

:-/


Vincent -« Plus vidéaste averti que photographe amateur... »
La galerie - Le blog   

Piwigo est une application libre de gestion de photos en ligne.

Hors ligne

#3 2010-05-19 10:29:56

samuel
Invité

Re: [Résolu] mise à jour ne fonctionne pas (SFR)

ok, merci... donc en gros, c'est une fonction php dont le script de mise à jour à besoin, mais que mon hebergeur refuse d'exectuer, c'est ca? donc il faut que j'aille voir ailleurs, ou que je fasse une réinstallation complete?

#4 2010-05-19 11:58:12

VDigital
Former Piwigo Team
Paris (FR)
2005-05-04
15124

Re: [Résolu] mise à jour ne fonctionne pas (SFR)

Personnellement, je te conseillerai un hébergement ailleurs.
Quand tu maîtriseras mieux Piwigo...
Tu penseras "Site distant" pour tenter d'utiliser l'espace disponible chez SFR.


Vincent -« Plus vidéaste averti que photographe amateur... »
La galerie - Le blog   

Piwigo est une application libre de gestion de photos en ligne.

Hors ligne

#5 2010-05-20 00:30:39

rimousky
Membre
Lyon (France)
2009-01-20
66

Re: [Résolu] mise à jour ne fonctionne pas (SFR)

Bonsoir Samuel

Je suis comme toi, hébergé par sfr, et j'ai exactement le même problème si on suit la procédure d'upgrade indiquée par nos amis de Piwigo, cela ne fonctionne pas, c'est l'hébergeur qui est en cause, mais pas de panique,  Il faut utiliser l'installation manuelle.
En effet les recettes standards de Piwigo pour l'installation n'ont jamais fonctionné chez sfr, pour ma première installation, j'ai ramé pendant pas mal de temps avant de découvrir cela. Mais en fin de compte on y arrive !
Je viens de faire le test sur un répertoire "Test" sur lequel j'ai réinstallé la nouvelle version de Piwigo, cela marche.

Bonne chance !

Dernière modification par rimousky (2010-05-20 00:35:34)


Velle parum est ; cupias ut se potiaris oportet.
Ma galerie,

Hors ligne

#6 2010-05-20 07:09:03

ddtddt
Équipe Piwigo
Quetigny (21) - France
2007-07-27
14450

Re: [Résolu] mise à jour ne fonctionne pas (SFR)

As tu essayé la procédure manuel de mise à jour -> http://fr.piwigo.org/basics/upgrade_manual


Vous aimez Piwigo alors n'hésitez pas à participer avec nous, plus d'infos sur la page "Contribuer à Piwigo". Si vous n'avez pas beaucoup de temps et que vous souhaitez nous soutenir vous pouvez aussi le faire par un don.

Hors ligne

#7 2010-05-20 08:44:13

VDigital
Former Piwigo Team
Paris (FR)
2005-05-04
15124

Re: [Résolu] mise à jour ne fonctionne pas (SFR)

rimousky a écrit:

Bonsoir Samuel

Je suis comme toi, hébergé par sfr, et j'ai exactement le même problème si on suit la procédure d'upgrade indiquée par nos amis de Piwigo, cela ne fonctionne pas, c'est l'hébergeur qui est en cause, mais pas de panique,  Il faut utiliser l'installation manuelle.
En effet les recettes standards de Piwigo pour l'installation n'ont jamais fonctionné chez sfr, pour ma première installation, j'ai ramé pendant pas mal de temps avant de découvrir cela. Mais en fin de compte on y arrive !
Je viens de faire le test sur un répertoire "Test" sur lequel j'ai réinstallé la nouvelle version de Piwigo, cela marche.

Bonne chance !

Installation manuelle... => Ok, c'est bon, mais la mise à jour qu'en est-il ?
SFR ferait mieux d'élargir ses offres que de brider son php, AMHA.


Vincent -« Plus vidéaste averti que photographe amateur... »
La galerie - Le blog   

Piwigo est une application libre de gestion de photos en ligne.

Hors ligne

#8 2010-05-20 10:33:31

rimousky
Membre
Lyon (France)
2009-01-20
66

Re: [Résolu] mise à jour ne fonctionne pas (SFR)

Il faut en prendre son parti en attendant que sfr élargisse son offre, c'est un choix délibéré de la part de celui-ci, qui ne s'en cache pas et indique explicitement qu'il n'apporte aucune aide concernant PHP et MY SQL, en un mot

débrouillez-vous

, alors ou tu restes chez lui  et tu fais avec, ou tu le quittes. De fait on arrive assez bien à installer et à utiliser la plupart des applications de type CMS moyennant quelques astuces et en lisant entre les lignes les explications fournies par SFR. SFR offre les dernières versions de PHP et de Mysql. Pour ma part j'ai choisi de faire une mise à jour manuelle, tant pis pour la théorie, si elle ne fonctionne pas on la contourne, Piwigo vaut bien cela !

A approfondir.

Cordialement

Dernière modification par rimousky (2010-05-31 23:34:16)


Velle parum est ; cupias ut se potiaris oportet.
Ma galerie,

Hors ligne

#9 2010-05-21 18:41:10

sereng44
Membre
2010-05-21
10

Re: [Résolu] mise à jour ne fonctionne pas (SFR)

Bonjour,

Cela fait maintenant un peu plus de 5 mois que j’utilise ce bel outil piwigo et j’espère bien pouvoir continuer en utilisant ses nouvelles versions.

Voila j’ai le même problème à savoir que mon site est hébergé chez SFR et que je suis donc obligé de faire ma migration manuellement. Malheureusement comme indiqué dans l’un des messages précédents, la fonction php_uname() étant interdit chez SFR l’exécution du script prep21up.php plante et m’empêche donc de générer le fichier upgrade21.zip.

Est-il possible de générer le répertoire local contenu dans upgrade21.zip, et  nécessaire à la migration (2.0.9 => 2.1), autrement qu’avec prep21up.php ?

N’étant pas un pro du PHP, manuellement par exemple ?

D'avance merci pour votre aide.

Hors ligne

#10 2010-05-21 18:50:05

Eric
Équipe Piwigo
VALENCE (FR)
2005-03-25
4579

Re: [Résolu] mise à jour ne fonctionne pas (SFR)

sereng44 a écrit:

Est-il possible de générer le répertoire local contenu dans upgrade21.zip, et  nécessaire à la migration (2.0.9 => 2.1), autrement qu’avec prep21up.php ?

prep21up.php n'était là *que* pour tester la migration en RC3. Pour un vrai mise à jour d'une galerie 2.0.x vers 2.1, il y a le plugin AutoUpgrade ou la mise à jour manuelle.


[Erratum] prep21up.php n'est pas *que* pour la RC :-/ [/Erratum]

Dernière modification par Eric (2010-05-21 18:53:17)

Hors ligne

#11 2010-05-21 18:53:32

ddtddt
Équipe Piwigo
Quetigny (21) - France
2007-07-27
14450

Re: [Résolu] mise à jour ne fonctionne pas (SFR)

Eric a écrit:

sereng44 a écrit:

Est-il possible de générer le répertoire local contenu dans upgrade21.zip, et  nécessaire à la migration (2.0.9 => 2.1), autrement qu’avec prep21up.php ?

prep21up.php n'était là *que* pour tester la migration en RC3. Pour un vrai mise à jour d'une galerie 2.0.x vers 2.1, il y a le plugin AutoUpgrade ou la mise à jour manuelle.

je t'invite à lire le Guide de Mise à jour manuelle
l'étape 3 ;-)


Vous aimez Piwigo alors n'hésitez pas à participer avec nous, plus d'infos sur la page "Contribuer à Piwigo". Si vous n'avez pas beaucoup de temps et que vous souhaitez nous soutenir vous pouvez aussi le faire par un don.

Hors ligne

#12 2010-05-21 18:55:25

Gotcha
Equipe Piwigo
Pierrelatte (26)
2007-03-14
13324

Re: [Résolu] mise à jour ne fonctionne pas (SFR)

Eric a écrit:

[Erratum] prep21up.php n'est pas *que* pour la RC :-/ [/Erratum]

Je suis tombé dans le même piège aussi Eric.
On prend vite goût aux automatismes ^^


Ayez comme premier réflexe de consulter le wiki.
Ensuite, veuillez effectuer une recherche sur le forum avant de poser votre question.

LE FAIRE EST LE REVELATEUR DE L'ETRE

Hors ligne

#13 2010-05-21 18:58:13

sereng44
Membre
2010-05-21
10

Re: [Résolu] mise à jour ne fonctionne pas (SFR)

Etant chez SFR l’Autoupgrade ne fonctionne pas. Je suis donc effectivement obligé de passer par la procédure manuelle.

Sauf erreur de ma part la procédure manuelle nécessite de lancer prep21up.php pour générer le fichier upgrade21.zip dans l’étape 3 ? non ? Et là re-problème avec SFR qui bloque php_uname() ... d'où ma question comment faire une migration manuelle sans utiliser prep21up.php ou sans utiliser php_uname() ?

Hors ligne

#14 2010-05-21 19:06:51

Gotcha
Equipe Piwigo
Pierrelatte (26)
2007-03-14
13324

Re: [Résolu] mise à jour ne fonctionne pas (SFR)

En le faisant sur un serveur local (EasyPHP, Wamp Serveur) et en transférant le résultat par FTP.
C'est mon idée. Attendez d'en avoir plusieurs, je ne suis pas un technicien ^^


Ayez comme premier réflexe de consulter le wiki.
Ensuite, veuillez effectuer une recherche sur le forum avant de poser votre question.

LE FAIRE EST LE REVELATEUR DE L'ETRE

Hors ligne

#15 2010-05-21 19:19:33

sereng44
Membre
2010-05-21
10

Re: [Résolu] mise à jour ne fonctionne pas (SFR)

En effet cela me semble une bonne idée.

En fait j’avais commencé à essayé de faire ce genre de manip chez un autre hébergeur, pour info MultiMania, mais je suis confronté à d’autres problèmes techniques que je ne maitrise pas et liés cette fois à MultiMania. Donc l’idée de tout faire en local et donc finalement de maitriser tout les paramètres me plait bien. Je vais voir si je peux récupérer EasyPHP ou Wamp.


Merci pour vos réponses

Hors ligne

  •  » Installation
  •  » [Résolu] mise à jour ne fonctionne pas (SFR)

Pied de page des forums

Propulsé par FluxBB

github twitter facebook newsletter Faire un don Piwigo.org © 2002-2019 · Contact