Paris Open Source Summit, 5 et 6 décembre 2018

Notes de version / Piwigo 2.9.4

bug fixes (including security)

2.9.4
Télécharger Piwigo 2.9.4

Sortie le 13 Juillet 2018

md5sum

La liste des changements majeurs est décrite sur les notes de la version 2.9.0.

Bugs corrigés

Problèmes connus

Langues

Fonctionnalités ajoutées

Mise à jour

Bugs corrigés

894 / Technique

Correction erreur de syntaxe

891 / Sécurité

Les liens vers piwigo.org doivent être en HTTPS

890 / Sécurité

Contenu mixte HTTP/HTTPS sur la page [Admin > Photos > Ajouter > Applications]

889 / Technique

Mise à jour de Smarty pour PHP 7.2

888 / Technique

Mise à jour de Cssmin pour PHP 7.2

887 / Technique

PHP 7.2, avertissement sur la gestion des utilisateurs

877 / Users & Groups

conflit potentiel sur le champ website_url avec une table utilisateurs tierce

872 / Sécurité

CVE-2018-7724

853 / Technique

Piwigo 2.9.3 casse le plugin Colored Tags

847 / Sécurité

CVE-2018-5692

844 / Affichage

Lien manquant dans le fil d'Ariane pour les albums récents

834 / Technique

compatibilité PHP 7.2

748 / Sécurité

Liste utilisateurs inaccessible

596 / Technique

PHP 7.1 et template.class.php incompatibles

258 / Photos

[albums] gestion par lot et filtre sur album supprimé

Problèmes connus

897 / Technique

[2.9.4] unexpected T_FUNCTION in functions_mysqli.inc.php on line 403

902 / Users & Groups

[2.9.4] users list no longer paginated or filtered

Langues

Langues mises à jour

Danois (Dansk)

Grec (Ελληνικά)

Esperanto

Estonien (eesti)

Persan (فارسی)

Finlandais (suomi)

Québecois

Hebreu (עברית)

Hongrois (Magyar)

Japonais (日本語)

Lithuanien (Lietuvių)

Hollandais (Nederlands)

Polonais (Polski)

Portugais (Português)

Roumain (Română)

Turc (Türkçe)

Vietnamien (Tiếng Việt)

Mise à jour

Nous recommandons la mise à jour automatiquea. Si vous utilisez la version 2.2+, Piwigo vous indiquera quels sont vos plugins qui ne sont pas encore compatibles avec la version 2.9.

Si vous utilisez actuellement Piwigo 2.9.x, vous pouvez télécharger l'archive 2.9.x_to_2.9.4.zip qui ne contient que les fichiers nouveaux ou modifiés. Une fois les fichiers extraits, transférez-les par FTP sur votre site par dessus votre installation 2.9.x. Votre base de données n'a pas besoin de mise à jour.

Si vous utilisez une version plus ancienne que la 2.9 et que vous ne souhaitez pas profiter de la mise à jour automatique, suivez la mise à jour manuelle.