#1 2020-01-08 20:57:50

lagome38
Membre
2015-11-24
5

Erreur suite a MAJ 2.10.1

Bonjour à tous,
Tout d'abord je vous souhaite une très bonne année à vous et vos proches :)

j'ai besoin d'aide, car suite a la mise a jour en 2.10.1, j'ai des erreurs sur la page d'accueil qui a apparu.
Après avoir parcouru le forum cela semble connu, mais je n'arrive pas a trouve le débugge …
De plus je viens d'annuler le support PHP fournie par 1and1 pensant que cela allé régler le problème .. mais patatra  cela a rajouté encore plus d'erreur. Je suis passer de la version PHP 5.5 vers 7.4

Je ne peux plus me connecter avec le compte admin.

voici le message d'erreur actuel:
Deprecated: Array and string offset access syntax with curly braces is deprecated in /homepages/22/d178960747/htdocs/SOUVENIRS/galerie/include/functions_cookie.inc.php on line 57
Warning: session_set_save_handler(): Cannot change save handler when headers already sent in /homepages/22/d178960747/htdocs/SOUVENIRS/galerie/include/functions_session.inc.php on line 24
Warning: ini_set(): Headers already sent. You cannot change the session module's ini settings at this time in /homepages/22/d178960747/htdocs/SOUVENIRS/galerie/include/functions_session.inc.php on line 29
Warning: ini_set(): Headers already sent. You cannot change the session module's ini settings at this time in /homepages/22/d178960747/htdocs/SOUVENIRS/galerie/include/functions_session.inc.php on line 30
Warning: ini_set(): Headers already sent. You cannot change the session module's ini settings at this time in /homepages/22/d178960747/htdocs/SOUVENIRS/galerie/include/functions_session.inc.php on line 31
Warning: ini_set(): Headers already sent. You cannot change the session module's ini settings at this time in /homepages/22/d178960747/htdocs/SOUVENIRS/galerie/include/functions_session.inc.php on line 32
Warning: session_name(): Cannot change session name when headers already sent in /homepages/22/d178960747/htdocs/SOUVENIRS/galerie/include/functions_session.inc.php on line 35
Warning: session_set_cookie_params(): Cannot change session cookie parameters when headers already sent in /homepages/22/d178960747/htdocs/SOUVENIRS/galerie/include/functions_session.inc.php on line 36
Warning: session_start(): Cannot start session when headers already sent in /homepages/22/d178960747/htdocs/SOUVENIRS/galerie/include/common.inc.php on line 141
Notice: Trying to access array offset on value of type null in /homepages/22/d178960747/htdocs/SOUVENIRS/galerie/include/functions_category.inc.php on line 125
Notice: Trying to access array offset on value of type null in /homepages/22/d178960747/htdocs/SOUVENIRS/galerie/include/functions_category.inc.php on line 126
Warning: Cannot modify header information - headers already sent by (output started at /homepages/22/d178960747/htdocs/SOUVENIRS/galerie/include/functions_cookie.inc.php:57) in /homepages/22/d178960747/htdocs/SOUVENIRS/galerie/include/page_header.php on line 86

Lors de ma connexion avec un compte il me rajoute aussi un message d'erreur:
•Les cookies sont bloqués ou non supportés par votre navigateur web. Vous devez activer les cookies pour vous connecter.
en revanche en version mobile j'arrive à me connecter :/

Voila ce n'est pas un grand site, il me permet de partager les photos avec la famille, 15/20 personnes, je pourrai refaire le site complètement, mais si vous pouvez m'aider ca serai vraiment top.

un très grand merci par avance et @ très vite
@ ++
Gérald

Version de Piwigo: 2.10.1
Version de PHP: 5.5  qui a été migrer en 7.4.1 dans la foulé
Version de MySQL: 5.5.60-0+deb7u1
URL Piwigo: http://nossouvenirs.com

Hors ligne

#2 2020-01-08 22:09:25

tramway61
Membre
2006-10-05
192

Re: Erreur suite a MAJ 2.10.1

Bonjour,

Et si vous passiez la version de PHP à 7.3 ?

@+
Thierry


@+
Thierry

Hors ligne

#3 2020-01-09 06:45:45

lagome38
Membre
2015-11-24
5

Re: Erreur suite a MAJ 2.10.1

merci Tramway61,
j'avais pas pensé a revenir en cette version.
Du coup php 7.3 est recommandé actuellement par 1and1 et elle est maintenu en support jusqu'à décembre 2021

donc j'arrive a me connecter maintenant avec mes comptes admin.
reste les erreurs initial:

Notice: Undefined index: display_fromto in /homepages/22/d178960747/htdocs/SOUVENIRS/galerie/include/category_cats.inc.php on line 119
Notice: Undefined index: display_fromto in /homepages/22/d178960747/htdocs/SOUVENIRS/galerie/include/category_cats.inc.php on line 315
Warning: Cannot modify header information - headers already sent by (output started at /homepages/22/d178960747/htdocs/SOUVENIRS/galerie/include/category_cats.inc.php:119) in /homepages/22/d178960747/htdocs/SOUVENIRS/galerie/include/page_header.php on line 86


et une fois connecter avec un compte admin  j'ai d'autre erreur qu'il se rajoute:

Notice: Undefined index: display_fromto in /homepages/22/d178960747/htdocs/SOUVENIRS/galerie/include/category_cats.inc.php on line 119
Notice: Undefined index: display_fromto in /homepages/22/d178960747/htdocs/SOUVENIRS/galerie/include/category_cats.inc.php on line 315
Notice: Undefined index: display_fromto in /homepages/22/d178960747/htdocs/SOUVENIRS/galerie/include/category_cats.inc.php on line 315
Notice: Undefined index: display_fromto in /homepages/22/d178960747/htdocs/SOUVENIRS/galerie/include/category_cats.inc.php on line 315
Notice: Undefined index: display_fromto in /homepages/22/d178960747/htdocs/SOUVENIRS/galerie/include/category_cats.inc.php on line 315
Notice: Undefined index: display_fromto in /homepages/22/d178960747/htdocs/SOUVENIRS/galerie/include/category_cats.inc.php on line 315
Warning: Cannot modify header information - headers already sent by (output started at /homepages/22/d178960747/htdocs/SOUVENIRS/galerie/include/category_cats.inc.php:119) in /homepages/22/d178960747/htdocs/SOUVENIRS/galerie/include/page_header.php on line 86


je vais refaire encore un tour sur le forum pour voir ce qu'il sait dit.

encore merci a vous tous
@++
Gérald

Hors ligne

#4 2020-01-09 13:57:06

lagome38
Membre
2015-11-24
5

Re: Erreur suite a MAJ 2.10.1

Hello tout le monde,
je viens de trouver un topic qui règle le ce problème.
cela relance l'upgrade  du site et le tour est joué

https://fr.piwigo.org/forum/viewtopic.php?pid=227525
==> ouvre upgrade.php dans ton navigateur web (à la place de admin.php), il te manque des mises à jour.



merci a bientot

Dernière modification par lagome38 (2020-01-09 18:08:16)

Hors ligne

Pied de page des forums

Propulsé par FluxBB

github twitter facebook newsletter Faire un don Piwigo.org © 2002-2020 · Contact