#1 2019-08-13 19:51:02

Katryne
Membre
Provence
2016-12-03
427

Url en sous-répertoire

Bonsoir,

Est-ce que Piwigo fonctionne bien avec une adresse en sous répertoire ? J'ai déjà installé 3 Piwigo, mais avec des URL en sous-domaine, 1 chez legtux, 2 chez 1&1-Ionos. Et là, avec une adresse en sous-répertoire, on dirait que la BDD a crashé (j'ai exposé le problème à mon hébergeur Legtux ce matin), je n'ai plus accès à PHPmyadmin et mes images refusent de s'afficher. Elles sont là, pourtant, je peux les voir par ftp et via l'admin, mais dès que j'essaye côté public j'ai une erreur probablement 404, mais je ne peux avoir le détail, car alors je suis renvoyée vers la page d'erreur standard du site principal qui est à la racine.

C'est une 2.9.10 beta 2 que je teste là . https://gabandjo.legtux.org/piwigo/ Je n'ai pas posté sur le forum beta-testing, car je voulais poser cette question de l'url en sous-répertoire.


https://photos.revestou.fr/  (Test même config: http://photos.katrynou.fr/)
Piwigo 2.9.5 -  Système d'exploitation: Linux
PHP: 7.3.4 - MySQL: 5.5.60-0+deb7u1-log
Bibliothèque graphique: External ImageMagick 6.8.9-9

Hors ligne

#2 2019-08-13 21:42:47

Justine5
Membre
2018-03-08
69

Re: Url en sous-répertoire

Peut-être des règles de réécriture d'URL dans un fichier .htaccess? Semble "manquer" .php dans tes adresses non?
https://gabandjo.legtux.org/piwigo/inde … /9-america
https://gabandjo.legtux.org/piwigo/pict … yce_canyon

PS: dans notre cas ;-) on a jamais rencontré de soucis avec Piwigo dans un sous-dossier

Hors ligne

#3 2019-08-13 21:57:49

Katryne
Membre
Provence
2016-12-03
427

Re: Url en sous-répertoire

Bien vu Justine. Merci Merci Merci
J'ai remis du php à la fin de l'url et ça marche nettement mieux.
J'avais repris en paquet mes modifs via LocalFileEditor des autres sites, mais j'ai oublié que pour cette réécriture ($conf['php_extension_in_urls'] = false;) il faut un autre plugin. Pour le moment j'ai oublié lequel.
Mais ça marche ailleurs : http://photos.katrynou.fr/index?/category/18-colorado
Et merci pour la confirmation pour l'url en sous-répertoire.

Dernière modification par Katryne (2019-08-13 21:58:36)


https://photos.revestou.fr/  (Test même config: http://photos.katrynou.fr/)
Piwigo 2.9.5 -  Système d'exploitation: Linux
PHP: 7.3.4 - MySQL: 5.5.60-0+deb7u1-log
Bibliothèque graphique: External ImageMagick 6.8.9-9

Hors ligne

#4 2019-08-14 16:33:07

Justine5
Membre
2018-03-08
69

Re: Url en sous-répertoire

Katryne a écrit:

Mais ça marche ailleurs : http://photos.katrynou.fr/index?/category/18-colorado

Yep j'avais remarqué ça ;-) mais je n'ai pas de réponse!

Par contre comme Piwigo ne nécessite pas (a priori) de modifier divers paramètres de config. lors d'un changement de répertoire, tu peux peut-être essayer "vite fait" de faire un test à la racine de l'un de ces hébergements vs sous-dossier de l'autre? question de vérifier des hypothèses

Hors ligne

#5 2019-08-14 16:49:24

Katryne
Membre
Provence
2016-12-03
427

Re: Url en sous-répertoire

J'ai essayé sur le site de mon amie Patricia  qui est à la racine sur son compte legtux, et ça ne marche pas  : si j'ajoute dans l'onglet configuration locale de LocalFileEditor

$conf['php_extension_in_urls'] = false;

les liens vers les albums sont inaccessibles (erreur 404)

Donc, cette modif fait son effet chez 1&1-Ionos, mais fait des caprices chez Legtux.


https://photos.revestou.fr/  (Test même config: http://photos.katrynou.fr/)
Piwigo 2.9.5 -  Système d'exploitation: Linux
PHP: 7.3.4 - MySQL: 5.5.60-0+deb7u1-log
Bibliothèque graphique: External ImageMagick 6.8.9-9

Hors ligne

#6 2019-08-14 17:30:12

Justine5
Membre
2018-03-08
69

Re: Url en sous-répertoire

Et au fait @Katryne rien trouvé dans les FAQ's ?
https://fr.piwigo.org/doc/doku.php?id=u … manquantes

Hors ligne

#7 2019-08-14 17:32:35

Justine5
Membre
2018-03-08
69

Re: Url en sous-répertoire

Plus de soucis @Katryne pour accèder à PHPmyadmin? c'est un peu inquiètant... non? du moins moi cela m'inquiéterait ;-) un peu

Hors ligne

#8 2019-08-14 19:37:28

Katryne
Membre
Provence
2016-12-03
427

Re: Url en sous-répertoire

Pour phpmonadmin, j'ai posé la question à l'hébergeur. C'est ce compte-là qui est maudit, ça fonctionne bien pour mes autres comptes Legtux.

Quant à la FAQ que tu signales, je l'avais bien étudiée, mais comme  c'est en sous-dossier, quand ça trouve pas, ça renvoie sur la page d'erreur du site principal qui est à la racine. Donc aucun diagnostic possible. C'est pourquoi j'avais posé la question de l'url en sous-dossier.


https://photos.revestou.fr/  (Test même config: http://photos.katrynou.fr/)
Piwigo 2.9.5 -  Système d'exploitation: Linux
PHP: 7.3.4 - MySQL: 5.5.60-0+deb7u1-log
Bibliothèque graphique: External ImageMagick 6.8.9-9

Hors ligne

Pied de page des forums

Propulsé par FluxBB

github twitter facebook newsletter Faire un don Piwigo.org © 2002-2019 · Contact