#1 2017-12-06 07:09:01

Benoit
Membre
78
2009-10-22
380

[Résolu] url profil en http o_o

Hello, je viens de constater que si on veut éditer l'adresse du site web dans le "profil", il est ajouté par défaut un http:// au début, donc on se retrouve avec une url comme suit: http://https://nomdedomaine.com/.

Voilà un petit truc à régler peut-être ?

Bonne journée.

Hors ligne

 

#2 2017-12-06 23:08:01

k5
Membre
lieu
2014-01-26
276

Re: [Résolu] url profil en http o_o

Bonjour Benoit, pourquoi pas, faire une refonte du forum ? peut-être pour l'année 2018 ? Nous pourrons soit afficher du http ou https

Il suffit de faire la mise à jour du forum ou alors de changer la ligne du fichier profile.php soit c'est le serveur qui gère.

Cordialement
k5

Dernière modification par k5 (2017-12-06 23:14:38)


Ayez comme premier réflexe de faire les mises à jours piwigo et extensions. merci

Hors ligne

 

#3 2017-12-07 14:48:08

flop25
Équipe Piwigo
2006-07-06
6405

Re: [Résolu] url profil en http o_o

quel domaine parlez vous Benoit ?
sur votre Piwigo ? Vous avez mis en place le https comment ?

Hors ligne

 

#4 2017-12-08 01:30:47

Katryne
Membre
Provence
2016-12-03
244

Re: [Résolu] url profil en http o_o

Hello !
Sur mon PunBB http://revest.legtux.org/index.php, qui est l'ancêtre de FluxBB, si je mets du https dans le profil, ça affiche du https, le http n'est pas pré-rempli, pas imposé, faut saisir l'url complète. Mais les 2 CMS ont pu évoluer différemment et leurs extensions aussi pour la gestion des utilisateurs. Qu'est-ce qui est utilisé ici ? La gestion native du forum ou une extension ?

Sinon, Benoît peut sans doute, en attendant une modif du forum Piwigo, entrer ici son URL en http, mais prévoir sur son site une redirection par htaccess du http vers le https.

Mais pour le moment, à l'heure où je poste, le site est pour moi inaccessible, même en récrivant l'url, que ce soit en http ou en https, avec ou sans www. Je ne me suis pas lancée personnellement dans le https, donc je n'y connais pas grand chose, mais si j'essaie de me connecter à ton site en https, mon navigateur m'envoie une alerte de sécurité, comme quoi  le certificat n'est pas valide :

destin-tanganyika.com utilise un certificat de sécurité invalide. Le certificat n’est pas sûr car il est auto-signé. Le certificat n’est pas valide pour le nom destin-tanganyika.com. Le certificat a expiré le mardi 17 mai 2016 11:08. La date courante est vendredi 8 décembre 2017 01:21. Code d’erreur : <a id="errorCode" title="SEC_ERROR_UNKNOWN_ISSUER">SEC_ERROR_UNKNOWN_ISSUER</a>


https://photos.revestou.fr/  (Test même config: http://photos.katrynou.fr/)
Piwigo 2.9.4 -  Système d'exploitation: Linux
PHP: 7.2.1 - MySQL: 5.5.59-0+deb7u1-log
Bibliothèque graphique: External ImageMagick 6.8.9-9

Hors ligne

 

#5 2017-12-09 09:32:13

Benoit
Membre
78
2009-10-22
380

Re: [Résolu] url profil en http o_o

Salut, merci pour ta réponse.
Utilises-tu safari comme navigateur ? C'est le seul qui me renvoi un message d'erreur lors de l'accès à mon site  en https.

Bonne journée.

Hors ligne

 

#6 2017-12-09 11:08:05

Katryne
Membre
Provence
2016-12-03
244

Re: [Résolu] url profil en http o_o

Bonjour Benoît, ce matin, c'est bon sur tous mes (10) navigateurs (j'ai pas pas Safari, Chrome non plus ...)

Je me demande ... quand j'ai copié ton url en https, je ne me suis pas aperçue qu'elle ne présentait pas de : entre http et // et avant que je puisse en ajouter, mes gentils navigateurs estimant que j'étais une nase (à tort ou à raison ?) m'ajoutaient systématiquement du http:// devant le bazar.
Essaye d'entrer de nouveau ton url dans ton profil en vérifiant bien la présence des deux points :

passe la souris sur le lien web de ton profil dans la marge des messages, tu verras qu'il manque :


https://photos.revestou.fr/  (Test même config: http://photos.katrynou.fr/)
Piwigo 2.9.4 -  Système d'exploitation: Linux
PHP: 7.2.1 - MySQL: 5.5.59-0+deb7u1-log
Bibliothèque graphique: External ImageMagick 6.8.9-9

Hors ligne

 

#7 2017-12-10 08:55:43

Benoit
Membre
78
2009-10-22
380

Re: [Résolu] url profil en http o_o

Salut, merci pour le retour.
Voilà comment est l'url dans mon espace: http://https://www.destin-tanganyika.com/galerie/paysages-biotopes/
Il y a donc bien les ":" et en plus le "http://".

Bon dimanche.

Hors ligne

 

#8 2017-12-10 22:13:20

flop25
Équipe Piwigo
2006-07-06
6405

Re: [Résolu] url profil en http o_o

ha vous parlez du profil sur ce forum désolé
le mieux c'est de mettre une redirection sur votre site de http en https

Hors ligne

 

#9 2017-12-12 21:31:05

Benoit
Membre
78
2009-10-22
380

Re: [Résolu] url profil en http o_o

Bonsoir, ça c'est fait, j'ai ouvert ce sujet juste pour le signaler, à la base. :)

Bonne soirée.

Hors ligne

 

#10 2017-12-12 23:25:56

ddtddt
Équipe Piwigo
Quetigny (21) - France
2007-07-27
14234

Re: [Résolu] url profil en http o_o

Bonjour,

Est ce que c'est bon maintenant ?
parce que j'ai corrigé le lien dans ton profil il y a plusieurs jours


Vous aimez Piwigo alors n'hésitez pas à participer avec nous, plus d'infos sur la page "Contribuer à Piwigo". Si vous n'avez pas beaucoup de temps et que vous souhaitez nous soutenir vous pouvez aussi le faire par un don.

Hors ligne

 

#11 2017-12-13 00:48:49

Benoit
Membre
78
2009-10-22
380

Re: [Résolu] url profil en http o_o

Oh mais c'est parfait, merci bien ! :)

Hors ligne

 

Pied de page des forums

Propulsé par FluxBB

github twitter facebook newsletter Faire un don Piwigo.org © 2002-2018 · Contact