#1 2017-10-10 06:51:19

Eric D
Invité

Non prise en compte des polices Google (Google Font) en https

Bonjour/Bonsoir,

De plus en plus d'hébergeur proposent et passent de http au protocole https.

Chez 1and1, les deux protocoles fonctionnent en parallèle pour l'instant...

Je me suis aperçu que les polices Google (Google font) ne marchent plus quand on est en https alors qu'en http, pas de souci :

http://evasion-en-images.fr (OK)
https://evasion-en-images.fr (KO)

Afin d'utiliser les Google Font, j'ai mis, grâce au plugin "Ajouter des éléments dans <head>", le code suivant :
<link href="http://fonts.googleapis.com/css?family=Handlee" rel="stylesheet" type="text/css">

et j'ai appliqué la police Handlee dans le css du thème striped responsiv) via LocalFile Editor à la balise body

Savez-vous SVP, comment appliquer les Google Fonts dans le cas du protocole "https" ?

Merci d'avance !


Version de Piwigo: 2.9.2
Version de PHP:
Version de MySQL:
URL Piwigo: http://evasion-en-images.fr

#2 2017-10-10 10:36:57

maximebrmd
Membre
Date d'inscription: 2017-09-01
Messages: 13

Re: Non prise en compte des polices Google (Google Font) en https

Bonjour Eric,

Peux-tu essayer ceci :

<link href="//fonts.googleapis.com/css?family=Handlee" rel="stylesheet" type="text/css">

- Maxime

Hors ligne

#3 2017-10-10 15:45:24

Katryne
Membre
Lieu: Provence
Date d'inscription: 2016-12-03
Messages: 167
Site web

Re: Non prise en compte des polices Google (Google Font) en https

Hello !
Quand j'utilise des Google Fonts, je ne les utilise pas en appel distant. Je veux dire que je les télécharge, je les pose sur le site dans un dossier /font de mon thème et je les appelle dans le fichier css avec une adresse locale.
Ce peut être une solution de dépannage pour ton souci en mode https.


Piwigo 2.9.2 -  Système d'exploitation: Linux
PHP: 7.0.24
MySQL: 5.5.57-0+deb7u1-log
Bibliothèque graphique: External ImageMagick 6.8.9-9

Hors ligne

#4 2017-10-11 06:48:06

Eric D
Invité

Re: Non prise en compte des polices Google (Google Font) en https

Super, ça fonctionne !!

Merci et bonne journée

#5 2017-10-11 16:59:55

maximebrmd
Membre
Date d'inscription: 2017-09-01
Messages: 13

Re: Non prise en compte des polices Google (Google Font) en https

Bonjour Eric,

Super ! Cela ne fonctionnait pas car vous avez précisez que vous vouliez la font en http seulement en retirant le http lors de l'insertion de la font, elle est alors utiliser en http et https ;)

- Maxime

Hors ligne

Pied de page des forums

Propulsé par FluxBB