•  » Installation
  •  » OVH mon hébergeur ne veux plus supporter php 5.2

#1 2015-03-25 10:33:09

gerard74
Membre
Bourg-Saint-Andeol
2011-03-06
47

OVH mon hébergeur ne veux plus supporter php 5.2

Bonjour/Bonsoir,

ovh mon hébergeur me signale qu'il ne pourra plus dans un avenir proche supporter php 5.2 et me conseille d'opter pour php 5.5 au minimum ou suppérieur

Pensez vous dans l'avenir opter pour une version de php supérieure ?

Je vous avoue que cela me perturbe et j'ai peur que ma galerie ne fonctionne plus

Par avance je vous remercie de votre réponse
bien cordialement
Gérard

Version de Piwigo: 2.7.4
Version de PHP: 5.2.17 (Montrer les informations) [2015-03-25 10:11:35]
Version de MySQL: 5.1.73-2+squeeze+build1+1-log [2015-03-25 10:11:35]
URL Piwigo: http://www.sillingyclubphoto.fr/piwigo/index.php

Hors ligne

#2 2015-03-25 10:37:25

mistic100
Ex Equipe Piwigo
Lyon
2008-09-27
3555

Re: OVH mon hébergeur ne veux plus supporter php 5.2

http://fr.piwigo.org/basics/requirements est ambigu mais c'est MINIMUM 5.2

edit: plg a mis à jour la page

Hors ligne

#3 2015-03-27 17:19:38

Umberto F.
Invité

Re: OVH mon hébergeur ne veux plus supporter php 5.2

meme message pour moi

Vous avez actuellement un ou plusieurs Hébergement(s) Web qui utilise(nt) le langage PHP pour des pages web.

Dans un souci d'amélioration et de sécurisation des services OVH, nous sensibilisons nos clients sur l'abandon des anciennes versions de PHP, qui ne sont plus maintenues par l'éditeur.

Cela concerne actuellement les versions PHP 4 ainsi que 5.3 et inférieures.

Il est possible que, dans le futur, nous soyons contraints de ne plus supporter ces versions obsolètes. Ainsi, il est recommandé de veiller à la mise à jour régulière de vos pages.

Vous pourrez suivre la planification d'éventuelles actions via la tâche travaux : http://travaux.ovh.net/?do=details&id=12455

Certains de vos sites utilisent une version obsolète de PHP. Nous vous conseillons donc de migrer vers une version plus récente, idéalement PHP 5.5 ou 5.6.

#4 2015-03-31 13:09:41

zoom
Membre
2008-02-29
154

Re: OVH mon hébergeur ne veux plus supporter php 5.2

Si ça peut aider:

Pour passer à la version php  5.4 sur votre hébergement OVH

Ouvrir un éditeur genre Notepad téléchargeable par exemple:
ici
Ouvrir un onglet "new"
Pour passer à la version  php 5.4 copier dans l'éditeur:

; ovhconfig
;
; this file must be placed in $HOME/.ovhconfig or in $DOCUMENT_ROOT/.ovhconfig

; __app.engine__
;
; values: php (php engine + opcache accelerator)
; notice: if php, a phpcgi engine will be activated as fallback (if previous engine crash)
;
;   php:
;       IMPORTANT: register_globals and magic_quotes_gpc are off for security
;       php optiones .htaccess (like php version) are ignored
;   phpcgi:
;       IMPORTANT this is a fallback to previous system
;       in this case __app.engine.version__ will be considerated as AUTO and php version will be old system
;       (meaning depending .htaccess or .phpX extension)
;
app.engine=php

; __app.engine.version__ specify version of your engine
;
; for php:
;   default: 5.4
; for phpcgi:
;   this options is ignored (= fallback in AUTO)
;
app.engine.version=5.4

; __http.firewall__ used to add application firewall  (filter http requests)
;
; values: none | security
; default: none
;
http.firewall=none

; __environment__
;
; values: production | development
;
;   production:
;       apache will maximise local cache
;       mod_expires will grow up TTL of js, css, pdf, images, video, audio
;       you can override it changing expiration explicitly in your .htaccess
;       feel free to look on our guide.
;   development:
;       no expiration is added, files are not locally in cache,
;       will speed up tests but decrease performances
;
; choosen environment will also be available in your variable ENVIRONMENT unix env
;
; default: production
;
environment=development


cliquer sur enregistrer
Nommer ce fichier .ovhconfig

à l'aide d'un client ftp genre filezilia téléchargeable par exemple:
ici

transférer (drag and drop) ce fichier à la racine de votre site.
Et voilà c'est fait .
Allez dans l'administration de votre piwigo, et vous verrez que votre version du php a changé.
Si j'ai ai fait quelques erreurs merci de me corriger.
Cordialement.
Zoomy

Dernière modification par zoom (2015-03-31 15:16:18)


Bien cordialement, Zoomy
Version Piwigo:2.8.1
Hébergeur O2switch; PHP: 5.6.20; MySQL: 5.6.29-76.2
url: http://zoomyphoto.fr

Hors ligne

#5 2015-04-02 11:00:50

Philippe Gueudré
Invité

Re: OVH mon hébergeur ne veux plus supporter php 5.2

Merci beaucoup, ça marche très bien
J'étais inquiet et avais reçu aussi la même mise en garde d'OVH.
J'ai appliqué votre procédure qui ressemble à celle proposée par OVH et ça marche très bien, on passe tout de suite à la version 5.4.

  •  » Installation
  •  » OVH mon hébergeur ne veux plus supporter php 5.2

Pied de page des forums

Propulsé par FluxBB

github twitter facebook newsletter Faire un don Piwigo.org © 2002-2019 · Contact