Annonce

  •  » Installation
  •  » [Résolu] Installation sur Nas Synology

#1 2014-07-18 18:08:26

pith
Membre
2014-07-18
3

[Résolu] Installation sur Nas Synology

Bonjour,
Je vais changer mon Nas Netgear par un Synology.
J'utilise Piwigo pour mes albums Photos familiaux
J'ai fouiller sur différent forum pour savoir comment procéder a une installation sur le Synology.
J'ai effectué la création du répertoire web devant accueillir les fichiers Piwigo.
Qaund je me connecte sur 192.168.xx.xx/piwigo/install.php  il ne se passe rien juste une page blanche.
MariaDB e phpmyadmin sont installer et les services sont actifs.
Quelqu'un pourrais me donner un coup de main car je ne comprends plus rien ?
Existe -il un package pour Synology ?
Merci
Pith

Version de Piwigo:  cela sera la derniere
Version de PHP: 4.1.14
Version de MySQL:
URL Piwigo: http://

Hors ligne

#2 2014-07-19 12:59:44

flop25
Équipe Piwigo
2006-07-06
6477

Re: [Résolu] Installation sur Nas Synology

Bonjour
pourriez vous regarder dans les log serveur pour connaitre l'erreur retournée

Hors ligne

#3 2014-07-19 17:29:54

pith
Membre
2014-07-18
3

Re: [Résolu] Installation sur Nas Synology

bonjour,
après avoir regarder de plus prés il me manquait 2 répertoires. correction de l'erreur tout Ok pour l'installation.
maintenant quand j'importe une image , j'ai un triangle avec un point d'exclamation a la place d'une miniature. la photo est visible quand je clique dessus.
si vous avez une idee... mais je continu a chercher.

Hors ligne

#4 2014-07-19 18:27:21

pith
Membre
2014-07-18
3

Re: [Résolu] Installation sur Nas Synology

youpi tout fonctionne.
merci

Hors ligne

#5 2014-07-26 18:37:17

mgr
Membre
Lyon
2009-09-08
220

Re: [Résolu] Installation sur Nas Synology

Bonjour.
Pourriez-vous me dire si c'est compliqué de mettre piwigo sur un synology?
Je n'ai installé sur mon NAS que des applis proposées dans le pack synology.
Il existe une procédure pas à pas pour installer piwigo? Merci.

Hors ligne

#6 2014-07-27 22:42:52

bleuvague
Membre
2011-10-13
40

Re: [Résolu] Installation sur Nas Synology

Là aussi je suis intéressé! J'ai jamais eu de problème pour installer piwigo sur mon Synology, par contre jamais pu lancer la génération des apperçu.... Si vous avez une idée je suis preneur!

Hors ligne

#7 2014-09-15 11:24:44

olliwa
Membre
2011-10-15
19

Re: [Résolu] Installation sur Nas Synology

Installer Piwigo sur un NAS Synology DSM5.0 DSM5 MariaDB
Gestion des aperçus, gestion des photos et des videos

voici mon expérience récente (sept 2014):

Petite précision, tous les accès de mon Synology sont en https

Téléchargement
- télécharger la dernière version et déposer dans le dossier "web" du Synology (ou bien copier "piwigo-netinstall.php" sur votre Synology dans le dossier "web")
- unzipper dans un dossier par exemple dossier "web/piwigo"

MariaDB
- lancer phpMyAdmin pour créer un compte et une base de données piwigo
- attention "client" doit sur "localhost" par défaut le nouvel utilisateur est créé en "%"

Installation
- modifier ou vérifier les droits d’accès au dossier piwigo et a ses sous dossiers
- lancer l'installation depuis votre browser et renseigner les comptes base de données et administrateur piwigo


Transfert de photo: quelques problèmes rencontrés
- ploader ne fonctionne pas en https (voir autres posts sur le forum) voir http://fr.piwigo.org/forum/viewtopic.ph … 79#p173679
- le formulaire flash ne fonctionne pas non plus (je n'ai pas cherché la raison)
- le formulaire html n'accepte pas la multiselection (trop loin pour moi de sélectionner les photos une par une)

Mon choix pour la création des "galleries" : Ftp et gestion des fichiers sur le Synology
- Après avoir lu différents post sur le forum, j'ai opte pour la bonne vieille méthode du ftp avec création de dossiers et sous dossiers. Sur le Synology, c'est bien plus efficace et beaucoup plus simple
- synchronisation une fois avoir mis a jour les dossiers
- création des aperçus et vignettes grâce a la fonction "gestion par lots"

Gestion des aperçus et imagettes : "ImageMagik"
- Il faut utiliser LocalFiles Editor pour modifier le chemin d’accès a "ImageMagik"
voir http://fr.piwigo.org/forum/viewtopic.ph … 41#p181741
- après synchro, j'ai créé les imagettes et j'ai géré les métadonnées dont la géolocalisation (je n'ai pas pu ou su  géolocaliser plusieurs photos en même temps avec le plugin "OpenStreetMaps")

Pour les videos,
- J'ai installé le plugin piwigo-videoJS.
- J'ai toujours un problème non résolu pour l'utilisation de Mediainfo et FFMpeg.
   - aussi pour le moment, les vignettes video sont créées en dehors de piwigo. J'ai suivi le conseil lu sur le forum et j'ai créé des fichiers "gif" animés que j'ai déposé dans le sous-dossier "pwg_representative".
http://fr.piwigo.org/forum/viewtopic.ph … 7#p211177. Çà fonctionne très bien avec le thème "elegant"
- J'ai aussi le message de warning non résolu
Warning: strpos(): Offset not contained in string in /volume1/web/piwigo/include/functions_url.inc.php on line 765

"thèmes":
- j'ai choisi "elegant"
- "stripped & columms", "stripped-galleria" et "stripped_responsive" bugguent

"plugins":
j'ai installé en automatique "OpenStreetMaps", "Advanced Menu Manager", Copyright", Cumulus Tags Cloud", "Grum Plugin Classes", "Meta", "LocalFiles Editor", "PWG Stuffs", "Statistics" et "VideoJS"


Version de Piwigo
        Piwigo 2.6.3
Environnement
        Système d'exploitation: Linux
        PHP: 5.5.13
        MySQL: 5.5.37-MariaDB
        Bibliothèque graphique: GD bundled (2.1.0 compatible)

Mon hébergeur: réseau local derrière une freebox

Hors ligne

#8 2015-03-02 17:21:58

tagadatsointsoin
Membre
2015-03-01
1

Re: [Résolu] Installation sur Nas Synology

pith a écrit:

bonjour,
après avoir regarder de plus prés il me manquait 2 répertoires. correction de l'erreur tout Ok pour l'installation.
maintenant quand j'importe une image , j'ai un triangle avec un point d'exclamation a la place d'une miniature. la photo est visible quand je clique dessus.
si vous avez une idee... mais je continu a chercher.

Bonjour,
J'ai le même problème. Ecran blanc quelque soit le navigateur lors du lancement de l'installation.
Quels sont les 2 répertoires qui vous manquaient ?

Hors ligne

  •  » Installation
  •  » [Résolu] Installation sur Nas Synology

Pied de page des forums

Propulsé par FluxBB

github twitter facebook newsletter Faire un don Piwigo.org © 2002-2020 · Contact