#1 2012-10-03 21:54:52

clockover
Membre
2012-07-04
32

Piwigo 2.4.4 avec PHP 5.3.3

Bonsoir,

Je constate que j'ai la page de gestion par lot totatement buggée.
Je n'ai malheureusement très peu de temps cette semaine poru em pencher sur le problème en détail. Je le publie pour voir si quelqu'un d'autre reconnait les mêmes sympthômes.

1.
Il m'est impossible de mettre à jour les filtres (suppression ou ajout de fitre) (il en se passe tout simplement rien).
Par cotnre si je change le filtre déjà en cours "filtre prédéfini" et que je passe sur "derneir import" et je clique sur "rafraichir le lot de photo" le résutlat est correct.

2.
Le lien "Suppriemr tous les filtres" dirige vers la gallerie (donc la racine du site) 8-o!

3.
Les liens de sélections ("toute la page", "tout le lot", "rien", "ivverser"...) sont tous inopérants.
Mais je peux cocher manuellement les photos.
Une fois une photo cochée, je dois cliquer sur "rafraichir le lot de photos"  pour que le menu action se remplisse (et encore il se remplit de toutes les actions possibles...).

(voir screen)

Bref elle ne gère plus du tout les évenements.
Je navigue avec IE 9.


Images attachées

Dernière modification par clockover (2012-10-03 21:56:05)

Hors ligne

#2 2012-10-03 22:00:58

mistic100
Ex Equipe Piwigo
Lyon
2008-09-27
3556

Re: Piwigo 2.4.4 avec PHP 5.3.3

Bonsoir,

je pense que l'origine du problème est simple : JavaScript n'est pas activé sur votre navigateur, et il est nécessaire pour toute l'administration

http://www.maboite.qc.ca/activation_js.php

Hors ligne

#3 2012-10-04 20:29:39

14SD101
Membre
Abbeville
2010-05-24
16

Re: Piwigo 2.4.4 avec PHP 5.3.3

Bonsoir,

Depuis la mise à jour 2.4.4
J'ai ces deux messages d'erreur et impossible de gérer les photos ...

Warning: substr_compare() [function.substr-compare]: The length cannot exceed initial string length in /homepages/34/d359900654/htdocs/photos/admin/batch_manager.php on line 118

Warning: Cannot modify header information - headers already sent by (output started at /homepages/34/d359900654/htdocs/photos/admin/batch_manager.php:118) in /homepages/34/d359900654/htdocs/photos/include/page_header.php on line 105

J'ai bien vérifié comme recommandé par Mistic (bien que je n'avais pas modifié les réglages entre 2.4 et cette mise à jour)

Merçi pour l'aide et félicitations à toute l'équipe.

Cordialement.

Francis

Hors ligne

#4 2012-10-04 20:38:08

mistic100
Ex Equipe Piwigo
Lyon
2008-09-27
3556

Re: Piwigo 2.4.4 avec PHP 5.3.3

bonjour

les deux problèmes n'ont aucun rapport
voir [Forum, topic 22848] Plus de gestion par lot !!

Hors ligne

#5 2012-10-09 18:29:25

clockover
Membre
2012-07-04
32

Re: Piwigo 2.4.4 avec PHP 5.3.3

Effectivement, je n'ai pas pensé à javascript!
Effectivement le comportement ressemble à cette cause mais non javascript est bien activé. (lien donné l'indique bien comme activé)

Avec un autre navigateur, je n'ai pas le soucis.
Bref si vosu n'avez pas d'autres cas, c'est mon IE qui tombe en vrac ^^

Hors ligne

#6 2012-10-09 22:37:08

flop25
Équipe Piwigo
2006-07-06
6466

Re: Piwigo 2.4.4 avec PHP 5.3.3

je crois avoir rencontré ce problème récemment sur le forum EN : désactivez le mode de compatibilité dans IE ou changez de navigateur pour un guide respecte les standards ^^

Hors ligne

Pied de page des forums

Propulsé par FluxBB

github twitter facebook newsletter Faire un don Piwigo.org © 2002-2019 · Contact