•  » Installation
  •  » [Résolu] La mise à jour vers la 2.1.0 est-elle sûre pour les plugins?

#1 2010-05-18 14:49:36

dragonballed
Membre
2010-02-25
72

[Résolu] La mise à jour vers la 2.1.0 est-elle sûre pour les plugins?

Bonjour!

Voilà, je serais vraiment ravi de passer à la dernière version mais j'ai un peu peur quand même.
En effet, ma galerie est privée et possède plus de 250 membres. Donc, j'aimerai éviter de tout faire planter.

Je suis en 2.0.8 et ma plus grosse inquiétude se situe au niveau des plugins "PWG Stuffs" et "UserAdvManager" que j'utilise pour avoir une vérification de l'adresse mail lors de l'inscription; avec les groupes "attente" et "validé". Est-ce que cela fonctionnera toujours après mise-à-jour.

Ensuite, je me sers aussi de "Register FluxBB". Fonctionnera-t-il après mise-à-jour?

Et enfin, j'ai pu constater qu'il y avait une grosse modif au niveau de la forme que prennent les thèmes sur le serveur. Est-ce que ca risque de me poser problème? Si oui, y-a-t-il une méthode pour que tout s'adapte correctement? J'utilise un thème "flop 25".

Merci d'avance pour vos réponses, j'ai besoin d'être sûr avant de me jetter à l'eau! ^^

Hors ligne

#2 2010-05-18 14:51:42

oualid
Membre
2009-09-07
59

Re: [Résolu] La mise à jour vers la 2.1.0 est-elle sûre pour les plugins?

dragonballed a écrit:

Bonjour!

Voilà, je serais vraiment ravi de passer à la dernière version mais j'ai un peu peur quand même.
En effet, ma galerie est privée et possède plus de 250 membres. Donc, j'aimerai éviter de tout faire planter.

Je suis en 2.0.8 et ma plus grosse inquiétude se situe au niveau des plugins "PWG Stuffs" et "UserAdvManager" que j'utilise pour avoir une vérification de l'adresse mail lors de l'inscription; avec les groupes "attente" et "validé". Est-ce que cela fonctionnera toujours après mise-à-jour.

Ensuite, je me sers aussi de "Register FluxBB". Fonctionnera-t-il après mise-à-jour?

Et enfin, j'ai pu constater qu'il y avait une grosse modif au niveau de la forme que prennent les thèmes sur le serveur. Est-ce que ca risque de me poser problème? Si oui, y-a-t-il une méthode pour que tout s'adapte correctement? J'utilise un thème "flop 25".

Merci d'avance pour vos réponses, j'ai besoin d'être sûr avant de me jetter à l'eau! ^^

Ces deux plugins posent problème après l'upgrade, j'ai du les virer !!
Je te conseille donc d'attendre leurs mises à jour.

Hors ligne

#3 2010-05-18 15:04:54

dragonballed
Membre
2010-02-25
72

Re: [Résolu] La mise à jour vers la 2.1.0 est-elle sûre pour les plugins?

wow! Je vois que j'ai bien fait de demander!!! xD

Apparemment NBC UAM propose déjà une MAJ que je n'ai pas (2.14.1). Mais déjà, si je le mets à jour, va-t-il se souvenir de mes réglages?

Je vais attendre les réponses de l'équipe Piwigo pour me faire une idée. Merci pour l'avertissement! ;)

Hors ligne

#4 2010-05-18 15:24:25

Gotcha
Equipe Piwigo
Pierrelatte (26)
2007-03-14
13330

Re: [Résolu] La mise à jour vers la 2.1.0 est-elle sûre pour les plugins?

Pas la peine de "virer" mais simplement Désactiver ce qui a l'avantage de ne pas rien supprimer et de conserver vos anciens paramètres :-)


Ayez comme premier réflexe de consulter le wiki.
Ensuite, veuillez effectuer une recherche sur le forum avant de poser votre question.

LE FAIRE EST LE REVELATEUR DE L'ETRE

En ligne

#5 2010-05-18 15:27:21

dragonballed
Membre
2010-02-25
72

Re: [Résolu] La mise à jour vers la 2.1.0 est-elle sûre pour les plugins?

euh... donc, il faut les désactiver, mettre à jour, puis les réactiver c'est ca? Il n'y aura pas de problème si je fais ca?

Et pour le thème, y-t-il aussi quelque chose à faire?

Hors ligne

#6 2010-05-18 16:22:27

Gotcha
Equipe Piwigo
Pierrelatte (26)
2007-03-14
13330

Re: [Résolu] La mise à jour vers la 2.1.0 est-elle sûre pour les plugins?

dragonballed a écrit:

euh... donc, il faut les désactiver, mettre à jour, puis les réactiver c'est ca? Il n'y aura pas de problème si je fais ca?

Oui.

dragonballed a écrit:

Et pour le thème, y-t-il aussi quelque chose à faire?

Une bonne sauvegarde :-)
Si ton thème est un thème "fait maison" alors il faudra le refaire. Aide dans le [wiki]


Ayez comme premier réflexe de consulter le wiki.
Ensuite, veuillez effectuer une recherche sur le forum avant de poser votre question.

LE FAIRE EST LE REVELATEUR DE L'ETRE

En ligne

#7 2010-05-18 19:14:42

Eric
Équipe Piwigo
VALENCE (FR)
2005-03-25
4579

Re: [Résolu] La mise à jour vers la 2.1.0 est-elle sûre pour les plugins?

dragonballed a écrit:

wow! Je vois que j'ai bien fait de demander!!! xD

Apparemment NBC UAM propose déjà une MAJ que je n'ai pas (2.14.1). Mais déjà, si je le mets à jour, va-t-il se souvenir de mes réglages?

Si on a bien suivi la procédure (désactiver et pas "virer" les plugins), il n'y a aucun souci pour les réglages. D'ailleurs, la procédure d'auto upgrade désactive d'elle-même les plugins avant de faire la mise à jour. Un message indique ensuite quels plugins sont maintenu en position désactivée afin de vous permettre de vérifier s'il n'existe pas une mise à jour disponible.

Hors ligne

#8 2010-05-18 19:29:55

P@t
Équipe Piwigo
Nice
2007-06-13
5694

Re: [Résolu] La mise à jour vers la 2.1.0 est-elle sûre pour les plugins?

PWG Stuffs et NBC UAM sont à jour pour la 2.1, foncez!


P@t

Hors ligne

#9 2010-05-18 19:39:02

Pilou bis
Membre
2008-02-15
143

Re: [Résolu] La mise à jour vers la 2.1.0 est-elle sûre pour les plugins?

Bonjour,

Après avoir mis à jour Piwigo, et le plugin PWG Stuffs, dès que j'active le plugin PWG Stuffs, j'obtiens ceci en page d'accueil de la gallerie ...

Code:

Warning: include(./plugins/PWG_Stuffs/modules/Personal/main.inc.php) [function.include]: failed to open stream: No such file or directory in /mounted-storage/*********/plugins/PWG_Stuffs/include/class.inc.php  on line 86

Warning: include(./plugins/PWG_Stuffs/modules/Personal/main.inc.php) [function.include]: failed to open stream: No such file or directory in /mounted-storage/*********/plugins/PWG_Stuffs/include/class.inc.php on line 86

Warning: include() [function.include]: Failed opening './plugins/PWG_Stuffs/modules/Personal/main.inc.php' for inclusion (include_path='.:/usr/share/php5/') in /mounted-storage/*********/plugins/PWG_Stuffs/include/class.inc.php on line 86

Warning: include(./plugins/PWG_Stuffs/modules/Random/main.inc.php) [function.include]: failed to open stream: No such file or directory in /mounted-storage/*********/plugins/PWG_Stuffs/include/class.inc.php on line 86

Warning: include(./plugins/PWG_Stuffs/modules/Random/main.inc.php) [function.include]: failed to open stream: No such file or directory in /mounted-storage/*********/plugins/PWG_Stuffs/include/class.inc.php on line 86

Warning: include() [function.include]: Failed opening './plugins/PWG_Stuffs/modules/Random/main.inc.php' for inclusion (include_path='.:/usr/share/php5/') in /mounted-storage/*********/plugins/PWG_Stuffs/include/class.inc.php on line 86

Warning: Cannot modify header information - headers already sent by (output started at /mounted-storage/*********/plugins/PWG_Stuffs/include/class.inc.php:86) in /mounted-storage/*********/include/page_header.php on line 98

Merci d'avance de votre aide.

Hors ligne

#10 2010-05-18 19:43:07

grum
Équipe Piwigo
50% Nantes - 50% Paris
2007-09-10
2502

Re: [Résolu] La mise à jour vers la 2.1.0 est-elle sûre pour les plugins?

attention, pour les plugins dépendant de GrumPluginClasses, une procédure particulière est à suivre !
[Forum, post 142256 by grum in topic 17695] Problème après upgrade en 2.1

sont concernés :
- Advanced Menu Manager
- LMT
- AStat
- UserStat


Mes photos avec Piwigo évidemment !
[ www.grum.fr ] [ photos.grum.fr ]

Hors ligne

#11 2010-05-18 20:50:21

dragonballed
Membre
2010-02-25
72

Re: [Résolu] La mise à jour vers la 2.1.0 est-elle sûre pour les plugins?

Okok je n'utilise pas ces plugins. Donc, si tous mes plugins sont à jour je peux lancer la MAJ?

Pour le style, j'utilise ce thème: http://fr.piwigo.org/ext/extension_view.php?eid=230
Dois-je faire quelque manips avant ou est-il carrement incompatible?

Merci!

Hors ligne

#12 2010-05-18 21:06:04

P@t
Équipe Piwigo
Nice
2007-06-13
5694

Re: [Résolu] La mise à jour vers la 2.1.0 est-elle sûre pour les plugins?

Pilou bis a écrit:

Bonjour,

Après avoir mis à jour Piwigo, et le plugin PWG Stuffs, dès que j'active le plugin PWG Stuffs, j'obtiens ceci en page d'accueil de la gallerie ...

Code:

Warning: include(./plugins/PWG_Stuffs/modules/Personal/main.inc.php) [function.include]: failed to open stream: No such file or directory in /mounted-storage/*********/plugins/PWG_Stuffs/include/class.inc.php  on line 86

Warning: include(./plugins/PWG_Stuffs/modules/Personal/main.inc.php) [function.include]: failed to open stream: No such file or directory in /mounted-storage/*********/plugins/PWG_Stuffs/include/class.inc.php on line 86

Warning: include() [function.include]: Failed opening './plugins/PWG_Stuffs/modules/Personal/main.inc.php' for inclusion (include_path='.:/usr/share/php5/') in /mounted-storage/*********/plugins/PWG_Stuffs/include/class.inc.php on line 86

Warning: include(./plugins/PWG_Stuffs/modules/Random/main.inc.php) [function.include]: failed to open stream: No such file or directory in /mounted-storage/*********/plugins/PWG_Stuffs/include/class.inc.php on line 86

Warning: include(./plugins/PWG_Stuffs/modules/Random/main.inc.php) [function.include]: failed to open stream: No such file or directory in /mounted-storage/*********/plugins/PWG_Stuffs/include/class.inc.php on line 86

Warning: include() [function.include]: Failed opening './plugins/PWG_Stuffs/modules/Random/main.inc.php' for inclusion (include_path='.:/usr/share/php5/') in /mounted-storage/*********/plugins/PWG_Stuffs/include/class.inc.php on line 86

Warning: Cannot modify header information - headers already sent by (output started at /mounted-storage/*********/plugins/PWG_Stuffs/include/class.inc.php:86) in /mounted-storage/*********/include/page_header.php on line 98

Merci d'avance de votre aide.

Désolé, grosse boulette de ma part, problème corrigé avec la version 2.1.b de PWG Stuffs


P@t

Hors ligne

#13 2010-05-19 06:47:37

Pilou bis
Membre
2008-02-15
143

Re: [Résolu] La mise à jour vers la 2.1.0 est-elle sûre pour les plugins?

Merci beaucoup P@t.

Hors ligne

  •  » Installation
  •  » [Résolu] La mise à jour vers la 2.1.0 est-elle sûre pour les plugins?

Pied de page des forums

Propulsé par FluxBB

github twitter facebook newsletter Faire un don Piwigo.org © 2002-2019 · Contact