#1 2009-11-20 13:37:59

Eric
Équipe Piwigo
VALENCE (FR)
2005-03-25
4579

[Résolu] [Dev Piwigo] Tester avant de commiter

Bonjour à tous.

[HS]Je poste ici car je n'ai pas trop le temps de m'attacher à traduire mes propos sur le forum EN[/HS]

Suite à une discussion privée avec Nicolas sur les tests unitaires avant commit de modifications de code sur le core de Piwigo (Trunk de SVN):

Eric a écrit:

A ma décharge, je n'ai jamais réussi à faire fonctionner une galerie installée en local (Wampserver) à partir du Trunk de Piwigo qui serait pourtant l'idéal pour tester des modifs avant de les commiter.

(...)

    Pourquoi pas une galerie "Trunk" en ligne sous piwigo.com qui servirait de référentiel pour les tests ?

Nicolas a écrit:

Cela s'appelle de l'intégration continue. Mais il n'est pas conseillé de mettre la machine en libre accès !

Eric a écrit:

Lorsqu'une modif est codée, avant de la commiter sur le trunk SVN (et par extension, Branch), on l'applique sur cette galerie qui servirait de référentiel pour tous. Ce qui fonctionne sur cette galerie serait alors éligible au commit et on travaillerait tous sur une même base de test.

    Le problème : Comment permettre l'application de modifs sur cette galerie qui toucheraient la structure de la base de données ? Et, surtout, comment faire pour faire machine arrière lorsque ce n'est pas bon ?

Nicolas a écrit:

Non il faut faire ces tests avant le commit. Un commit ne doit rien cassé. Une fois mon histoire d'abstraction de base de données, soit je m'attaque aux tests (unitaires et fonctionnels) soit à l'internationnalisation avec gettext.

Il est évident de tester les modifications apportées au code de Piwigo *avant* de les commiter sur le trunk. L'idéal serait donc de tester sur une galerie installée à partir du Trunk.
Mais, comme je l'indique ci-dessus, je n'arrive pas à installer correctement une galerie en local (sous Wampserver) en utilisant le code du Trunk. Soit il y a des erreurs à la création des tables et il faut les traiter manuellement (pas top s'il faut faire çà à chaque fois pour repartir sur une install propre), soit des fonctionnalités ne sont pas complètement présentes - code non terminé (ce serait étonnant) ? Ou pb d'intégration ? Je n'en sais rien... Peut-être aussi est-ce moi qui m'y prend mal ?

Bref, personnellement, je galère et j'ai pris le parti d'installer une galerie de test locale à partir de la dernière release publiée de Piwigo. Mais comme tous les derniers commit ne sont pas intégrés à cette install, les éventuels effets de bord ne sont pas gérés et les tests sont, de fait, caduques.

L'intégration en ligne (sur une galerie de test sous piwigo.org, par exemple, et qui serait issue d'une install du Trunk mais pas en accès libre) que j'ai soumis est peut-être une solution mais qui apporte aussi son lot de contraintes et de problèmes notamment lorsqu'il y a des manipulations en base de données à la clef.

En fait, tout ce résoudrait si je parvenais à installer localement une galerie issue du Trunk...

Hors ligne

#2 2009-11-20 13:53:39

ddtddt
Équipe Piwigo
Quetigny (21) - France
2007-07-27
14740

Re: [Résolu] [Dev Piwigo] Tester avant de commiter

j'utilises wampserveur pour Br2 et trunk sans problème


Vous aimez Piwigo alors n'hésitez pas à participer avec nous, plus d'infos sur la page "Contribuer à Piwigo". Si vous n'avez pas beaucoup de temps et que vous souhaitez nous soutenir vous pouvez aussi le faire par un don.

Hors ligne

#3 2009-11-20 13:58:05

ddtddt
Équipe Piwigo
Quetigny (21) - France
2007-07-27
14740

Re: [Résolu] [Dev Piwigo] Tester avant de commiter

Eric a écrit:

L'intégration en ligne (sur une galerie de test sous piwigo.org, par exemple, et qui serait issue d'une install du Trunk mais pas en accès libre) que j'ai soumis est peut-être une solution mais qui apporte aussi son lot de contraintes et de problèmes notamment lorsqu'il y a des manipulations en base de données à la clef.

Une petite recherche sur le forum privé


Vous aimez Piwigo alors n'hésitez pas à participer avec nous, plus d'infos sur la page "Contribuer à Piwigo". Si vous n'avez pas beaucoup de temps et que vous souhaitez nous soutenir vous pouvez aussi le faire par un don.

Hors ligne

#4 2009-11-20 14:08:33

Eric
Équipe Piwigo
VALENCE (FR)
2005-03-25
4579

Re: [Résolu] [Dev Piwigo] Tester avant de commiter

ddtddt a écrit:

Eric a écrit:

L'intégration en ligne (sur une galerie de test sous piwigo.org, par exemple, et qui serait issue d'une install du Trunk mais pas en accès libre) que j'ai soumis est peut-être une solution mais qui apporte aussi son lot de contraintes et de problèmes notamment lorsqu'il y a des manipulations en base de données à la clef.

Une petite recherche sur le forum privé

Vu ;-)

Hors ligne

#5 2009-11-20 15:01:56

VDigital
Former Piwigo Team
Paris (FR)
2005-05-04
15124

Re: [Résolu] [Dev Piwigo] Tester avant de commiter

Eric a écrit:

Eric a écrit:

A ma décharge, je n'ai jamais réussi à faire fonctionner une galerie installée en local (Wampserver) à partir du Trunk de Piwigo qui serait pourtant l'idéal pour tester des modifs avant de les commiter. .../...

En fait, tout ce résoudrait si je parvenais à installer localement une galerie issue du Trunk...

Wampserver avec Trunk et Branch 2.0 installée en local.
Hyper-simple sans le moindre sushi.
Mieux qu'une lettre à la poste dirait Olivier B.
;-)

Un topic dédié à initier.


Vincent -« Plus vidéaste averti que photographe amateur... »
La galerie - Le blog   

Piwigo est une application libre de gestion de photos en ligne.

Hors ligne

#6 2009-11-20 15:20:10

Eric
Équipe Piwigo
VALENCE (FR)
2005-03-25
4579

Re: [Résolu] [Dev Piwigo] Tester avant de commiter

VDigital a écrit:

Eric a écrit:


En fait, tout ce résoudrait si je parvenais à installer localement une galerie issue du Trunk...

Wampserver avec Trunk et Branch 2.0 installée en local.
Hyper-simple sans le moindre sushi.
Mieux qu'une lettre à la poste dirait Olivier B.
;-)

Un topic dédié à initier.

%@$!

Je ne pensais pas être un "manchot" quand à l'utilisation de Wampserver...

- Je créé une base pwg_trunk et une autre pwg_branch
- Je créé deux dossiers dans mon www : pwg_trunk et pwg_branch. Et je créé des alias en rapport.
- J'extrais une copie du trunk SVN vers pwg_trunk. Idem avec Branch vers pwg_branch.
- Je lance l'install.php sur pwg_trunk avec les bons paramètres d'accès à la bdd : "Piwigo is already installed" alors que le mysql.inc.php est vide !
- Je lance l'install.php sur pwg_branch : RAS.

C'est moi ou quoi ?

Hors ligne

#7 2009-11-20 15:37:13

ddtddt
Équipe Piwigo
Quetigny (21) - France
2007-07-27
14740

Re: [Résolu] [Dev Piwigo] Tester avant de commiter

Eric a écrit:

C'est moi ou quoi ?

C'est toi :-)

Un problème dans l'alias ? [il suffit d'ailleurs appeler le répertoire mm sans alias]

Supprime le fichier des paramétrer de la base de données qui doit être présent dans ton installation


Vous aimez Piwigo alors n'hésitez pas à participer avec nous, plus d'infos sur la page "Contribuer à Piwigo". Si vous n'avez pas beaucoup de temps et que vous souhaitez nous soutenir vous pouvez aussi le faire par un don.

Hors ligne

#8 2009-11-20 15:47:35

nicolas
Former Piwigo Team
2004-12-30
1535

Re: [Résolu] [Dev Piwigo] Tester avant de commiter

Eric a écrit:

- Je créé une base pwg_trunk et une autre pwg_branch
- Je créé deux dossiers dans mon www : pwg_trunk et pwg_branch. Et je créé des alias en rapport.
- J'extrais une copie du trunk SVN vers pwg_trunk. Idem avec Branch vers pwg_branch.
- Je lance l'install.php sur pwg_trunk avec les bons paramètres d'accès à la bdd : "Piwigo is already installed" alors que le mysql.inc.php est vide !
- Je lance l'install.php sur pwg_branch : RAS.

C'est moi ou quoi ?

C'est toi ! :-) Mais ce n'est pas perdu !

Tu as bien deux bases de données ?
Quand tu dis je crée deux dossiers, ce sont bien des copies de travail (subversion; au moins pour trunk) ?
L'installation dans trunk, tu n'as besoin de la faire qu'une seule fois. Tu viens de la faire l'installation dans trunk ? Avec mon dernier commit ?


Donnez du peps à vos tags
Laissez vos visiteurs vous aidez à tagger vos images avec user_tags

Hors ligne

#9 2009-11-20 23:25:30

Eric
Équipe Piwigo
VALENCE (FR)
2005-03-25
4579

Re: [Résolu] [Dev Piwigo] Tester avant de commiter

ddtddt a écrit:

C'est toi :-)

Un problème dans l'alias ? [il suffit d'ailleurs appeler le répertoire mm sans alias]

Supprime le fichier des paramétrer de la base de données qui doit être présent dans ton installation

- Pas d'alias, appel direct du site par l'url http:\\localhost\pwg_trunk
- Fichier de paramétrage systématiquement effacé avant chaque tentative d'install


Nicolas a écrit:

C'est toi ! :-) Mais ce n'est pas perdu !

Tu as bien deux bases de données ?
Quand tu dis je crée deux dossiers, ce sont bien des copies de travail (subversion; au moins pour trunk) ?
L'installation dans trunk, tu n'as besoin de la faire qu'une seule fois. Tu viens de la faire l'installation dans trunk ? Avec mon dernier commit ?

- J'ai bien 2 bases pwg_trunk et pwg_branch. pwg_trunk est vierge mais pas pwg_branch puisque là, tout fonctionne bien.
- Chaque dossier pwg_trunk et pwg_branch est une copie de travail de subversion (extraite avec Tortoise SVN). J'ai bien la surcharge d'icones en vert.
- J'ai fait l'installation une seule fois de pwg_branch sans aucun pb. Mais c'est l'installation initiale (et unique) de pwg_trunk qui m'affiche sans arrêt que "Piwigo is already installed" alors que mysql.inc.php n'existe pas !

J'ai effectué exactement les même manip pour l'install de pwg_branch, issue du SVN de la branche 2.0, sans aucun pb. Une lettre à la poste d'O.B. (comme dirait VDigital).

C'est bien ma 7ème tentative sans succès depuis mon retour du boulot. Là, je fatigue. Je reprendrai tout à zéro (encore une fois) demain...

Hors ligne

#10 2009-11-21 00:03:36

VDigital
Former Piwigo Team
Paris (FR)
2005-05-04
15124

Re: [Résolu] [Dev Piwigo] Tester avant de commiter

Je pensais l'avoir écrit dans un post mais je ne le retrouve plus.

Chez moi, ma copie-SVN est quelque part dans l'arborescence de www.
Je crée bien autant de bases que je veux pas de problème.

Exemple:

Index of /svn-org
[ICO] Name               Last modified            Size    Description
[DIR] Parent Directory                                  -
[DIR] WordPress/     06-Nov-2009 22:24     -
[DIR] branches/       16-Apr-2009 14:06      -
[DIR] extensions/    19-Nov-2009 07:16      -
[DIR] trunk/             14-May-2009 00:29      -

Quand je clique sur trunk... je suis sur ma galerie du tronc commun en développement.
et sur branches/2.0... sur la branche en cours.

Où est le pb?


Vincent -« Plus vidéaste averti que photographe amateur... »
La galerie - Le blog   

Piwigo est une application libre de gestion de photos en ligne.

Hors ligne

#11 2009-11-21 12:59:50

Eric
Équipe Piwigo
VALENCE (FR)
2005-03-25
4579

Re: [Résolu] [Dev Piwigo] Tester avant de commiter

VDigital a écrit:

Je pensais l'avoir écrit dans un post mais je ne le retrouve plus.

Chez moi, ma copie-SVN est quelque part dans l'arborescence de www.
Je crée bien autant de bases que je veux pas de problème.

Exemple:

Index of /svn-org
[ICO] Name               Last modified            Size    Description
[DIR] Parent Directory                                  -
[DIR] WordPress/     06-Nov-2009 22:24     -
[DIR] branches/       16-Apr-2009 14:06      -
[DIR] extensions/    19-Nov-2009 07:16      -
[DIR] trunk/             14-May-2009 00:29      -

Quand je clique sur trunk... je suis sur ma galerie du tronc commun en développement.
et sur branches/2.0... sur la branche en cours.

Où est le pb?

Cà y est ! J'ai enfin réussi à installer une galerie Trunk en local ! Comme quoi, une bonne nuit de sommeil...

Depuis le début, j'ai exactement la même structure que toi, VDigital (modulo WordPress évidemment et mes copies locales de mes sites web) dans mon www de Wampserver. Chaque installation de galerie, que ce soit Branch, Trunk ou les galeries incluses dans mes sites locaux, disposent bien d'une base de données qui leur est propre.

Mes [DIR] Branch et Trunk sont bien issus d'un checkout (je vais utiliser le terme anglais pour être sure que l'on parle bien de la même chose) initial de Tortoise SVN et sont géré comme tel. C'est à dire que je peux mettre à jour (SVN update) ou livrer (SVN commit) ou toute autre action liée à SVN à partir de ces dossiers.

Pour Branch, pas de problème. L'installation de la galerie en local fonctionne très bien et tout le reste aussi. Mais pour Trunk, jusqu'à ce matin, impossible !

Ce que j'ai fait entre hier soir (où çà ne fonctionnait pas) et ce matin (où çà fonctionne) :
- Mise à jour de Tortoise SVN à la dernière version stable. Je n'y croyais pas trop vu le changelog et je n'avais qu'une version mineure d'écart. Mais bon, çà ne mangeait pas de pain.
- SVN Cleanup du dossier ../www/Trunk puis re-test d'install : NOK
- Suppression locale complète de mon dossier .../www/Trunk et recréation d'un dossier local au même endroit et avec le même nom puis re SVN Checkout.
- Relance de l'install... Et là, çà a marché !

Alors, bug de Tortoise SVN ou problème avec un update de mon Trunk original ? Difficile à dire. Mais l'important est que çà fonctionne correctement maintenant.

Je passe en résolu.

Dernière modification par Eric (2009-11-21 18:47:53)

Hors ligne

Pied de page des forums

Propulsé par FluxBB

github twitter facebook newsletter Faire un don Piwigo.org © 2002-2020 · Contact