•  » Installation
  •  » [Résolu] Https et images non visibles

#1 2017-12-01 23:14:00

Eric B
Membre
2003-10-02
231

[Résolu] Https et images non visibles

Bonjour/Bonsoir,

J aimerais basculer définitivement ma galerie en https, cad avec SSL.
Pour l instant, les 2 versions sont accessibles:
http://photo.eric-creation.com
https://photo.eric-creation.com

La 1ere fonctionne bien, mais la 2nd en https n affiche aucune photo. Pourquoi?
Est ce un soucis de piwigo ou de mon hébergeur?

J'ai MAJ piwigo et toutes les extensions.

Je viens de lire la doc sur les images manquantes, le cas https n est pas cité.
http://fr.piwigo.org/doc/doku.php?id=ut … manquantes

Dernière modification par Eric B (2017-12-02 11:47:00)

Hors ligne

#2 2017-12-02 00:11:27

k5
Membre
lieu
2014-01-26
277

Re: [Résolu] Https et images non visibles

Bonjour Eric B, par exemple voir ci dessous


Images attachées


Ayez comme premier réflexe de faire les mises à jours piwigo et extensions. merci

Hors ligne

#3 2017-12-02 11:45:55

Eric B
Membre
2003-10-02
231

Re: [Résolu] Https et images non visibles

???
chez toi, les images s'affichent correctement en https, mais pas chez moi, comment est ce possible?

Hors ligne

#4 2018-01-23 22:46:40

Eric B
Membre
2003-10-02
231

Re: [Résolu] Https et images non visibles

J'ai tjs pas trouvé de solution à mon pb. Des idées?

Hors ligne

#5 2018-01-24 07:20:08

BrandonCougar
Membre
Lille
2013-05-04
176

Re: [Résolu] Https et images non visibles

Bonjour,

étrange... je ne vois pas les photos non plus mais pourtant ça devrait fonctionner... si je récupère l'url d'une image, en https elle s'affiche normalement.

https://photo.eric-creation.com/_data/i … ee_-th.jpg

Hors ligne

#6 2018-01-24 20:48:49

flop25
Équipe Piwigo
2006-07-06
6407

Re: [Résolu] Https et images non visibles

anti hotlink foireux? Bref je pense à des driectives serveurs qui posent problème

Hors ligne

#7 2018-01-25 16:24:19

k5
Membre
lieu
2014-01-26
277

Re: [Résolu] Https et images non visibles

Bonjour, ce que l'on sait c'est que vos sites sont sur des sous-domaines acceptant le https/http. l'erreur 403 sur l'image de la mariée que Brandoncougar a ecris est dans /_data/.

1ére idée : essayer l'extension force HTTPS de piwigo Force https

2éme idée : installer le dernier piwigo de base avec une photo de test sur le https
pour le tester : il y a l'ip local (normalement par ex c'est du localhost),... par telephone portable (tester en 4g, 3g...si vous avez)

3éme idée : verifier s'il vous plait les permissions de i.php. Chmod : 755 dossiers, 644 fichiers.

4ème idée : hotlink ? directives serveurs ? ssl ? Possible

Cordialement
k5


Ayez comme premier réflexe de faire les mises à jours piwigo et extensions. merci

Hors ligne

#8 2018-01-26 09:47:05

Eric B
Membre
2003-10-02
231

Re: [Résolu] Https et images non visibles

merci de vos retours.
J'ai ouvert un ticket chez mon hébergeur. Qui m'a alors rapidement rappelé que j avais créé un .htaccess à la racine pour limiter les accès aux images (généré par cPanel/protection contre les hotlinks): j'y avais inscris les domaines autorisés pour mes images.
J'ai alors remplacé les adresses http par des adresses https.
Maintenant cela fonctionne comme souhaité, cad à l'envers: images visibles en https mais PAS en http!

Dernière modification par Eric B (2018-01-26 11:52:26)

Hors ligne

#9 2018-02-07 08:20:23

Benoit
Membre
78
2009-10-22
380

Re: [Résolu] Https et images non visibles

Saut sur le lien https://photo.eric-creation.com/_data/i … ee_-th.jpg, si on ajoute un "www" dans l'url, elle apparait.

Hors ligne

  •  » Installation
  •  » [Résolu] Https et images non visibles

Pied de page des forums

Propulsé par FluxBB

github twitter facebook newsletter Faire un don Piwigo.org © 2002-2018 · Contact