FAQ-Debug : Mes images n'apparaissent pas !

Bienvenue sur ce guide : suivez les questions et instructions

Si vous ne comprenez pas une expression technique, merci d'utiliser un moteur de recherche, Google ou la recherche de la Documentation Piwigo ou celle du forum etc

Pour les miniatures de contenu non-image (vidéo, son etc), en 2.4 le dossier thumbnail n'existe plus, donc il faut utiliser le dossier pwg_representative (cf la page Photos→Ajouter→Ftp+Synchro onglet)

1) Est-ce que vos images sont enregistrées dans Piwigo ?

Dans l'administration, allez dans la Gestion par Lot et sélectionner dans les filtres l'album dans lequel les photos sont censées apparaître. Une fois le filtre validé, des images miniatures devraient apparaître :

  • si vous obtenez “Aucune photo sélectionnée, aucune action possible.”, l'envoi de vos photos n'a pas eu lieu : vérifiez que vos photos ne sont pas trop grosses selon les informations écrites sur Photos→Ajouter “20MB. jpeg, png, gif.” par exemple.
  • si vous voyez “parmi les XX photos du lot” mais qu'aucune image n'apparaît, lisez le paragraphe 2.
  • si vous voyez “parmi les XX photos du lot” et des miniatures, lisez le paragraphe 3.

2) Mes images sont enregistrées, mais pas de miniatures !

Depuis la version 2.4, Piwigo a un système de génération automatique des miniatures et autres images retaillées. Piwigo appelle le fichier i.php pour générer les images retaillées dans ./_data/i/, puis une fois que l'image retaillée a été générée dans ce cache, Piwigo appelle directement l'image retaillée depuis ./_data/i/ . Ainsi plusieurs problèmes peuvent apparaître : surcharge serveur, image trop grosse/lourde ou avec une mauvaise extension de fichier, pas assez de permission sur les fichiers/dossiers…

  1. Vérifiez tout d'abord si une erreur est retournée par l'url d'appel à i.php : Dans l'administration, allez dans la Gestion par Lot ; dans votre navigateur, clic droit sur une image non-générée, puis “Afficher l'image”. Vous pouvez aussi afficher le code source html de la page Ctrl+U souvent) puis chercher (Ctrl+F) une url contenant “i.php”. Allez à cette adresse url avec votre navigateur, et notez les erreurs affichées
    1. “source not found” : vérifiez par Ftp si l'image source/d'origine existe bien (dans upload ou galleries, c'est marqué dans l'url après “i.php?”. D'ailleurs, si ce chemin est faux, postez sur le forum) et si les permissions sur les fichiers et dossiers sont suffisantes (Chmod : 755 folders, 644 files). Si cela ne marche toujours pas, vérifiez que l'utilisateur système Php a assez de droits sur votre serveur (contactez votre hébergeur)
    2. “dir create error” : vérifiez par Ftp si les permissions sur les fichiers et dossiers sont suffisantes (Chmod : 755 folders, 644 files). Si cela ne marche toujours pas, vérifiez que l'utilisateur système Php a assez de droits sur votre serveur (contactez votre hébergeur)
    3. “Empty array while parsing Sizing” “Sizing arr” “Invalid chars in request”… : un thème ou plugin ne marche pas correctement : assurez-vous qu'ils soient à jour et compatibles avec votre version de Piwigo.
    4. 404 error page : le fichier i.php est manquant. Téléchargez le package complet depuis piwigo.org, extrayez les fichiers et uploadez les par Ftp en écrasant les fichiers existants (vous ne perdrez aucune configuration).
    5. 403 error page : vérifiez les permissions de i.php. Chmod : 755 dossiers, 644 fichiers.
    6. “500 Internal error page” ou “PHP Fatal Error: Allowed memory size of …” : plusieurs problèmes peuvent générer ces erreurs. Si quelques images sont générées et d'autres non, cela peut être du à une surcharge temporaire de votre serveur : attendez ou contactez votre hébergeur. Il est aussi possible que la mémoire allouée à Php soit insuffisante pour les images que vous avez uploadées : augmentez ou demandez à votre hébergeur d'augmenter memory_limit. Si la librairie graphique est GD (visible sur la première page d'administration), nous recommandons fortement l'utilisation de Imagemagick à la place : lisez le paragraphe au sujet d'Imagemagick plus bas.
  2. Pas de message?
    1. Avec le plugin Localfiles Editor, ajoutez cette ligne “$conf['enable_i_log'] = true;” à la configuration locale. Ensuite essayez de générer des images via le Gestionnaire par Lot. Une fois ceci fait, allez chercher par Ftp le fichier _data/tmp/i.log et ouvrez le afin de vérifier la présence éventuelle d'erreurs.
    2. Vous pouvez aussi lire les instructions ci-dessus pour “500 Internal error page” et utiliser Imagemagick.

3) Je vois les miniatures, mais pas d'image ou de miniature visible dans la partie publique de ma galerie

La plupart du temps, il s'agit d'un problème de permissions :

  1. Vérifier le niveau de permission “Qui peut voir ces photos” : dans la Gestion par Lot, cliquer sur Éditer au survol d'une image. Ensuite vérifier le niveau de permission, “Qui peut voir ces photos”. Il faut aussi vérifier si les utilisateurs -dont vous- sont autorisés correctement : allez sur Utilisateurs→Gérer→Propriétés colonne et vérifier que le niveau de permission est suffisant par rapport à celui marqué pour l'image.

Astuce : Sur la page de Gestion par Lot, si l'image a un niveau de permission différent de “Tout le monde”, ce niveau est marqué sur la miniature.

  1. Vérifiez la visibilité des albums : allez dans Album→Propriétés, et vérifier si les albums sont privés ou non. Si un album est privé alors qu'il ne le devrait pas, sélectionner le et cliquer sur la flèche en bas pour le faire passer public. Si vous avez mis vos albums privés volontairement, allez vérifier qui a accès à l'album en allant sur Album→Gérer : naviguer jusqu'à l'album et cliquer sur Éditer. Aller dans l'onglet Permissions pour s'assurer de la visibilité de l'album en fonctions des comptes utilisateurs.

Activer le plugin Multi View est la manière la plus rapide et efficace pour vérifier la visibilité des images et albums en fonctions des comptes utilisateurs : dans la pop-up qui s'ouvre, utiliser le menu déroulant pour sélectionner un autre utilisateur et voir son rendu de la galerie

Il peut aussi s'agir d'un problème de Template (modèle) ou Thème non mis à jour : désactivez vos templates et essayez un thème par défaut de Piwigo

Utiliser Imagemagick

Imagemagick (IM) est bien plus efficace que l'autre libraire graphique GD : moins de ressources utilisées et une meilleure qualité dans les images générées. Non seulement pas mal de problèmes peuvent être résolus en utilisant IM, mais votre serveur sera moins sollicité et, dans le cas d'un hébergement mutualisé, votre hébergeur sera content. Utilisez les variables de configuration suivantes avec le plugin Localfiles editor :

// Library used for image resizing. Value could be 'auto', 'imagick',
// 'ext_imagick' or 'gd'. If value is 'auto', library will be choosen in this
// order. If choosen library is not available, another one will be picked up.
$conf['graphics_library'] = 'ext_imagick';
// If library used is external installation of ImageMagick ('ext_imagick'),
// you can define imagemagick directory.
$conf['ext_imagick_dir'] = '/usr/local/bin/convert';//A changer selon votre installation!

Demandez à votre hébergeur le chemin d'installation des binaires d'Imagemagick.

Problème non résolu ?

Si cela ne vous a malheureusement pas aidé, poster sur le forum : soyez poli, écrivez ce que vous avez fait, et ajoutez toujours un lien vers votre galerie avec au moins quelques images publiques, Merci.

 
Haut de page
utiliser/apprendre/faq/images_manquantes.txt · Dernière modification: 2017/06/14 16:32 par katryne
 
 
github twitter facebook google+ newsletter Faire un don Piwigo.org © 2002-2017 · Contact