#1 2012-06-24 18:58:46

FDRT
Membre
2012-06-24
3

Migration 2.4 sur NAS personnel

Bonjour à tous,

Tous d'abord un grand merci à l'équipe piwigo pour ce superbe outil trés simple à installer et à utiliser. Bravo !

Je suis un peu "newbie" dans ce domaine. J'ai installé un site piwigo voici à peine un mois. En fait, je cherchais à créer ma gallerie personnelle. J'ai regardé du côté des hébergeurs spécialisés (pbase, deviant, 500pics, ...) et finalement, je n'étais satisfait par aucun en particuliers. Il manquait toujours quelque chose. Et puis je suis tombé sur piwigo et zenphoto. Un concept me permettant d'installer tout chez moi, sur mon serveur. J'ai trouvé le forum piwigo plus actif que celui de zenphoto, alors je me suis lancé pour celui-ci. Et je ne le regrette pas: 10 minutes pour l'installer sur mon serveur et moins d'un week-end pour avoir un site fonctionnel et customisé avec déjà plein de photos dedans.

Ma configuration est la suivante: tout tourne chez moi sur un serveur NAS Synology CS209 (proc 1.2Ghz et 256 Mo de RAM).

Tout tournait impeccablement bien jusqu'au passage de la 2.4. Je m'étais fait une custo avec le theme de Gbo (clin d'oeil)  et j'avais pas mal de plugins activés. Mon site était vraiment bien personnalisé.

Au passage à la 2.4, quelle horreur ! Plus rien ne fonctionne ou presque et/ou tout est d'une lenteur abominable. En plus de la custo, toutes les vignettes et les photos ont disparues. Parfois, quelques-unes apparaissent mais lorsque l'on clique dessus pas de photos. En cherchant un peu le problème et avec un peu de patience, je crois avoir compris le problème.  La création des vignettes et des différents formats utiles se fait "à la volée" sur cette nouvelle version. Lorsque l'on affiche une page, piwigo va demander au serveur de générer les vignettes si elles n'existent pas déjà. Mon propre petit NAS est alors "surchargé" (processeur à 100% tout le temps de la génération qui peut prendre environ 1 minute par photo) ...

La solution est donc d'aller dans l'outil d'administration et, via la gestion de photo par lot, de sélectionner l'ensemble des photos du site (on est pas obligé de tout faire d'un coup !) et de lancer la génération des différentes tailles. Pendant tout le temps de la génération, le serveur n'est pratiquement plus accessible tellement il est occupé. Mais, une fois, les différents formats générés, le serveur retrouve son état "normal" et le temps d'affichage d'une page du site redevient normal.

A noter aussi, que la nouvelle fonctionnalité de watermark, oblige à régénérer les photos si l'on ne veux pas avoir les mêmes déboires de temps de latence du serveur à chaque consultation. Mieux vaut donc bien préparer son watermark (ou non), une fois pour toute !

Enfin, le nouveau thème "élégant" fourni avec cette nouvelle version est trés sympa. La fonctionnalité pour masquer le menu est trés bien vu ! Je me demande si je ne vais pas l'adopter finalement ?

Voilà, je poste ce message:
1- Pour avoir confirmation du comportement de génération de vignettes "à la volée" que je décris ci-dessus par la Piwigo's dream team ? Ou bien cette saturation du proc proviendrait-elle d'un autre phénomène ?
2- Pour avertir les utilisateurs de NAS de cette petite difficulté de la migration, qui n'a rien de rédhibitoire mais qui pourrait rendre indisponible pendant quelques temps un serveur (le temps de régénérer toutes les tailles de toutes les photos)   !

Il ne reste plus qu'à attendre que les plugins soient mis à jour pour cette version. A ce propos (question subsidiaire!), je suis sous linux; le ploader actuel fonctionne-t-il avec cette nouvelle version. Y a-t-il une nouvelle version ?

Je conclurais par "tout est bien qui fini bien". Franchement, j'invite aussi tous ceux qui ont l'intention de créer une galerie web sans l'avoir fait jusqu'à présent de regarder sérieusement vers cette nouvelle version de piwigo. C'est simple, customisable à souhait, et le forum est une mine d'or pour un support en cas de problème.


Cordialement
FDRT

Hors ligne

#2 2012-06-24 19:11:04

Gotcha
Equipe Piwigo
Pierrelatte (26)
2007-03-14
13324

Re: Migration 2.4 sur NAS personnel

FDRT a écrit:

Voilà, je poste ce message:
1- Pour avoir confirmation du comportement de génération de vignettes "à la volée" que je décris ci-dessus par la Piwigo's dream team ? Ou bien cette saturation du proc proviendrait-elle d'un autre phénomène ?
2- Pour avertir les utilisateurs de NAS de cette petite difficulté de la migration, qui n'a rien de rédhibitoire mais qui pourrait rendre indisponible pendant quelques temps un serveur (le temps de régénérer toutes les tailles de toutes les photos)   !

Il ne reste plus qu'à attendre que les plugins soient mis à jour pour cette version. A ce propos (question subsidiaire!), je suis sous linux; le ploader actuel fonctionne-t-il avec cette nouvelle version. Y a-t-il une nouvelle version ?

Bonjour,

Merci pour votre retour d'expérience détaillé :-)

Pour répondre à vos questions :
Oui la charge serveur est importante pour générer le cache des fichiers images. Il est donc normal que des petits serveurs soient vite surchargés.
Concernant pLoader je vous invite à lire ceci [Forum, post 188130 by plg in topic 22226] Ploader et version Piwgo 2.4 ?


Ayez comme premier réflexe de consulter le wiki.
Ensuite, veuillez effectuer une recherche sur le forum avant de poser votre question.

LE FAIRE EST LE REVELATEUR DE L'ETRE

Hors ligne

Pied de page des forums

Propulsé par FluxBB

github twitter facebook newsletter Faire un don Piwigo.org © 2002-2019 · Contact