Annonce

  •  » Utilisation
  •  » Fatal Error à la connexion Administrateur

#1 2022-08-31 15:28:24

Philindy26
Membre
Drôme (26)
2013-02-01
110

Fatal Error à la connexion Administrateur

Bonjour/Bonsoir,

Depuis quelques jours, quand je veux me connecter en tant qu'administrateur, j'ai l'erreur suivante :

Fatal error: Uncaught Error: Function name must be a string in /home/philindy/public_html/piwigotest/plugins/no_stats_for_robots/main.inc.php:1 Stack trace: #0 /home/philindy/public_html/piwigotest/include/functions_plugins.inc.php(350): include_once() #1 /home/philindy/public_html/piwigotest/include/functions_plugins.inc.php(435): load_plugin(Array) #2 /home/philindy/public_html/piwigotest/include/common.inc.php(142): load_plugins() #3 /home/philindy/public_html/piwigotest/identification.php(11): include_once('/home/philindy/...') #4 {main} thrown in /home/philindy/public_html/piwigotest/plugins/no_stats_for_robots/main.inc.php on line 1

Sur mon 1er site (https://photos-dromoises.fr/albumpiwigo/), j'ai supprimé tous les plugins par FTP, mais cela n'a pas été suffisant... Alors j'ai renvoyé les fichiers de Piwigo comme une mise à jour en manuelle... Et cela refonctionne...

Par contre, sur mon site de secours, j'ai le même problème...
J'ai regardé sur le forum, mais je n'ai pas retrouvé ces erreurs...

Est-ce que vous pouvez me donner les raisons de ces erreurs ?


PS : Hors administrateur, les sites fonctionnent !!!

Philindy26


Environnement :

Piwigo 12.3.0
PHP: 7.4.29
MySQL: 5.5.5-10.3.35-MariaDB
Bibliothèque graphique: External ImageMagick 6.9.10-68

Hors ligne

#2 2022-09-01 20:26:41

Philindy26
Membre
Drôme (26)
2013-02-01
110

Re: Fatal Error à la connexion Administrateur

Bonsoir,

Ce soir, mon 1er site est reparti en live avec une erreur fatale à la connexion administrateur.
L'erreur :
Fatal error: Uncaught Error: Function name must be a string in /home/philindy/public_html/albumpiwigo/include/smarty/libs/sysplugins/smarty_resource.php:1 Stack trace: #0 /home/philindy/public_html/albumpiwigo/include/smarty/libs/Smarty.class.php(89): require_once() #1 /home/philindy/public_html/albumpiwigo/include/template.class.php(13): require_once('/home/philindy/...') #2 /home/philindy/public_html/albumpiwigo/include/common.inc.php(99): include('/home/philindy/...') #3 /home/philindy/public_html/albumpiwigo/identification.php(11): include_once('/home/philindy/...') #4 {main} thrown in /home/philindy/public_html/albumpiwigo/include/smarty/libs/sysplugins/smarty_resource.php on line 1

Je ne peux plus me connecter en administrateur...  sinon il fonctionne !!!
https://photos-dromoises.fr/albumpiwigo/


Est-ce que quelqu'un a une idée ?
Merci d'avance
Philindy26

Dernière modification par Philindy26 (2022-09-01 20:29:39)

Hors ligne

#3 2022-09-02 09:20:54

dreamer
Membre
St Cyr/mer (83)
2006-02-26
929

Re: Fatal Error à la connexion Administrateur


beauxvoyages.fr/photos (photos), beauxvoyages.fr/jukebox (musiques) et tout nouveau beauxvoyages.fr/camping (camping-car) le tout en version 12.2

Hors ligne

#4 2022-09-02 16:36:20

Philindy26
Membre
Drôme (26)
2013-02-01
110

Re: Fatal Error à la connexion Administrateur

Bonjour,

Merci beaucoup Dreamer,
J'ai pu me reconnecter en tant qu'Administrateur...
Super et j'espère que cela ne se reproduira plus.

Cordialement,
Philindy26

Hors ligne

#5 2022-09-04 19:49:11

Philindy26
Membre
Drôme (26)
2013-02-01
110

Re: Fatal Error à la connexion Administrateur

Bonsoir,

Cela a fonctionné en lançant : https://photos-dromoises.fr/albumpiwigo/admin.php
Environ 2 jours...

Mais aujourd'hui, de nouveau plus question de se connecter, même avec admin.php...
Voici l'erreur :
Fatal error: Uncaught Error: Function name must be a string in /home/philindy/public_html/albumpiwigo/include/filter.inc.php:1 Stack trace: #0 /home/philindy/public_html/albumpiwigo/include/common.inc.php(281): include() #1 /home/philindy/public_html/albumpiwigo/identification.php(11): include_once('/home/philindy/...') #2 {main} thrown in /home/philindy/public_html/albumpiwigo/include/filter.inc.php on line 1

Je n'ai rien changé..., ni l'identifiant, ni le MDP...
Je ne sais pas ce qui se passe...

Si quelqu'un a une idée ?

Cordialement,
Philindy26

Hors ligne

#6 2022-09-08 10:12:49

Philindy26
Membre
Drôme (26)
2013-02-01
110

Re: Fatal Error à la connexion Administrateur

Bonjour,

Quand je veux me connecter en tant qu'administrateur, je ne peux toujours pas...
Erreur :
Fatal error: Uncaught Error: Function name must be a string in /home/philindy/public_html/albumpiwigo/include/constants.php:1 Stack trace: #0 /home/philindy/public_html/albumpiwigo/include/common.inc.php(97): include() #1 /home/philindy/public_html/albumpiwigo/identification.php(11): include_once('/home/philindy/...') #2 {main} thrown in /home/philindy/public_html/albumpiwigo/include/constants.php on line 1


Quelqu'un a un idée ?

Merci d'avance
Philindy26

Hors ligne

#7 2022-09-23 20:02:20

k5
Équipe Piwigo
La reppe
2014-01-26
1017

Re: Fatal Error à la connexion Administrateur

Bonjour,
oui une idée ! l'arriere plan beige ou gthumb ou google analytics ? hebergeur ?

derniers ressorts: sauvegarde tout (ftp et base de donnée) et d'essayer de tout refaire (sans google analytics).

A très vite

Hors ligne

#8 2022-09-24 10:03:33

Philindy26
Membre
Drôme (26)
2013-02-01
110

Re: Fatal Error à la connexion Administrateur

Bonjour,

Merci de votre réponse

J'ai déjà tout réinstaller une fois
J'ai supprimé le plugin "Statistics" qui utilise Google Analytics

Le vrai problème, c'est que cette erreur n'est pas visible en permanence... et là je ne comprends pas du tout...

Cordialement,
Philindy26

Hors ligne

  •  » Utilisation
  •  » Fatal Error à la connexion Administrateur

Pied de page des forums

Propulsé par FluxBB

github twitter newsletter Faire un don Piwigo.org © 2002-2023 · Contact