Annonce

  •  » Installation
  •  » Problème de Sécurité de mon site HTTPS ?

#1 2021-03-08 18:29:49

Escapade
Membre
2021-02-22
12

Problème de Sécurité de mon site HTTPS ?

Bonjour,

Je suis en train de construire une galerie Piwigo et je dispose d'un hébergement OVH.
Le certificat SSL est activé chez OVH.
Le plugin "Force HTTPS" est activé sur ma galerie.

Je rencontre le problème suivant : dès que j'entre sur mon site (galerie verrouillée cause installation en cours) mon antivirus Norton ferme la page et affiche "Ce site est sûr, mais… il demande des informations personnelles et la communauté Norton ne lui fait pas confiance. Soyez vigilant lorsque vous saisissez vos informations sur ce site... ".
Bien qu'une possibilité de revenir sur le site soit quand même proposée, une telle mise en garde ne fera que fuir les éventuels visiteurs.

Comment remédier à la situation, sachant :
- qu'OVH me renvoie vers l'éditeur du module ?
- que je ne maitrise pas la technique, et encore moins le contenu du dossier .htaccess... que je ne trouve pas.

En vous remerciant pour votre aide.


Version de Piwigo: 11.3.0
Version de PHP: 5.4.45
Version de MySQL: 5.5.30

Dernière modification par Escapade (2021-03-08 18:32:32)

Hors ligne

#2 2021-03-10 10:40:19

Escapade
Membre
2021-02-22
12

Re: Problème de Sécurité de mon site HTTPS ?

Bonjour à tous,
Personne n'a rencontré le même type de problème ?
Personne n'a d'idée pour y remédier ?
La question devrait-elle être posée dans le forum "Utilisation" ?
Merci...

Hors ligne

#3 2021-03-10 10:59:51

ddtddt
Équipe Piwigo
Quetigny (21) - France
2007-07-27
16235

Re: Problème de Sécurité de mon site HTTPS ?

Bonjour,

désactive le plugin et suivant ton offre met le code données par OVH pour forcer le https


Vous aimez Piwigo alors n'hésitez pas à participer avec nous, plus d'infos sur la page "Contribuer à Piwigo". Si vous n'avez pas beaucoup de temps et que vous souhaitez nous soutenir vous pouvez aussi le faire par un don.

Hors ligne

#4 2021-03-10 11:15:14

Escapade
Membre
2021-02-22
12

Re: Problème de Sécurité de mon site HTTPS ?

Merci beaucoup, mais je ne vois pas de quel code tu parles, ni, d'ailleurs, où il faudrait le mettre ?

Hors ligne

#5 2021-03-10 12:21:59

ddtddt
Équipe Piwigo
Quetigny (21) - France
2007-07-27
16235

Re: Problème de Sécurité de mon site HTTPS ?

Bonjour
Bonjour dans le htaccess un truc du genre

RewriteEngine On
RewriteCond %{SERVER_PORT} 80
RewriteRule ^(.*)$ https://ton site/$1 [R,L]


Vous aimez Piwigo alors n'hésitez pas à participer avec nous, plus d'infos sur la page "Contribuer à Piwigo". Si vous n'avez pas beaucoup de temps et que vous souhaitez nous soutenir vous pouvez aussi le faire par un don.

Hors ligne

#6 2021-03-10 18:34:55

Escapade
Membre
2021-02-22
12

Re: Problème de Sécurité de mon site HTTPS ?

Merci pour avoir bien voulu t'intéresser à mon problème, mais je crains fort de ne pas parvenir à le solutionner, car comme je l'ai sous-entendu, je ne maîtrise pas SQL, ni l'écriture des données, car ce n'est pas mon métier !

Du coup... un peu dommage que la galerie Piwigo ne soit pas programmée à l'origine pour respecter les exigences de sécurité Internet contrôlées par les antivirus (ce n'est pas une critique...).

Hors ligne

#7 2021-03-10 19:38:07

Katryne
Membre
Provence
2016-12-03
1210

Re: Problème de Sécurité de mon site HTTPS ?

Hello ! Et ce serait pas possible de paramétrer Norton pour lui indiquer que c'est un site de confiance ? Bon, mais je suis plus dans le bain, parce que ça fait longtemps que je n'utilise plus aucun antivirus sur mon ordi. Juste le Window Defender de série. J'avais l'impression que les anti-virus faisaient de la surenchère en imaginant des tas de barrières nouvelles pour prouver qu'ils étaient meilleurs que la concurrence. Je n'aime pas qu'on décide pour moi ce qui est mieux pour moi et encore moins si c'est un algorithme ou une IA.


https://photos.revestou.fr/  v.12.2 PHP: 7.4.30 - https://dardennes.revestou.fr/ v.11.5 - http://photos.katrynou.fr/ v.11.5 PHP: 7.4.30 https://album.chauvigne.info/ v.12.3.0  PHP: 8.0.22
Système d'exploitation: Linux - Hébergeur 1&1-Ionos - MySQL: 5.7.38
Bibliothèque graphique: External ImageMagick 6.9.10-23

En ligne

#8 2021-03-10 20:09:38

Escapade
Membre
2021-02-22
12

Re: Problème de Sécurité de mon site HTTPS ?

Merci.
En fait c'est Norton "Safe Web" qui alerte en fermant le site avec le message : "Ce site est sûr, mais… il demande des informations personnelles et la communauté Norton ne lui fait pas confiance. Soyez vigilant lorsque vous saisissez vos informations sur ce site... ".

Je pense aussi à de la surenchère, mais le doute s'installera forcément dans la tête de celui qui sera alerté.
En attendant... j'ai désactivé cette option de Norton (je dis bien l'option Safe Web, et pas l'antivirus lui-même).

Hors ligne

#9 2021-03-11 06:16:54

ddtddt
Équipe Piwigo
Quetigny (21) - France
2007-07-27
16235

Re: Problème de Sécurité de mon site HTTPS ?

Bonjour

Escapade a écrit:

Merci pour avoir bien voulu t'intéresser à mon problème, mais je crains fort de ne pas parvenir à le solutionner, car comme je l'ai sous-entendu, je ne maîtrise pas SQL, ni l'écriture des données, car ce n'est pas mon métier !

euh ! je t'ai donné le code tu as juste à remplacer ton site par ton nom de domaine il y a besoins d’aucune connaissance !


Vous aimez Piwigo alors n'hésitez pas à participer avec nous, plus d'infos sur la page "Contribuer à Piwigo". Si vous n'avez pas beaucoup de temps et que vous souhaitez nous soutenir vous pouvez aussi le faire par un don.

Hors ligne

#10 2021-03-11 16:06:22

Escapade
Membre
2021-02-22
12

Re: Problème de Sécurité de mon site HTTPS ?

Simple pour toi... mais très compliqué pour moi, hélas.
Je vais tenter d'obtenir de l'aide... voire abandonner simplement mon projet de galerie !...
Je te remercie néanmoins pour t'être donné la peine de répondre.

Hors ligne

#11 2021-03-11 16:50:22

ddtddt
Équipe Piwigo
Quetigny (21) - France
2007-07-27
16235

Re: Problème de Sécurité de mon site HTTPS ?

Bonjour,

ok

Tu peux aussi essayer piwigo sur l'offre piwigo.com


Vous aimez Piwigo alors n'hésitez pas à participer avec nous, plus d'infos sur la page "Contribuer à Piwigo". Si vous n'avez pas beaucoup de temps et que vous souhaitez nous soutenir vous pouvez aussi le faire par un don.

Hors ligne

#12 2021-03-13 12:31:30

lexi
Membre
2021-03-10
41

Re: Problème de Sécurité de mon site HTTPS ?

Bonjour Escapade,

Si c'est trop compliqué, il t'es possible de poser des questions précises sur les points que tu ne comprends pas. Comme par exemple, pour ma part, si je devais faire une vidange, faire des blancs en neige....


ddtddt te proposait de mettre les quelques lignes dans un fichier que tu nommerais ".htaccess" (en le copiant collant)
Et de remplacer "ton site" par le lien exact de ton site.

Et ensuite d'uploader (envoyer) sur le serveur de ton hébergement. Exactement comme tu as fait la première fois pour y déployer Piwigo comme ceci (avec Filezilla si ton ordinateur est sous Windows)  :
https://fr.piwigo.org/guides/installati … stallation

Après en effet rien n'empêche de déléguer ce type de tache en te dirigenant sur Piwigo qui sont spécialement prévu, que ce soit pour des particuliers que des pros.

Et c'est compréhensible. Je n'ai pas eu le courage pour le moment d'entretenir ma voiture moi même, changer les pneus, vidanges.... par contre j'ai appris dernièrement à faire les blancs en neige :)

Bon weekend à toi


Piwigo 11.5.0
PHP: 7.4.21
Base de donnée: 5.5.5-10.5.11-MariaDB-1 [2021-10-15 11:35:03]
Graphics Library: GD 2.3.0

Hors ligne

  •  » Installation
  •  » Problème de Sécurité de mon site HTTPS ?

Pied de page des forums

Propulsé par FluxBB

github twitter newsletter Faire un don Piwigo.org © 2002-2022 · Contact