Annonce

#1 2020-06-19 10:55:46

JLE67
Membre
2020-06-18
11

Code LF ajouté à chaque image en download

Bonjour,

vu que ça ressemble de plus en plus à un bug, je mets le lien ici vers mon problème. Pour la faire simple, tout fonctionne sauf que quand je télécharge une image depuis mon site Piwigo, le code LF(&0A) est ajouté au début du fichier image, "cassant" cette dernière. Si avec un éditeur hexa j'enlève ce caractère surnuméraire, l'image est normale. J'ai testé sur MacOS/wndows/Safari/Firefox et c'est toujours pareil donc bien un pb côté serveur…

Je mets ci-dessous les infos à jour.

Thread originel : https://fr.piwigo.org/forum/viewtopic.p … 78#p230178

VersionOS : CentOS 7 (à jour)
Version de Piwigo: 2.10.2
Version de PHP: 7.2.31
Version de MySQL: 5.5.65-MariaDB
Bibliothèque graphique: External ImageMagick 6.9.10-68
URL Piwigo: privée
Plugins installés : Admin Tools, Force HTTPS, LDAP Login, LocalFiles Editor

Hors ligne

#2 2020-06-24 13:45:54

JLE67
Membre
2020-06-18
11

Re: Code LF ajouté à chaque image en download

Question subsidiaire :

Où se trouve la fonction php d'export d'image qui est appelée lorsqu'on presse l'icône idoine ?
Merci par avance.

Hors ligne

#3 2020-06-24 13:51:53

ddtddt
Équipe Piwigo
Quetigny (21) - France
2007-07-27
15290

Re: Code LF ajouté à chaque image en download

Bonjour

je ne sais pas combien il y a d'installation piwigo qui tourne dans le monde mais je dirais que ce qu'il faut regarder c'est les spécificité de ton site

As tu des plugin d'activé, des modif perso ?

quel hébergeur as tu ?

je doute que le problème soit dans le code de base et que personne ne ce soit aperçu de cela


Vous aimez Piwigo alors n'hésitez pas à participer avec nous, plus d'infos sur la page "Contribuer à Piwigo". Si vous n'avez pas beaucoup de temps et que vous souhaitez nous soutenir vous pouvez aussi le faire par un don.

Hors ligne

#4 2020-06-24 13:52:25

ddtddt
Équipe Piwigo
Quetigny (21) - France
2007-07-27
15290

Re: Code LF ajouté à chaque image en download

un lien vers ta galerie ?


Vous aimez Piwigo alors n'hésitez pas à participer avec nous, plus d'infos sur la page "Contribuer à Piwigo". Si vous n'avez pas beaucoup de temps et que vous souhaitez nous soutenir vous pouvez aussi le faire par un don.

Hors ligne

#5 2020-06-24 14:46:06

JLE67
Membre
2020-06-18
11

Re: Code LF ajouté à chaque image en download

Ben, je suis quelque part d'accord avec toi, mais je ne comprends pas du tout le problème…
Ce qui est "interpellant" c'est que ce n'est pas n'importe quel caractère qui est inséré, mais un LF…

Ce n'est pas un hébergement chez un provider mais une installation en interne chez nous (labo de recherche) sur un unix CentOS 7. Je ne suis pas LE spécialiste Unix chez nous, mais cette installation n'a rien de particulier en tant que telle. Ce sont des VM dont on a un "master" qui est déployé à la demande selon les besoins. On a par exemple un OwnCloud qui tourne dessus depuis des lustres et sans problème.

Les modules PHP installés sont dans leur version 7.2 et sont :
php php-common php-opcache php-mcrypt php-cli php-gd php-curl php-mysql php-xml php-mbstring php-ldap

Vu le souci, j'ai installé ImageMagick qui est utilisé à la place de gd sans changement.

Le serveur a ses certificats signés par une autorité valide et est accessible en https uniquement et Piwigo se connecte en LDAP sur un AD pour l'authentification.

Les plugins Piwigo installés sont : Admin Tools, Force HTTPS, LDAP Login, LocalFiles Editor

Malheureusement le site n'est pas "public" et je ne peux en ouvrir l'accès… (labo de recherche)

Question installation, il n'y a rien d'extraordinaire à part qu'elle a été faite en manuel (copie du dossier Piwigo dans var/www/html/ et configuration en ligne lors d'une primo connexion…

Voilà, je ne vois pas trop quoi dire de plus à part qu'absolument tout semble fonctionnel à part cette insertion de LF au début du fichier image lors d'un téléchargement. Sur le serveur les fichiers sont intacts : je peux les y ouvrir sans problème…

Hors ligne

#6 2020-06-24 15:20:14

plg
Équipe Piwigo
Nantes, France, Europe
2002-04-05
12375

Re: Code LF ajouté à chaque image en download

Désactive le plugin LDAP pour voir si ça marche mieux.


Dernier billet du blog Piwigo.com (18 mars 2020) Covid19 : allongement de la période d’essai pour les entreprises

Hors ligne

#7 2020-06-24 15:38:16

JLE67
Membre
2020-06-18
11

Re: Code LF ajouté à chaque image en download

Trop fort ! Ça fonctionne maintenant… :-)

Mais je fais comment pour que mes utilisateurs se connectent via le LDAP ? ;-)

Bon, ça à la limite, vu que ce n'est pas tout le staff qui va y déposer les images, il y a peut-être moyen de s'en passer… C'est embêtant mais moins critique que des images cassées…

Dernière modification par JLE67 (2020-06-24 16:09:05)

Hors ligne

#8 2020-06-24 17:22:39

plg
Équipe Piwigo
Nantes, France, Europe
2002-04-05
12375

Re: Code LF ajouté à chaque image en download

Applique ce correctif https://github.com/Piwigo/Piwigo/pull/643/files

Et tu pourras réactiver le plugin LDAP :-)


Dernier billet du blog Piwigo.com (18 mars 2020) Covid19 : allongement de la période d’essai pour les entreprises

Hors ligne

#9 2020-06-24 20:27:06

JLE67
Membre
2020-06-18
11

Re: Code LF ajouté à chaque image en download

Bonsoir,
ok, merci :-)

Après test, ta solution fonctionne à merveille "plg" !!!

GRAND merci !

Maintenant la balle est dans le camp du gestionnaire du site :-)

Dernière modification par JLE67 (2020-06-25 09:14:33)

Hors ligne

Pied de page des forums

Propulsé par FluxBB

github twitter newsletter Faire un don Piwigo.org © 2002-2020 · Contact