Annonce

#1 2020-05-18 18:27:36

PhilEPTB
Membre
2016-12-12
18

les photos téléchargés à partir dde Piwigo ne s'affichent plus

Bonsoir,

Depuis environ 2 mois, lorsque je veux ouvrir une photo jpg téléchargée depuis l'interface de Piwigo, la visionneuse Windows affiche : "il semble que nous ne prenions pas en charge ce format de fichier".
J'ai fait la même expérience sur le serveur (linux Debian 9) : même résultat.
J'ai donc recherché le nom du fichier (en éditant la photo en mode administration). Si je vais ouvrir directement le fichier sur le serveur sans passer par l'application, il s'ouvre correctement.
Autre test : j'arrive à ouvrir ces jpg avec XnView.
Je précise que cela se produit avec toutes les photos. Je suis même allé jusqu'à remonté un piwigo sur un serveur tout neuf en http (mon serveur de prod est en https) et j'observe le même comportement.
J'avoue que j'en perds mon latin...
Si quelqu'un a une idée, je suis preneur !


Version de Piwigo: 2.10.2
Version de PHP: 7.0.33-0+deb9u7
Version de MySQL: 5.5.5-10.1.44-MariaDB-0+deb9u1
URL Piwigo: https://media.seinegrandslacs.fr

Hors ligne

#2 2020-05-19 06:27:47

ddtddt
Équipe Piwigo
Quetigny (21) - France
2007-07-27
15375

Re: les photos téléchargés à partir dde Piwigo ne s'affichent plus

Bonjour

Windows ne télécharge pas l'extension ?

avec tous les navigateur ?


Vous aimez Piwigo alors n'hésitez pas à participer avec nous, plus d'infos sur la page "Contribuer à Piwigo". Si vous n'avez pas beaucoup de temps et que vous souhaitez nous soutenir vous pouvez aussi le faire par un don.

Hors ligne

#3 2020-05-19 08:56:51

k5
Équipe Piwigo
lieu
2014-01-26
531

Re: les photos téléchargés à partir dde Piwigo ne s'affichent plus

Bonjour,
Php 5 installé ?


Essayez d'Avoir comme premier réflexe de lire les documentations s'il y a des réponses à votre question. merci
Piwigo documentation

Hors ligne

#4 2020-05-19 09:34:14

PhilEPTB
Membre
2016-12-12
18

Re: les photos téléchargés à partir dde Piwigo ne s'affichent plus

Bonjour et merci pour votre réactivité.

Comme je l'ai indiqué dans mon message, j'utilise PHP 7 sur le serveur.
D'autre part, si cela venait de Windows, pourquoi, sur mon serveur Linux, il y aurait le même comportement ?
Je rappelle que le fichier d'origine n'est visiblement pas altéré puisque j'arrive à l'ouvrir avec l'explorateur de fichier de Debian 9. C'est à travers l'application Piwigo que je n'y arrive plus (alors que ça fonctionnait avant !).
J'ai essayé sur Windows avec les navigateurs Firefox, Chrome et Opéra et j'obtiens le même comportement. J'ai essayé également avec des petits fichiers jpg, au cas où un timeout ou un filesizemax bloquerait mais c'est toujours pareil.

En vous remerciant d'avance pour vos réponses.

Hors ligne

#5 2020-05-23 11:57:18

PhilEPTB
Membre
2016-12-12
18

Re: les photos téléchargés à partir dde Piwigo ne s'affichent plus

Bonjour,

Je viens d'éditer et de comparer le fichier téléchargé (qui ne s'affiche pas) avec le fichier original (qui s'affiche) avec notepad++.
Le fichier téléchargé a la 1ère ligne vide et alors qu'il devrait se terminer par FF D9, il se termine par FF.
Si je supprime la ligne vide et que j'écris D9 à la fin (FF D9 étant la fin d'un fichier jpg), le fichier s'affiche avec la visionneuse Windows.
Reste à savoir pourquoi cette transformation s'opère lors du téléchargement de fichier...
Quelqu'un a-t-il une idée ou arrive-t-il à reproduire le problème ?

En vous remerciant d'avance pour vos réponse.

Hors ligne

#6 2020-05-23 19:22:59

Dom59
Membre
Lille
2020-05-02
98

Re: les photos téléchargés à partir dde Piwigo ne s'affichent plus

Bonjour, je ne sais pas si il y a un rapport mais j'ai remarqué un truc cette semaine.
J'utilise également XnView pour éditer mes metadata de mes photos et Notepad++ pour éditer mes fichiers txt, php, css etc
Par défaut j'ai configurer notepad pour encoder en UTF-8
Si tu mets les meta IPTC en UTF-8 dans XnView tu auras un soucis avec avec l'encodage des caractères latin à,é,ë etc etc
Sur XnView il faut envoyer du ANSI
https://superuser.com/questions/540286/ … fault-ones
Bon courage

Dernière modification par Dom59 (2020-05-23 19:28:10)


Piwigo 2.10.2
Bootstrap_darkroom 2.4.4
PHP: 7.3
https://lillephotos.com

Hors ligne

#7 2020-07-17 11:12:53

PhilEPTB
Membre
2016-12-12
18

Re: les photos téléchargés à partir dde Piwigo ne s'affichent plus

Solution apportée par l'équipe Piwigo ici https://github.com/Piwigo/Piwigo/pull/643/files (merci à eux) de laquelle j'ai été informé grâce à JLE67.
La solution fonctionne, le ticket peut être clos.

Dernière modification par PhilEPTB (2020-07-17 11:16:07)

Hors ligne

Pied de page des forums

Propulsé par FluxBB

github twitter newsletter Faire un don Piwigo.org © 2002-2020 · Contact