Annonce

#1 2019-12-09 13:54:02

gesualda
Membre
2010-12-09
87

erreur piwigo dans php7.4

Bonjour/Bonsoir,

Je viens d'installer sur mon serveur la version 7.4 de php et j'ai l’erreur suivante à la ligne 125/126 dans le fichier "include/menubar.inc => "Notice: Trying to access array offset on value of type null in"

Si j'ai bien compris c'est la boucle et l'appel du tableau qui pose problème dans php 7.4 XX
cela sera t-il mis à jour l'autre dans une version future de piwigo ?

Vous remerciant par avance,

Version de Piwigo: 2.10
Version de PHP: 7.4.x
Version de MySQL: 5.6 X
URL Piwigo: http:// en local pour le moment  ..

Hors ligne

#2 2019-12-09 14:15:21

k5
Équipe Piwigo
La reppe
2014-01-26
891

Re: erreur piwigo dans php7.4

bonjour gesualda,
y a t'il des tags /& images&pages dans votre gallerie ? merci
cordialement
k5


Beta test sur Github Codespaces !!!

Hors ligne

#3 2019-12-09 17:58:51

gesualda
Membre
2010-12-09
87

Re: erreur piwigo dans php7.4

Bonjour,

Non aucun tag.
Je peux créer une entrée utilisateur => testeur si tu veux contrôler.

Dernière modification par gesualda (2019-12-09 18:08:37)

Hors ligne

#4 2019-12-09 22:43:26

k5
Équipe Piwigo
La reppe
2014-01-26
891

Re: erreur piwigo dans php7.4

Bonjour,
Essayez d'ajouter 1 ligne dans localfiles editor ====> config local

Code:

$ conf ['show_php_errors'] = E_ERROR;

ou

Code:

$ conf ['show_php_errors'] = E_ALL;

et n'hesitez pas de faire les mises à jour piwigo :)
Cordialement
k5


Beta test sur Github Codespaces !!!

Hors ligne

#5 2019-12-10 10:05:00

gesualda
Membre
2010-12-09
87

Re: erreur piwigo dans php7.4

Bonjour K5,

J'ai rajouté la ligne, mais l'affichage des erreurs étaient déjà validée dans php.ini.
Je mets piwigo à jour à chaque nouvelle version.

Alors je vais donc attendre la prochaine correction
Merci

Dernière modification par gesualda (2019-12-10 10:05:25)

Hors ligne

#6 2019-12-10 10:16:08

ddtddt
Équipe Piwigo
Quetigny (21) - France
2007-07-27
16209

Re: erreur piwigo dans php7.4

Bonjour,

est ce qu'en ajoutant

$conf['menubar_tag_cloud_content'] = 'current_only';

cela résout ton erreur ?


Vous aimez Piwigo alors n'hésitez pas à participer avec nous, plus d'infos sur la page "Contribuer à Piwigo". Si vous n'avez pas beaucoup de temps et que vous souhaitez nous soutenir vous pouvez aussi le faire par un don.

Hors ligne

#7 2019-12-10 10:35:11

gesualda
Membre
2010-12-09
87

Re: erreur piwigo dans php7.4

Bonjour ddtddt

Non cela ne règle pas le soucis. Je mets une capture d'écran. Je rappelle que c'est après la mise à vers php7.4 Merci

Dernière modification par gesualda (2019-12-10 10:36:24)

Hors ligne

#8 2019-12-16 16:08:45

k5
Équipe Piwigo
La reppe
2014-01-26
891

Re: erreur piwigo dans php7.4

Bonjour Gesualda,
j'ai reproduit l'erreur.
voila ce que j'ai fais :
- désactiver iis
- installer Wamp 3.2.2 et activer en cliquant
sur php ==> 7.4
sur mysql ==> 8
- installer piwigo 2.10.1 et mise à jour de modus

j'ai remarqué que vous n'étiez pas seul sur cette erreur.
(voir lien sur github et forum anglais)
j'ai apperçu aussi des erreurs sur page_header...

php 7.4 est sorti il y a 2 semaines :)

Cordialement
k5


Beta test sur Github Codespaces !!!

Hors ligne

#9 2019-12-16 18:20:50

gesualda
Membre
2010-12-09
87

Re: erreur piwigo dans php7.4

Bonjour K5,

Oui, c'est exact php7.4 n'a que quelques jours. C'est pour cela également que je remonte une erreur lorsque je la trouve.

En tous les cas, merci beaucoup de l’intérêt que tu portes au message.
Bonne soirée,

Hors ligne

Pied de page des forums

Propulsé par FluxBB

github twitter newsletter Faire un don Piwigo.org © 2002-2022 · Contact