#1 2018-06-08 17:23:05

thierry@sanchoweb.com
Membre
2016-04-06
5

Site Web planté - mysql error

Bonjour,

Depuis quelques temps je ne peux plus me connecter à mon site web piwigo hebergé sur Hostinger (mes autres sites hebergés chez le même hebergeurs sont fonctionnels).
Voici le message d'erreur :

Warning:  [mysql error 1064] You have an error in your SQL syntax; check the manual that corresponds to your MariaDB server version for the right syntax to use near 'recursive,
    create_subcategories,
    nb_photos,
    storage
  FROM piwigo_co' at line 6

SELECT
    id,
    type,
    category_id,
    user_album,
    recursive,
    create_subcategories,
    nb_photos,
    storage
  FROM piwigo_community_permissions
  WHERE (type = 'any_visitor')
; in /home/u610447498/public_html/include/dblayer/functions_mysqli.inc.php on line 845


Fatal error: Call to a member function fetch_assoc() on a non-object in /home/u610447498/public_html/include/dblayer/functions_mysqli.inc.php on line 226

Quelqu'un pourrait-il me venir en aide ?

Merci d'avance.

Version de Piwigo: 2.9.3
Version de PHP: 5.3.29
Version de MySQL: 10.2.15-MariaDB
URL Piwigo: http://sanchoweb.com

Hors ligne

#2 2018-06-08 20:40:47

ddtddt
Équipe Piwigo
Quetigny (21) - France
2007-07-27
14512

Re: Site Web planté - mysql error

Bonjour,

C'est un problème de version de MariaDB / Plugin community, dans un premier temps je te conseils de désactiver le plugin


Vous aimez Piwigo alors n'hésitez pas à participer avec nous, plus d'infos sur la page "Contribuer à Piwigo". Si vous n'avez pas beaucoup de temps et que vous souhaitez nous soutenir vous pouvez aussi le faire par un don.

Hors ligne

#3 2018-06-09 14:26:01

thierry@sanchoweb.com
Membre
2016-04-06
5

Re: Site Web planté - mysql error

Bonjour merci pour la réponse.

N'ayant pas accès à la console d'administration de Piwigo, comment je peux désactiver le plugin ?

Merci.

Hors ligne

#4 2018-06-09 15:36:30

thierry@sanchoweb.com
Membre
2016-04-06
5

Re: Site Web planté - mysql error

Bonjour,

J'ai réussi à désactiver le plugin à travers phpMyadmin, et en effet mon site fonctionne à nouveau.

Merci Beaucoup.

Hors ligne

Pied de page des forums

Propulsé par FluxBB

github twitter facebook newsletter Faire un don Piwigo.org © 2002-2019 · Contact