Annonce

  •  » Utilisation
  •  » [Résolu] Rendu des images dégradé après upload - A l'aide !!!

#1 2012-03-24 11:49:45

surfinette
Membre
2012-03-20
8

[Résolu] Rendu des images dégradé après upload - A l'aide !!!

Bonjour,
J'ai récemment démarré avec Piwigo.
J'ai un problème quand j'upload mes photos (format jpg) avec l'outil web (je n'ai pas encore testé pLoader ou autre), à savoir que quand je suis dans les options d'ajout et que je coche la case "resize" (redimentionner), par exemple en laissant par défaut 800x600, les photos qui sont uploadées dans Piwigo ont un rendu dégradé : couleurs plus ternes, image plus plate, moins contrastée,... et cela même si je met image quality à 100%. Si je décoche la case, resize, je n'ai plus le problème de dégradation du rendu visuel, mais cette solution n'est pas idéale : soit mes photos sont trop grandes pour le site, soit, si je les resize moi-même avant l'upload en 800x600 alors le visiteur perd l'option de les agrandir (et puis ce n'est pas forcément pratique pour moi de réduiire toutes mes photos avant upload).

Bon mais de tout façon je ne vois pas pourquoi un resize sans perte de qualité devrait modifier couleurs, contraste, saturation, luminosité, etc...
Y a -t-il un couple taille/résolution idéal avant d'uploader ?

Pour info, j'utilise le thème Stripped.

Sinon, bravo pour Piwigo, je ne fait que commencer à explorer ses possibilités, c'est génial !

A+

Surfinette

Dernière modification par surfinette (2012-03-25 11:44:05)

Hors ligne

#2 2012-03-24 11:55:28

Gotcha
Equipe Piwigo
Pierrelatte (26)
2007-03-14
13331

Re: [Résolu] Rendu des images dégradé après upload - A l'aide !!!

Bonjour,

Sur la première page de l'administration de votre galerie, vous devriez trouver une ligne faisant mention de la "Librairie graphique".
Pourriez-vous nous donner le contenu de cette ligne ? Merci.


Ayez comme premier réflexe de consulter le wiki.
Ensuite, veuillez effectuer une recherche sur le forum avant de poser votre question.

LE FAIRE EST LE REVELATEUR DE L'ETRE

Hors ligne

#3 2012-03-24 13:46:58

surfinette
Membre
2012-03-20
8

Re: [Résolu] Rendu des images dégradé après upload - A l'aide !!!

Bonjour,

Voici le contenu de la ligne:
Graphics Library: GD bundled (2.0.34 compatible)

Petites précisions:
J'ai installé mercredi dernier Piwigo directement depuis l'interface O2Switch en utilisant l'outil Softaculous.
Mon interface d'administration Piwigo s'est installé en anglais (pas eu d'option de choisir autre chose) et je n'ai pas trouvé comment passer l'interface en Français... est-ce possible ?

Merci de votre aide

Surfinette

Hors ligne

#4 2012-03-24 14:19:21

surfinette
Membre
2012-03-20
8

Re: [Résolu] Rendu des images dégradé après upload - A l'aide !!!

Bon avant de me lancer avec une solution hébergeur + piwigo, j'avais créé un compte sur Piwigo.com qui est toujours actif...

Je viens de tester : la même photo uploadée par la même méthode sur Piwigo.com est parfaitement bien affichée sur Piwigo.com, alors qu'elle est modifiée sur mon Piwigo hébergé chez 02switch.

Pour comprendre ce dont je parle, voir les exemples dans l'album Test que j'ai créé ici http://surfinette.piwigo.com/ (affichage correcte) et là http://quiya.com/piwigo/ (affichage dégradé).

A+

Hors ligne

#5 2012-03-24 15:46:14

Zaphod
Former Piwigo Team
Toulouse
2006-11-13
2422

Re: [Résolu] Rendu des images dégradé après upload - A l'aide !!!

Alors,

Ca n'est pas le même algorithme de redimensionnement dans les deux cas.

Chez piwigo.com, c'est ImageMagick qui est utilisé, chez O2switch, c'est GD.
ImageMagick fait un redimensionnement de meilleure qualité, ce qui est visible ici.

Mais ça n'est pas la raison de la différence de couleur.
Tout est une question de gestion de couleurs.

On peut noter que sur chrome, par exemple, il n'y a aucune différence de couleur entre les deux images.

Par exemple si on compare les deux images :
http://surfinette.piwigo.com/uploads/p/ … 570b05.jpg
http://quiya.com/piwigo/upload/2012/03/ … 570b05.jpg

Dans chrome on ne voit que la différence de rendu des algorithmes.
Dans firefox on voit la différence de couleur, en plus.


La raison est simple : l'image au départ, est dans un espace de couleur Adobe RGB.
ImageMagick conserve cet espace lors du redimensionnement.
GD ne le conserve pas (les valeurs de couleurs restent les mêmes, mais l'espace étant plus réduit, les couleurs apparaitront plus fades)

En règle générale, une image dans un espace Adobe RGB sera mal affichée chez 99% des visiteurs.
De plus, la plus value d'avoir un espace large ne sera visible que sur des écrans wide gamut...

En gros, mon conseil : toujours utiliser des images dans l'espace sRGB, quand on publie sur le web.
Sinon, on ne fait que s'attirer des ennuis...

Par exemple, même sur le site piwigo.com, si on utilise chrome... les couleurs seront fades.

Dernière modification par Zaphod (2012-03-24 15:47:53)

Hors ligne

#6 2012-03-24 23:16:36

Gotcha
Equipe Piwigo
Pierrelatte (26)
2007-03-14
13331

Re: [Résolu] Rendu des images dégradé après upload - A l'aide !!!

Je suis aussi chez O2switch et la libraire graphique est bien "ImageMagick". Cela dépend du serveur de stockage.
Si vous poursuivez chez O2switch, vous pourriez leur demander de changer de libraire et n'hésitez pas à leur dire que c'est pour Piwigo (j'ai un bon contact avec le responsable).

;-)


Ayez comme premier réflexe de consulter le wiki.
Ensuite, veuillez effectuer une recherche sur le forum avant de poser votre question.

LE FAIRE EST LE REVELATEUR DE L'ETRE

Hors ligne

#7 2012-03-24 23:31:28

Zaphod
Former Piwigo Team
Toulouse
2006-11-13
2422

Re: [Résolu] Rendu des images dégradé après upload - A l'aide !!!

Enfin même avec ImageMagick les images seront mal affichées chez 99% des gens...
Il faut agir au niveau des images de départ... sur le web, il faut toujours choisir sRVB, pas Adobe RGB.

Hors ligne

#8 2012-03-24 23:35:39

surfinette
Membre
2012-03-20
8

Re: [Résolu] Rendu des images dégradé après upload - A l'aide !!!

Merci Zaphod, votre réponse m'est très utile, mais me perplexifie également !

Tout ça lève doutes et questionnement :
(1) je ne savais pas que la qualité de compression pouvait varier d'un hébergeur à l'autre (en fait je pensais que c'était géré au niveau du module/appli Piwigo). Du coup je me demande si j'ai fait le bon choix en m'hébergeant chez O2switch (pourtant recommandé par Piwigo... c'est d'ailleurs comme ça que j'ai fait mon choix pour l'hébergeur)

(2) Plus problématique encore pour moi, je réalise que j'ai atteint mon principe de Peter !... car je n'y comprend pas grand chose en profil/gestion des couleurs... je dirais même que je suis presque complètement paumée...
Donc si je comprend bien je dois retourner dans photoshop et basculer sur sRGB IEC61966-2.1.
Est-ce que si je choisi Europe General Purpose 3 comme profil dans Photoshop, je suis OK pour le web comme pour l' impression ? Ou est-ce que Adobe RGB sera toujours mieux pour les impressions ?

(3) Auriez-vous des liens qui explique clairement ces histoires de gestion des couleurs afin que je me cultive et devienne moins bête sur ces sujets ?

A+

Hors ligne

#9 2012-03-24 23:38:34

surfinette
Membre
2012-03-20
8

Re: [Résolu] Rendu des images dégradé après upload - A l'aide !!!

Gotcha a écrit:

Je suis aussi chez O2switch et la libraire graphique est bien "ImageMagick". Cela dépend du serveur de stockage.
Si vous poursuivez chez O2switch, vous pourriez leur demander de changer de libraire et n'hésitez pas à leur dire que c'est pour Piwigo (j'ai un bon contact avec le responsable).

;-)

Je ne suis pas exactement sûre de bien comprendre (décidément j'ai vraiment un problème !)...
On peut donc être chez O2switch et être soit sur ImageMacgick, soit sur GD ? Et comment sait-on sur quelle librairie graphique ?

Hors ligne

#10 2012-03-24 23:49:03

Gotcha
Equipe Piwigo
Pierrelatte (26)
2007-03-14
13331

Re: [Résolu] Rendu des images dégradé après upload - A l'aide !!!

Zaphod s'y connais surement mieux que moi en espace colorimétrique, mais je crois savoir qu'il n'existe pas un seul espace colorimétrique qui soit "le meilleur en tout". Cela va dépendre de votre matériel et du rendu que vous souhaitez faire apparaitre.
Comme il existe une multitude de domaines (impression d'art, épreuvage, impression magasine, publication web, traitement photo sur ordinateur etc) et multipliez ça par le nombre de matériels !
Oui il existe des espaces très larges qui donnent (au moins dans la théorie) d’excellents résultat mais non ils ne sont pas toujours bon à employer dans des supports inadaptés (le tirage d'art n'est pas pareil que l'affichage sur le web).

Une page assez simple pour avoir des éléments de réponses :
http://www.impression-panoramique.com/C … 10.html#t2

Mais là n'est pas question qui nous intéresse.
Piwigo va afficher des images qu'on lui aura soumis. Ces images peuvent être en Adobe RGB 1998 comme en Pro Photo. Ce n'est pas Piwigo qui va chipoter mais plutôt le navigateur.
Donc cela pour vous dire que le problème se situe avant d'envoyer vos photos à Piwigo. Il s'agit de bien faire attention au fichier que vous envoyez en ligne. Pour garantir une compatibilité maximal entre les navigateurs, il est conseillé d'opter pour un profil colorimétrique sRGB


Ayez comme premier réflexe de consulter le wiki.
Ensuite, veuillez effectuer une recherche sur le forum avant de poser votre question.

LE FAIRE EST LE REVELATEUR DE L'ETRE

Hors ligne

#11 2012-03-24 23:51:37

Gotcha
Equipe Piwigo
Pierrelatte (26)
2007-03-14
13331

Re: [Résolu] Rendu des images dégradé après upload - A l'aide !!!

surfinette a écrit:

Je ne suis pas exactement sûre de bien comprendre (décidément j'ai vraiment un problème !)...
On peut donc être chez O2switch et être soit sur ImageMacgick, soit sur GD ? Et comment sait-on sur quelle librairie graphique ?

L'hébergeur dispose d'une ferme de serveur, c'est à dire d'une multitude de machines.
Toutes ces machines ne sont pas forcément identiques et il arrive d'avoir des petites différences chez le même hébergeur selon qui sont site soit hébergeur sur le serveur X et un autre site sur le serveur Y.

;-)


Ayez comme premier réflexe de consulter le wiki.
Ensuite, veuillez effectuer une recherche sur le forum avant de poser votre question.

LE FAIRE EST LE REVELATEUR DE L'ETRE

Hors ligne

#12 2012-03-25 00:13:48

Zaphod
Former Piwigo Team
Toulouse
2006-11-13
2422

Re: [Résolu] Rendu des images dégradé après upload - A l'aide !!!

surfinette a écrit:

(2) Plus problématique encore pour moi, je réalise que j'ai atteint mon principe de Peter !... car je n'y comprend pas grand chose en profil/gestion des couleurs... je dirais même que je suis presque complètement paumée...

La question qu'il faut se poser, c'est pourquoi les images sont en Adobe RGB au départ ?
Ca n'est pas une option classique...

Si on ne maitrise pas la gestion des couleurs, il faut toujours choisir sRGB.
Pour le web, il faut toujours choisir sRGB.

Si on respecte ces deux principes, on n'est pas embetté ;)

surfinette a écrit:

Donc si je comprend bien je dois retourner dans photoshop et basculer sur sRGB IEC61966-2.1.
Est-ce que si je choisi Europe General Purpose 3 comme profil dans Photoshop, je suis OK pour le web comme pour l' impression ?

Désolé mais je ne connais pas Photoshop.
C'est un logiciel très puissant mais également très complexe au niveau de la gestion des couleurs.
Les options offertes par Photoshop me dépassent totalement.


surfinette a écrit:

Ou est-ce que Adobe RGB sera toujours mieux pour les impressions ?

Tout dépend où on imprime...

En tous cas, si on exporte dans un espace plus large, il faut être certain qu'il sera bien reconnu au final.

Il faut voir aussi dans quel espace sont les photos au départ (à la sortie de l'appareil photo)



surfinette a écrit:

Auriez-vous des liens qui explique clairement ces histoires de gestion des couleurs afin que je me cultive et devienne moins bête sur ces sujets ?

Je connais un lien qui normalement est pas mal :
http://www.guide-gestion-des-couleurs.com/

Dernière modification par Zaphod (2012-03-25 00:16:47)

Hors ligne

#13 2012-03-25 00:58:19

surfinette
Membre
2012-03-20
8

Re: [Résolu] Rendu des images dégradé après upload - A l'aide !!!

Pourquoi j'étais en Adobe RGB ? Ben, j'avais fait une fausse manip l'autre jour après une réinstallation de photoshop et le bidouillage de certains réglages.

J'ai repris mes 2 fichiers Raw et je les ai retravaillé dans l'espace sRGB... j'ai réuploadé les photos (toujours visibles dans l'album Test) et maintenant je n'ai plus de différence de couleur entre Piwigo.com et Piwigo@O2switch.   :)
Quant à la différence de qualité lié à la différence d'algorithme de compression, certes il y en a une, mais je trouve qu'elle est assez minime...

En tous les cas, merci à vous deux, car j'ai résolu mon problème technique...

Je vais lire attentivement les liens fournis par Zaphod car j'ai vraiment besoin de  comprendre tout ça (le site d'Arnaud Frich a effectivement l'air d'être top).

Très grand merci

Surfinette

Hors ligne

  •  » Utilisation
  •  » [Résolu] Rendu des images dégradé après upload - A l'aide !!!

Pied de page des forums

Propulsé par FluxBB

github twitter newsletter Faire un don Piwigo.org © 2002-2021 · Contact