•  » Installation
  •  » [Résolu] Echec de mise à jour PhpWebGallery 1.7.1 vers Piwigo 2.3.2

#1 2012-01-19 18:07:26

mike23
Membre
2012-01-19
11

[Résolu] Echec de mise à jour PhpWebGallery 1.7.1 vers Piwigo 2.3.2

Bonjour,

J'essaie de mettre à jour PhpWebGallery 1.7.1 vers Piwigo 2.3.2, sur une install local en serveur XAMPP sous Linux.

J'ai suivi les documentations de la mise à jour auto et manuelle, j'ai essayé les deux mais à chaque fois le problème suivant survient :

Tout à la fin, une fois que la mise à jour a été effectuée et que l'écran de résumé apparait, lorsque je clique sur "Accueil" pour revenir à mon site, cela affiche l'écran d'installation, avec la demande des identifiants SQL et la création du compte admin (comme pour une install fraiche en fait).

Si je remplis ces infos, ca remet tout à zéro et au final je n'ai plus mes galeries ni rien sur le site (une install toute neuve a été faite)

Quelqu'un aurait-il une piste ? Merci pour votre aide :)

Hors ligne

#2 2012-01-19 18:45:52

P@t
Équipe Piwigo
Nice
2007-06-13
5694

Re: [Résolu] Echec de mise à jour PhpWebGallery 1.7.1 vers Piwigo 2.3.2

Est-ce que tu es bien passé par l'étape 3 du guide de mise à jour manuelle?


P@t

Hors ligne

#3 2012-01-19 19:56:36

WebFantasy
Membre
2012-01-08
18

Re: [Résolu] Echec de mise à jour PhpWebGallery 1.7.1 vers Piwigo 2.3.2

J'ai eu le même problème, que j'ai résolu en modifiant le fichier local/config/database.inc.php , en mettant le code suivant après les variables $conf et le prefixe :

Code:

define('PHPWG_INSTALLED', true);
define('PWG_CHARSET', 'utf-8');
define('DB_CHARSET', 'utf8');
define('DB_COLLATE', '');
?>

Il semblerait que le "preup21" ne génère pas un fichier assez complet :/ (ou alors j'ai mal compris quelque chose)

Hors ligne

#4 2012-01-20 13:02:26

mike23
Membre
2012-01-19
11

Re: [Résolu] Echec de mise à jour PhpWebGallery 1.7.1 vers Piwigo 2.3.2

Super ça fonctionne avec ta solution !

J'ai donc effectué une mise à jour manuelle, et à l'étape 3 après avoir extrait le dossier local/ j'ai modifié local/config/database.inc.php en ajoutant le code cité par WebFantasy.

Merci bcp à vous deux !

Hors ligne

  •  » Installation
  •  » [Résolu] Echec de mise à jour PhpWebGallery 1.7.1 vers Piwigo 2.3.2

Pied de page des forums

Propulsé par FluxBB

github twitter facebook newsletter Faire un don Piwigo.org © 2002-2019 · Contact