Annonce

  •  » Outils
  •  » Plugin Shotwell - Changement de paramètres de connexion à Piwigo

#1 2011-11-18 17:45:20

Nimch
Membre
2011-11-18
7

Plugin Shotwell - Changement de paramètres de connexion à Piwigo

Bonjour,

Tout d'abord je suis un nouvel utilisateur de Piwigo et je félicite les développeurs pour le boulot. Je me suis installé une galerie perso pour la famille sur un serveur à la maison et ça fonctionne nickel !

Je rencontre un p'tit bug concernant le plugin de publication de Shotwell, je ne sais pas si je poste au bon endroit mais je me suis dit que peut-être ici quelqu'un aurait une solution à me proposer. J'utilise donc Shotwell (0.11.4) sur une Ubuntu 11.10 et une version à jour de Piwigo (2.3.1) sur mon serveur Debian mais je suis à peu près sûr que Piwigo n'a pas de lien avec le problème.

Voici donc le problème : il se trouve que j'ai modifié l'url de la galerie entre la phase de test et la phase de prod et je me retrouve avec un Shotwell tout bloqué sur l'ancienne url sans pouvoir la modifier ! Soit ce dernier plante méchamment lorsque je clique "publier", soit il m'affiche la fenêtre de connexion à Piwigo avec un message ressemblant à "Service http://ancienneAdresse.net/ws.php 404 error not found". J'ai beau chercher je ne trouve pas un moyen propre pour réinitialiser les paramètres de connexion. Et je n'ai pas trouvé de réponse dans les forums et autre doc. J'ai donc cherché où était stockées ces infos, d'abord dans .shotwell mais non et ensuite dans gconf de Gnome, bingo ! Je me dis c'est gagné, j'efface les infos à la main (beurk) en laissant les clés mais je m'aperçois que les valeurs reviennent à chaque fois que je lance Shotwell. J'ai essayé en virant carrément les clés et cette fois-ci uniquement le mot de passe réapparait dans gconf mais Shotwell continue de se connecter avec tous les anciens paramètres ou à planter ! Voilà c'est à n'y rien comprendre et donc en désespoir de cause je me permets de vous demandez un coup de main.

Merci à celui qui prendra la peine de me lire et de m'aiguiller.

Hors ligne

#2 2011-11-18 19:56:58

ddtddt
Équipe Piwigo
Quetigny (21) - France
2007-07-27
16288

Re: Plugin Shotwell - Changement de paramètres de connexion à Piwigo

Merci pour ce long message et pour la question

Je ne sais pas répondre mais je contacts l'auteur du plugin pour qu'il te réponde sur le forum et que cela profite à tous ;-)


Vous aimez Piwigo alors n'hésitez pas à participer avec nous, plus d'infos sur la page "Contribuer à Piwigo". Si vous n'avez pas beaucoup de temps et que vous souhaitez nous soutenir vous pouvez aussi le faire par un don.

En ligne

#3 2011-11-18 21:24:27

Nimch
Membre
2011-11-18
7

Re: Plugin Shotwell - Changement de paramètres de connexion à Piwigo

Je te remercie et je patiente pour une réponse plus technique.

Dernière modification par Nimch (2011-11-18 21:24:40)

Hors ligne

#4 2011-11-19 01:31:44

Bruno Girin
Invité

Re: Plugin Shotwell - Changement de paramètres de connexion à Piwigo

En théorie, le plugin devrait offrir la page de configuration s'il y a un problème pour se connecter mais apparemment ce n'est pas toujours le cas. @Nimch, si tu peux documenter le bogue ici, ce serait bien: http://redmine.yorba.org/projects/shotwell/issues

En attendant, je vais essayer de reproduire et de trouver la cause de l'erreur.

#5 2011-11-19 18:06:34

Nimch
Membre
2011-11-18
7

Re: Plugin Shotwell - Changement de paramètres de connexion à Piwigo

J'essaierai de documenter le bogue dans le wiki de Shotwell en début de semaine car pas trop le temps d'ici là... En attendant j'ai quand même une question : si les paramètres de connexion ne sont plus dans gconf mais continuent d'être utilisés dans l'appli c'est qu'ils sont stockés ailleurs, puis-je savoir où afin de modifier l'url et peut-être réparer temporairement le fonctionnement ? Et s'ils sont stockés ailleurs pourquoi les dupliquer dans gconf ?

Hors ligne

#6 2011-11-29 21:33:01

mishka81
Invité

Re: Plugin Shotwell - Changement de paramètres de connexion à Piwigo

Exactement le même problème et je dois dire que c'est relativement pénible ! à la différence près que dès que je sélectionne le plugin Piwigo, Shotwell plante inopinément ...
J'ai supprimé la base de données Shotwell ~./shotwell ainsi que les entrées dans Gconf , désinstallé Shotwell en purgeant les fichiers de conf pour mettre la toute dernière version à jour du ppa, mais rien n'y fait !

J'espère que je ne vais pas devoir désinstaller Ubuntu :S

#7 2011-11-29 22:31:43

Bruno Girin
Invité

Re: Plugin Shotwell - Changement de paramètres de connexion à Piwigo

Désolé, je n'ai pas eu le temps de regarder ce qu'il se passe. Toute la config devrait être dans gconf donc je ne vois pas pourquoi il la garde. Essaie de supprimer les répertoires ~/.shotwell et ~/.gconf/apps/shotwell

#8 2012-01-29 16:01:24

Bruno Girin
Invité

Re: Plugin Shotwell - Changement de paramètres de connexion à Piwigo

Désolé pour le délai, j'ai enfin eu le temps de regarder aujourd'hui et j'ai ouvert un ticket pour lequel j'ai fourni un patch: http://redmine.yorba.org/issues/4678

Dès que ce patch est inclus dans le code, ça devrait fonctionner résoudre le problème. J'ai aussi ajouté un certain nombre de message de débogage donc j'aimerais avoir des volontaires pour le tester au max histoire que le plugin dans la prochaine version de Shotwell soit aussi solide que possible.

#9 2012-02-27 22:11:23

Bruno Girin
Invité

Re: Plugin Shotwell - Changement de paramètres de connexion à Piwigo

Le code a maintenant été mis à jours avec mon patch donc s'il y a des volontaires pour tester, ce serait très utile. Les docs pour installer à partir des sources sont là: http://yorba.org/shotwell/install/#source

S'il y a encore des problèmes, démarrez Shotwell en mode debug depuis la ligne de commande:

SHOTWELL_LOG=1 shotwell

Et postez le contenu du fichier ~/.cache/shotwell/shotwell.log

  •  » Outils
  •  » Plugin Shotwell - Changement de paramètres de connexion à Piwigo

Pied de page des forums

Propulsé par FluxBB

github twitter newsletter Faire un don Piwigo.org © 2002-2022 · Contact