•  » Utilisation
  •  » [Résolu] Problème local_config.inc

#1 2010-05-16 08:42:21

Gilles
Membre
Brie Comte Robert
2007-01-19
30

[Résolu] Problème local_config.inc

Bonjour. Je souhais passer de la v 1.7.3 à la 2.0, mais mon hébergeur propose php5, mais seulement mysql 4 ce qui ne semble pas compatible.
Je souhaite donc ajouter quelques liens ('links') sur ma page d'accueil 1.7.3, ce que j'avais déjà fait il y a longtemps, mais problème:
j'édite la section $conf['links'] du fichier, mais page blanche! En fait, lorsque je laisse 1 seul lien dans le tableau, ça marche, mais dès que j'ajoute 1 ligne (aucun pb. de syntaxe, vérifié), ça ne fonctionne plus. Un petit coup de main serait hautement apprécié!
Gilles

Hors ligne

#2 2010-05-16 08:51:34

ddtddt
Équipe Piwigo
Quetigny (21) - France
2007-07-27
14613

Re: [Résolu] Problème local_config.inc

Si tu obtient un page blanche, c'est qu'il y a une erreur de codage

dans le tableau du style

$conf['links'] = array(
'http://phpwebgallery.net' => 'PWG website',
'http://forum.phpwebgallery.net' => 'PWG forum',
'http://phpwebgallery.net/doc' => 'PWG wiki'
);

l'erreur régulière c'est oublier la , en fin de ligne

Tu peux copier se que tu veux et on pourra plus facilement t'indiquer l'erreur ;-)


Vous aimez Piwigo alors n'hésitez pas à participer avec nous, plus d'infos sur la page "Contribuer à Piwigo". Si vous n'avez pas beaucoup de temps et que vous souhaitez nous soutenir vous pouvez aussi le faire par un don.

Hors ligne

#3 2010-05-17 06:24:01

Gilles
Membre
Brie Comte Robert
2007-01-19
30

Re: [Résolu] Problème local_config.inc

C'était bien ça. Autant pour moi, et 1000 mercis. Encore une fois, la communauté Piwigo n'a pas démérité!
Gilles

Hors ligne

#4 2010-05-17 07:17:53

VDigital
Former Piwigo Team
Paris (FR)
2005-05-04
15124

Re: [Résolu] Problème local_config.inc

Version de MySQL ??? précise, Merci.


PS: Erreur dans le titre du topic "Problème local_config.inc" : Non
mais "Erreur de syntaxe dans le config_local.inc" : Oui


Vincent -« Plus vidéaste averti que photographe amateur... »
La galerie - Le blog   

Piwigo est une application libre de gestion de photos en ligne.

Hors ligne

#5 2010-05-17 09:22:55

Gilles
Membre
Brie Comte Robert
2007-01-19
30

Re: [Résolu] Problème local_config.inc

- Nom du fichier: désolé pour l'indexation, il s'agit effectivement de Config_local.inc!
- Version de MySql: je suis hébergé chez LWS, et la version de MySql est la 4. Je peux passer en 5, mais il semble que je perds toutes mes bases de données dans ce cas.
Piwigo 2 est-il réellement dépendant de MySql 5?
Amicalement,
Gilles

Hors ligne

#6 2010-05-17 09:47:10

ddtddt
Équipe Piwigo
Quetigny (21) - France
2007-07-27
14613

Re: [Résolu] Problème local_config.inc

Peux tu préciser car 4 c'est trop vague ...


Vous aimez Piwigo alors n'hésitez pas à participer avec nous, plus d'infos sur la page "Contribuer à Piwigo". Si vous n'avez pas beaucoup de temps et que vous souhaitez nous soutenir vous pouvez aussi le faire par un don.

Hors ligne

#7 2010-05-17 10:27:30

nicolas
Former Piwigo Team
2004-12-30
1530

Re: [Résolu] Problème local_config.inc

Gilles a écrit:

- Nom du fichier: désolé pour l'indexation, il s'agit effectivement de Config_local.inc!
- Version de MySql: je suis hébergé chez LWS, et la version de MySql est la 4. Je peux passer en 5, mais il semble que je perds toutes mes bases de données dans ce cas.
Piwigo 2 est-il réellement dépendant de MySql 5?
Amicalement,
Gilles

Non pas nécessairement. Je n'ai plus en mémoire le problème précis mais une fois qu'on aura ta version précise de mysql (4.0.x ou 4.1.x) on pourra te répondre plus précisément.


Donnez du peps à vos tags
Laissez vos visiteurs vous aidez à tagger vos images avec user_tags

Hors ligne

#8 2010-05-17 12:06:01

VDigital
Former Piwigo Team
Paris (FR)
2005-05-04
15124

Re: [Résolu] Problème local_config.inc

Gilles a écrit:

- Nom du fichier: désolé pour l'indexation, il s'agit effectivement de Config_local.inc!
- Version de MySql: je suis hébergé chez LWS, et la version de MySql est la 4. Je peux passer en 5, mais il semble que je perds toutes mes bases de données dans ce cas.
Piwigo 2 est-il réellement dépendant de MySql 5?
Amicalement,
Gilles

4. C'est un peu comme si tu dis "j'ai un Olympus"
En admin, la version MySQL est affichée

Piwigo 2 est-il réellement dépendant de MySql 5? Non, pas forcément... D'où la question.

LWS ou un autre.
De toute façon une base cela s'exporte et s'importe.

Et tu peux t'entrainer au besoin en installant un server local comme WampServer.
T'entrainer avec 2 versions de MySQL au besoin pour te familiariser avec les fonctions d'export/import.
Google est ton ami, et tu trouveras les forums qui répondront à tes questions sur la procédure à appliquer.

Ma question reste:
Version de MySQL ??? précise, Merci.


Vincent -« Plus vidéaste averti que photographe amateur... »
La galerie - Le blog   

Piwigo est une application libre de gestion de photos en ligne.

Hors ligne

#9 2010-05-17 12:52:04

Gilles
Membre
Brie Comte Robert
2007-01-19
30

Re: [Résolu] Problème local_config.inc

Désolé de tant d'incompétence crasse (je suis plus photographe qu'informaticien!).
En mode admin, la version de MySql qui s'affiche est 'MySQL: 4.0.15-max-nt ' (suivi de la date et l'heure).
Amitiés
Gilles
PS: j'ai un Nikon, pas un Olympus! ;)

Hors ligne

#10 2010-05-17 14:08:32

VDigital
Former Piwigo Team
Paris (FR)
2005-05-04
15124

Re: [Résolu] Problème local_config.inc

Comme ça de mémoire, je dirai que tu pourrais avoir des problèmes avec MySQL 4.0 en raison du passage de Piwigo en UTF-8.
Essentiellement cela concerne les langues asiatiques mais pas seulement.

A mon avis, tu pourrais par la recherche rapide ne pas trouver certaines images.
Tu dois pouvoir passer en Piwigo 2.0.x

Plutôt que de tenter une migration (upgrade) tout de suite, je te conseille de commencer par faire une installation de test dans un autre répertoire et avec un autre préfixe de table pour quelques jours de tests.

Puis de supprimer ton environnement de test, et de faire la mise à jour de la vraie galerie quand tu te sentiras prêt à le faire.


Vincent -« Plus vidéaste averti que photographe amateur... »
La galerie - Le blog   

Piwigo est une application libre de gestion de photos en ligne.

Hors ligne

#11 2010-05-17 15:49:43

Gilles
Membre
Brie Comte Robert
2007-01-19
30

Re: [Résolu] Problème local_config.inc

Merci des conseils (et de la rapidité aux réponses!) Je vais suivre ton conseil et faire un test.
Amitiés
Gilles

Hors ligne

#12 2010-05-18 09:29:27

Gilles
Membre
Brie Comte Robert
2007-01-19
30

Re: [Résolu] Problème local_config.inc

VDigital a écrit:

(...), je te conseille de commencer par faire une installation de test dans un autre répertoire et avec un autre préfixe de table pour quelques jours de tests. (...).

J'ai suivi ton conseil (rappel environnement: Php5.1.1 / MySql 4.0). L'installation s'est déroulée nickel. 3 messages en fin d'install (2 concernant les données exif, et 1 informant de la possibilité de problèmes liés à la version de MySql). Ca semble marcher, mais je n'ai pas tout testé.
Je vais donc migrer, mais mon hébergeur m'informe que la migration vers MySql 5 va me faire perdre toutes mes bases MySql. J'ai une possibilité de les sauvegarder à partir de l'interface de gestion, mais quid de la restauration? Est-ce quelque chose de complexe / dangereux, ou est-ce d'une simplicité biblique?
Merci
Amitiés
Gilles

Hors ligne

#13 2010-05-18 10:26:03

VDigital
Former Piwigo Team
Paris (FR)
2005-05-04
15124

Re: [Résolu] Problème local_config.inc

3/4 cela rate, surtout quand on n'a jamais fait ça.

=>
Tu peux t'entrainer au besoin en installant un server local comme WampServer.
Avec ce serveur local, tu pourras t'entrainer avec 2 versions de MySQL pour te familiariser avec les fonctions d'export/import.
Google est ton ami.


Vincent -« Plus vidéaste averti que photographe amateur... »
La galerie - Le blog   

Piwigo est une application libre de gestion de photos en ligne.

Hors ligne

#14 2010-05-18 20:47:27

mathiasm
Former Piwigo Team
2006-02-06
2692

Re: [Résolu] Problème local_config.inc

Gilles, peux-tu passer le fil en résolu, le sujet local_config étant clos ? (Méthode: lien dans le 1er message du fil)

Merci

Hors ligne

  •  » Utilisation
  •  » [Résolu] Problème local_config.inc

Pied de page des forums

Propulsé par FluxBB

github twitter facebook newsletter Faire un don Piwigo.org © 2002-2019 · Contact