•  » Installation
  •  » [Résolu] Problème de migration de pwg 1.7.3 vers 2.0.7

#16 2010-01-29 07:55:58

VDigital
Former Piwigo Team
Paris (FR)
2005-05-04
15124

Re: [Résolu] Problème de migration de pwg 1.7.3 vers 2.0.7

Mise à jour | fr.piwigo.org
Dès que tu as un pb, ou que ce n'est pas clair...
=> Forum / Recherche sur récent / sinon question

Chez OVH (qui plus est avec un kitsufi) cela ne pose aucun pb de 1.7.3 vers 2.0.8

Rappel: Cette procédure de mise à jour est valable pour toutes les versions sorties après 2003 (release 1.3).


Vincent -« Plus vidéaste averti que photographe amateur... »
La galerie - Le blog   

Piwigo est une application libre de gestion de photos en ligne.

Hors ligne

#17 2010-01-29 07:57:58

VDigital
Former Piwigo Team
Paris (FR)
2005-05-04
15124

Re: [Résolu] Problème de migration de pwg 1.7.3 vers 2.0.7

ddtddt a écrit:

VDigital a écrit:

URL du site en privé si besoin...

tu lui as répondu ?

[Forum, post 131223 by grays in topic 16942] [Résolu] Problème de migration de pwg 1.7.3 vers 2.0.7

(Encore un petit effort le weekend arrive.)


Vincent -« Plus vidéaste averti que photographe amateur... »
La galerie - Le blog   

Piwigo est une application libre de gestion de photos en ligne.

Hors ligne

#18 2010-01-29 08:25:44

ddtddt
Équipe Piwigo
Quetigny (21) - France
2007-07-27
14449

Re: [Résolu] Problème de migration de pwg 1.7.3 vers 2.0.7

VDigital a écrit:

ddtddt a écrit:

VDigital a écrit:

URL du site en privé si besoin...

tu lui as répondu ?

[Forum, post 131223 by grays in topic 16942] [Résolu] Problème de migration de pwg 1.7.3 vers 2.0.7

(Encore un petit effort le weekend arrive.)

:-P ok je retourne me coucher :-D


Vous aimez Piwigo alors n'hésitez pas à participer avec nous, plus d'infos sur la page "Contribuer à Piwigo". Si vous n'avez pas beaucoup de temps et que vous souhaitez nous soutenir vous pouvez aussi le faire par un don.

Hors ligne

#19 2010-01-29 08:46:45

grays
Membre
2010-01-27
14

Re: [Résolu] Problème de migration de pwg 1.7.3 vers 2.0.7

Houla, pas tout suivi...

@ddtddt Oui et non, je n'ai pas répondu en privé, mais directement sur le post: photos.trollino.name

@VDigital Bon, je vais tenter de 17.3 vers 2.0.8, on sait jamais...

Merci pour vos coup de main en tout cas, j'espère que ça va aller... ;)

Hors ligne

#20 2010-01-29 10:11:10

Gotcha
Equipe Piwigo
Pierrelatte (26)
2007-03-14
13324

Re: [Résolu] Problème de migration de pwg 1.7.3 vers 2.0.7

Un point qui peut t'être utile.

Dans ton ancien fichier ./include/mysql.inc.php tu dois trouver ce genre de lignes :

Code:

$cfgBase = 'nom_de_votre_base';
$cfgUser = 'root';
$cfgPassword = 'mysql';
$cfgHote = 'localhost';
 
$prefixeTable = 'piwigo_';

Dans ton nouveau fichier ./include/mysql.inc.php il suffira de coller TES lignes provenant de ton ancien fichier.


Ayez comme premier réflexe de consulter le wiki.
Ensuite, veuillez effectuer une recherche sur le forum avant de poser votre question.

LE FAIRE EST LE REVELATEUR DE L'ETRE

Hors ligne

#21 2010-01-29 12:20:03

grays
Membre
2010-01-27
14

Re: [Résolu] Problème de migration de pwg 1.7.3 vers 2.0.7

Hum, ça oui, mis par contre ce n'est pas piwigo en préfixe de table, ça date de l'ancien nom, phpwebgallery, ça pourrait venir de là?

Hors ligne

#22 2010-01-29 12:29:45

Gotcha
Equipe Piwigo
Pierrelatte (26)
2007-03-14
13324

Re: [Résolu] Problème de migration de pwg 1.7.3 vers 2.0.7

il faut conserver l'ancien préfixe, sinon, c'est comme ci vous n'aviez pas de base de données ^^


Ayez comme premier réflexe de consulter le wiki.
Ensuite, veuillez effectuer une recherche sur le forum avant de poser votre question.

LE FAIRE EST LE REVELATEUR DE L'ETRE

Hors ligne

#23 2010-01-30 20:04:56

grays
Membre
2010-01-27
14

Re: [Résolu] Problème de migration de pwg 1.7.3 vers 2.0.7

Bon, toujours le même souci, même avec la version 2.0.8

Je vais essayer de faire par étape, p'tet qu'avec une version plus ancienne, ça va passer...

*soupir*

Hors ligne

#24 2010-01-30 20:54:25

grays
Membre
2010-01-27
14

Re: [Résolu] Problème de migration de pwg 1.7.3 vers 2.0.7

Hum, bon, c'est pas clair, mais c'est résolu...

J'ai simplement migré en copiant tous les fichiers de la version 2.0.8 par dessus la 1.7.3.
En gros, j'ai sauté l'étape 5.
Ce que je ne comprends pas, c'est que sur ce post: http://fr.piwigo.org/forum/viewtopic.php?id=16019
La personne a du justement bien passer par cette étape 5.
Si quelqu'un a une explication, je suis preneur.

Je dois avoir donc un p'tit fouillis de fichiers de la 1.7.3 et de a 2.0.8 en même temps. Pas top.

Mais bon, ça tourne, je verrai le reste plus tard.

Merci

Hors ligne

#25 2010-01-30 21:11:56

VDigital
Former Piwigo Team
Paris (FR)
2005-05-04
15124

Re: [Résolu] Problème de migration de pwg 1.7.3 vers 2.0.7

Étape 5 - Nettoyage (Seulement pour les utilisateurs Avancés)
Nettoyez par FTP (5 min.).
Attention ne supprimez pas :

    * le répertoire galleries (si vous utilisez le transfert FTP, vos photos sont ici)
    * le répertoire upload (si vous utilisiez pLoader, vos photos sont ici)
    * le répertoire Plugins (PhpWebGallery 1.7, ou Piwigo de 2.0, est capable de réutiliser leurs paramètres de configuration)
    * les répertoires de thème (ils devront être testés ultérieurement. En cas de non fonctionnement, vous devrez attribuer un autre thème à certains de vos membres. Avoir dans un profil un thème inexistant entrainerait des erreurs, et des utilisateurs seraient perdus.
    * Les template-common et template-extension (devront être testés).

Dans tous les cas ne supprimez pas ou restaurez immédiatement :

    * include/mysql.inc.php
    * include/config_local.inc.php

Si tu n'as donc pas supprimer par exemple le répertoire admin.
Ce qui veut dire que par FTP, en créant de nouveaux répertoires, ils sont créés avec des droits insuffisants.
Il va falloir qu'on pointe les droits des répertoires et fichiers distribués.
On trouvera l'explication.
Merci pour la piste.


Vincent -« Plus vidéaste averti que photographe amateur... »
La galerie - Le blog   

Piwigo est une application libre de gestion de photos en ligne.

Hors ligne

#26 2010-01-30 21:27:44

Gotcha
Equipe Piwigo
Pierrelatte (26)
2007-03-14
13324

Re: [Résolu] Problème de migration de pwg 1.7.3 vers 2.0.7

Par contre ça veut dire qu'il doit rester des fichiers "obsolètes" ...


Ayez comme premier réflexe de consulter le wiki.
Ensuite, veuillez effectuer une recherche sur le forum avant de poser votre question.

LE FAIRE EST LE REVELATEUR DE L'ETRE

Hors ligne

#27 2010-01-30 21:51:57

VDigital
Former Piwigo Team
Paris (FR)
2005-05-04
15124

Re: [Résolu] Problème de migration de pwg 1.7.3 vers 2.0.7

"obsolètes": hors d'usage, qu'on n'utilise plus, dépassés, à mettre à la poubelle, ils peuvent contenir du code qui pourrait fonctionner et casser le fonctionnement actuel de la galerie.
Et l'Auto update de P@t fait le ménage au fur et à mesure sans que tu le saches.


Vincent -« Plus vidéaste averti que photographe amateur... »
La galerie - Le blog   

Piwigo est une application libre de gestion de photos en ligne.

Hors ligne

#28 2010-01-30 22:20:08

Gotcha
Equipe Piwigo
Pierrelatte (26)
2007-03-14
13324

Re: [Résolu] Problème de migration de pwg 1.7.3 vers 2.0.7

VDigital a écrit:

Et l'Auto update de P@t fait le ménage au fur et à mesure sans que tu le saches.

C'est "fou" comment tout est prévu ...!

:-)


Ayez comme premier réflexe de consulter le wiki.
Ensuite, veuillez effectuer une recherche sur le forum avant de poser votre question.

LE FAIRE EST LE REVELATEUR DE L'ETRE

Hors ligne

#29 2010-01-31 12:09:01

grays
Membre
2010-01-27
14

Re: [Résolu] Problème de migration de pwg 1.7.3 vers 2.0.7

Cool, pour les fichiers obsolètes qui vont être nettoyés au fur et à mesure, c'est une très bonne chose. ;) J'suis moins inquiet dans ce cas pour le code qui pourrait être source de problème par la suite.

Ha, une précision qui a son importance, je n'ai pas de serveur ftp, je n'aime pas ça. J'ai simplement téléchargé l'archive .zip (wget -c est mon ami) et je l'ai dézippé dans un répertoire à côté pour pouvoir manipuler les fichiers tranquillement. Mais donc, les répertoires ont été crées avec les droits de l'archive. Mais effectivement, je n'ai rien effacé en template, plugins, tools, admin, blablabla... ;)

Grays, content que ça fonctionne et ya plus qu'à ajouter d'autres galeries

Hors ligne

  •  » Installation
  •  » [Résolu] Problème de migration de pwg 1.7.3 vers 2.0.7

Pied de page des forums

Propulsé par FluxBB

github twitter facebook newsletter Faire un don Piwigo.org © 2002-2019 · Contact