Annonce

  •  » Outils
  •  » pLoader pour Windows, préparer et transférer ses photos

#61 2009-07-03 01:11:36

plg
Équipe Piwigo
Nantes, France, Europe
2002-04-05
12522

Re: pLoader pour Windows, préparer et transférer ses photos

fibo a écrit:

Suis preneur de l'explication.

* [Forum, post 94949 by plg in topic 13823] [Evolution] Amélioration de l'upload de photos
* [Forum, post 97968 by plg in topic 13998] [pLoader] spécifications ?
* [english wiki] pwg.images.add & pwg.images.addChunk

Et notamment sur les droits d'accès aux différents répertoires cela peut être utile...

Pour être très précis : le propriétaire du processus du serveur httpd (Apache) doit avoir les droits en écriture sur le répertoire "upload". Par exemple, sous Debian, par défaut, c'est www-data qui est propriétaire du processus apache2, donc il doit avoir les droits en écriture sur "upload".


Historiquement, premier utilisateur connu de Piwigo ;-)

Hors ligne

#62 2009-07-03 01:24:09

plg
Équipe Piwigo
Nantes, France, Europe
2002-04-05
12522

Re: pLoader pour Windows, préparer et transférer ses photos

fibo a écrit:

upload high (original size) sélectionné

Fais les premiers essais en décochant cette option (elle consomme beaucoup de réseau et ralentit les tests).

fibo a écrit:

image blur: cékoi?

c'est l'algorithme de création du flou. Mais un flou inférieur à 1 créé de la... netteté. Ce n'est pas très "user friendly" comme paramètre de configuration. On devrait sans doute le déplacer dans "advanced" (nouvel onglet dans pLoader 2.0.3a ou 2.0.2d, on ne sait pas encore).

fibo a écrit:

Suis allé jeter un coup d'oeil dans .../upload
J'en ai transféré une copie  en local. Les fichiers jpg ne sont pas reconnus par Gimp...
Peut-être aurais-je dû le nettoyer  avant de faire d'autres tentatives?

Très très très intéressant. Je réalise qu'il y a une coquille dans mon algo sur la gestion des chunks et de leur fusion. Si un upload plante, les chunks restent là et quand on relance l'ajout, il va fusionner les anciens + les nouveaux chunks, donc la photo est corrompue la deuxième fois même si le second upload a marché.

En attendant que je trouve une solution plus propre, il faudrait purger le répertoire "upload/buffer". Et relancer un upload pour voir (pas sûr du tout que ça soit la solution, la gestion plus fine des erreurs citée par ron va sérieusement nous aider à résoudre ce genre de soucis).


Historiquement, premier utilisateur connu de Piwigo ;-)

Hors ligne

#63 2009-07-03 08:51:43

small59
Membre
Lille
2009-06-09
43

Re: pLoader pour Windows, préparer et transférer ses photos

plg a écrit:

small59 a écrit:

[...] bien que ce soit une catégorie "privée". Je pensais que ce n'était pas possible [...]

L'important, ce n'est pas qu'elle soit privée, mais qu'elle soit accessible ou non à l'utilisateur qui se connecte avec pLoader. Mais je te confirme que pLoader prend en compte les permissions.

small59 a écrit:

[...] les données EXIF faisait apparaitre que la prise de vue originale était en "vertical". Y a t il un lien ?

Oui. Si le tag EXIF "orientation" est noté comme "à tourner de 90 degrés" et que lorsque tu as manuellement tourné ta photo, cela n'a pas mis à jour le tag EXIF (ce qui aurait dû être fait par l'application qui a tourné la photo), alors pLoader lui applique l'instruction et tourne la photo à 90 degrés. Tu peux désactiver ce comportement en décochant "Global settings > General > Auto rotate image".

La solution dans ton cas, c'est de supprimer la photo (voir [Forum, post 107898 by Zaphod in topic 15110] Supprimer les éléments non liés ?), de vider ton cache côté pLoader (lire [Forum, topic 15713] Ploader fait grève ... [RESOLU] CCleaner est ton ami !) et d'ajouter à nouveau la photo en question.

merci pour ces explications, et bonne journée

Hors ligne

#64 2009-07-03 10:15:14

ron
Former Piwigo Team
2008-09-30
211

Re: pLoader pour Windows, préparer et transférer ses photos

small59 a écrit:

par contre je me suis rendu compte qu'une photo sur le site était orientée à "l'horizontale" (attention au torticolis !) alors que l'original est sur mon disque dur "à la verticale" ! et pas moyen de la mettre comme il faudrait = "à la verticale"...
j'ai un peu farfouillé et découvert que les données EXIF faisait apparaitre que la prise de vue originale était en "vertical". Y a t il un lien ?

Normalement l'orientation exif de l'original indique la position de l'appareil photo, et pLoader applique une rotation inverse si nécessaire.

Dans certains cas, la photo a déjà été "redressée" par une autre application, sans que l'orientation exif soit changée pour indiquer la nouvelle orientation. Dans ce cas, pLoader, se basant sur cette information erronée, applique une seconde fois la rotation.

small59 a écrit:

j'ai changé l'option concernée de ploader "autorotate image" cochée et décochée en rechargeant l'image à chaque fois, mais sans le résultat escompté. Peut-être y a t il un pb de cache, de cookie, ... ?

Voici la marche à suivre dans ce cas :

- Dans l'administration Piwigo, supprimer la photo.
- Supprimer la photo dans le cache pLoader : C:\Documents and Settings\<User>\Local Settings\Application Data\.pLoader\resize
- décocher l'option  "autorotate image"
- recharger la photo dans pLoader
- transférer la photo dans pLoader

Les prochaines versions de pLoader éviteront ce genre de manip.

Hors ligne

#65 2009-07-03 11:32:07

small59
Membre
Lille
2009-06-09
43

Re: pLoader pour Windows, préparer et transférer ses photos

ron a écrit:

Voici la marche à suivre dans ce cas :

- Dans l'administration Piwigo, supprimer la photo.
- Supprimer la photo dans le cache pLoader : C:\Documents and Settings\<User>\Local Settings\Application Data\.pLoader\resize
- décocher l'option  "autorotate image"
- recharger la photo dans pLoader
- transférer la photo dans pLoader

Les prochaines versions de pLoader éviteront ce genre de manip.

je viens de suivre ta procédure (et après avoir enregistrées les données EXIF de la photo pour être sûr que celles ci correspondent bien à l'image affichée) et ça fonctionne. Je retrouve sur le site une image maintenant bien orientée.

Par contre, je viens d'observer que la prévisualisation lors un clic droit sur la photo dans ploader,  ne donne qu'un affichage très très partiel de la photo (quelques ligne de pixels) !? un bug ?

cord.

Hors ligne

#66 2009-07-03 12:35:24

ron
Former Piwigo Team
2008-09-30
211

Re: pLoader pour Windows, préparer et transférer ses photos

small59 a écrit:

Par contre, je viens d'observer que la prévisualisation lors un clic droit sur la photo dans ploader,  ne donne qu'un affichage très très partiel de la photo (quelques ligne de pixels) !? un bug ?

cord.

Oui, c'est un bug qui est normalement corrigé dans la prochaine version : [Bugtracker] ticket 1027

Hors ligne

#67 2009-07-03 15:33:57

fibo
Membre
1970-01-01
14

Re: pLoader pour Windows, préparer et transférer ses photos

Désolé, mais je n'y arrive pas malgré près d'une heure de manips et essais

Denier essai:
- j'ai nettoyé les fichiers locaux (tous)
- j'ai nettoyé le /upload distant
- resize activé
- transfert high désactivé
-  loader chargé avec ces réglages

Apparemment, je suis bien arrivé à obtenir l'image dans upload (mais seulement après avoir nettoyé le cache local)... mais piwigo ne semble pas en vouloir

J'ai fait un rar de ces deux dossiers.

Au passage (mais légèrement HS): prévoir un bouton pour nettoyer le cache local. Voire distant.

Dernière modification par fibo (2009-07-03 15:37:50)

Hors ligne

#68 2009-07-06 07:17:04

ddtddt
Équipe Piwigo
Quetigny (21) - France
2007-07-27
16144

Re: pLoader pour Windows, préparer et transférer ses photos


Vous aimez Piwigo alors n'hésitez pas à participer avec nous, plus d'infos sur la page "Contribuer à Piwigo". Si vous n'avez pas beaucoup de temps et que vous souhaitez nous soutenir vous pouvez aussi le faire par un don.

Hors ligne

#69 2009-07-06 09:36:43

fibo
Membre
1970-01-01
14

Re: pLoader pour Windows, préparer et transférer ses photos

Désolé, je n'y arrive toujours pas.
Cette fois j'ai une erreur 500 et un upload en erreur.
Il y a un fichier .block dans uplaod/buffer. Et, après quelques essais, plus d'un fichier .jpg dans 2009/07/06.

Background:
- piwigo 2.0.3
- j'ai mis le dossier cible en 775 bien que je n'aime pas trop
- ploader 2.0.3a
- j'avais vidé le fichier de local settings.

Désolé, mais chaque essai prend 30 minutes et je vois peu de changement. Je suis frustré d'essayer de deviner une recette magique pour que cela marche, sans voir la moindre évolution.

Ne croyez pas que j'ignore le travail que représentent piwigo et ploader, mais je dois avancer sur deux-trois autres "petites" choses. 
J'envisage en ce qui me concerne deux possibilités:
1 - je laisse tomber, dans quelque temps les problèmes auront été résolus (merci de vos efforts)
2 - vous me dites toutes les infos dont vous avez besoin, quels fichiers vous voulez, quels accès etc. je vous les donne en MP, vous testez tout ce que vous voulez  et quand vous me dites que c'est réglé j'essaie encore.

Mais en tous cas, je ne teste plus à l'aveugle

Hors ligne

#70 2009-07-07 00:50:45

plg
Équipe Piwigo
Nantes, France, Europe
2002-04-05
12522

Re: pLoader pour Windows, préparer et transférer ses photos

fibo, ton problème me fait penser à [Forum, topic 15758] Ploader - upload ok mais image non visible

Maintenant que tu as un pLoader 2.0.3a, est-ce que tu peux essayer de mettre une plus petite valeur dans [Global Settings > Advanced > Transfert Chunk Size], 50000 par exemple (un zero de moins).

Si le problème persiste, je te propose de créer un compte sur http://www.piwigo.com et de faire un essai dessus, pour déterminer si c'est plutôt un problème côté client ou côté serveur.

fibo, tes tests et ta volonté de faire marcher le couple pLoader/Piwigo est une contribution en soit pour le projet. Merci pour ça :-)


Historiquement, premier utilisateur connu de Piwigo ;-)

Hors ligne

#71 2009-07-07 13:16:15

fibo
Membre
1970-01-01
14

Re: pLoader pour Windows, préparer et transférer ses photos

plg a écrit:

fibo, ton problème me fait penser à [Forum, topic 15758] Ploader - upload ok mais image non visible

Maintenant que tu as un pLoader 2.0.3a, est-ce que tu peux essayer de mettre une plus petite valeur dans [Global Settings > Advanced > Transfert Chunk Size], 50000 par exemple (un zero de moins).

Si le problème persiste, je te propose de créer un compte sur http://www.piwigo.com et de faire un essai dessus, pour déterminer si c'est plutôt un problème côté client ou côté serveur.

- Créé compte sur piwigo.

1 - depuis une autre machine (Vista).
- maj ploader vers 2.0.3a (install effectué en mode admin vista)
- lance ploader. connexion à piwigo.com OK
- Je crée un dossier sur le site. ok
- Je sélectionne une image.... ça se gâte: image processing ok. MAIS quand je clique "close" ça plante "ne répond pas"
- "gestionnaire des tâches de windows" me dit que ploader "pas de réponse" (il n'identifie apparemment qu'une fenêtre, pas deux)
- je tue ploader avec gestionnaire des tâches
- je relance
HORREUR je réalise que le raccourci que j'utilise me lance ploader 2.0.2 (ah bon, la maj de désinstalle pas? faudra que je vérifie sur mon autre machine!!!!!!!!!!!!!!!)
- désinstall ploader. The plot thickens je ne peux désinstaller que 2.0.3!!! Le raccourci windows pointe vers "C:\Program Files\pLoader\bin\pLoader.exe"
--> je désinstalle tout (par le lien de désinstall de ploader), on verra après. l'icône de désinstall du panneau de contrôle disparaît (ouf)
- apu répertoire ploader
- recherche dans C:\ProgramData, pas de répertoire ploader
- dans C:\Users\xxxxxxx\AppData\Local, .ploader semble vide, mais je le détruis
- réinstall plader en mode admin
- lancer: connect piwigo.com ok. suis bien en version 2.0.3
- advanced, chunk à 50 000
- ajout une image.
- traitement OK, 'progression du traitement de l'image'... et plantage sur clic du bouton "close"
- fermeture par le gestionnaire de tâches. relance en local hors connexion
- relecture image. plantage

Bon, c'est pas tout ça, encore une heure partie en fumée.


plg a écrit:

fibo, tes tests et ta volonté de faire marcher le couple pLoader/Piwigo est une contribution en soit pour le projet. Merci pour ça :-)

B-) J'espère surtout que je pourrai ainsi faire que mes amis chargent les photos sans mon aide... mais j'aurais passé moins de temps si je les avais aidé à distance, même en leur faisant installer filezilla!

Dernière modification par fibo (2009-07-07 13:36:19)

Hors ligne

#72 2009-07-08 01:54:24

fibo
Membre
1970-01-01
14

Re: pLoader pour Windows, préparer et transférer ses photos

Bizarre bizarre

Cette fois depuis la machine XP
- Je lance le ploader 2.0.3a "installé" hier... sauf qu'il m'affiche 2.0.2c
- Je désinstalle. Je veux détruire C:\Documents and Settings\xxx\Local Settings\Application Data\.pLoader ... qui bloque et refuse de détruire le sous répertoire preview, même après que je l'aie vidé.
- Je réinstalle, je lance ploader qui m'affiche toujours 2.0.2c et qui donc ne permet pas advanced.
- A tout hasard, je charge une image pour l'envoyer sur piwigo
- Tout se passe bien (enfin!)
- Essai de charger 6 photos d'un coup. Tout se passe bien

SAUF QUE (Hors du sujet du thread) je n'arrive pas à détruire ces photos!!! Comment faire???

- j'essaie alors de charger ma photo initiale vers mon site 2.0.3
- l'envoi foire avec une erreur 500 (copie message attachée)

Résumé de mon expérience de ce jour:
- tant sur Vista que sur XP, l'install de ploader 2.0.3a ne fonctionne pas totalement, puisque c'est la 2.0.2 qui s'affiche (pas d'onglet advanced)
- sur Vista, après désinstall + nettoyage des fichiers + ré-install de ploader, celui-ci accepte de s'installer en 2.0.3. ... mais plante lors du traitement local des images
- sur XP, le désinstall semble marcher MAIS pas possible de détruire .ploader/preview/. Le ré-install semble marcher...  mais en fait on affiche toujours 2.0.2c. Le traitement local et l'envoi vers piwigo marche correctement. L'envoi vers "mon" serveur plante avec erreur 500

Hors ligne

#73 2009-07-08 02:13:32

plg
Équipe Piwigo
Nantes, France, Europe
2002-04-05
12522

Re: pLoader pour Windows, préparer et transférer ses photos

(je répondrais plus en détails demain, mais pour info, je viens à l'instant tout juste maintenant de passer les installations de piwigo.com en 2.0.3, au cas où ça nous éclairerait)


Historiquement, premier utilisateur connu de Piwigo ;-)

Hors ligne

#74 2009-07-08 16:24:48

fibo
Membre
1970-01-01
14

Re: pLoader pour Windows, préparer et transférer ses photos

Je pense qu'il y a plusieurs pistes à explorer / corriger

- un désinstall qui marche proprement ou indique les problèmes (important)
peut-être associé à un bouton "info" qui mette dans un fichier les infos utiles de config (versions des dll et de fichiers)

- un bouton de nettoyage du cache local (pratique mais pas indispensable)

- important: pouvoir demander en option des messages d'erreurs plus détaillés, ne serait-ce que pour fournir un bon feedback (au lieu d'avoir un description détaillée de ce que j'ai fait... et qui n'est guère intéressant a priori.

Hors ligne

#75 2009-07-13 21:04:07

Eric B
Membre
2003-10-02
231

Re: pLoader pour Windows, préparer et transférer ses photos

je viens de m inscrire a piwigo.com et viens d essayer pLoader 2.0.3a dessus.
J ai commencé par creer un album, mais là, pLoader freeze depuis l upload et occupe 50% de mon CPU.
Certes, j ai  pris 2 images pleine résolution, mais je pensais qu elles étaient redimmensionnées avant l upload.

Bref, usability de base: y a t il une gestion multithreading ds l outil, et notamment un thread "GUI" séparé d un thread "logic".
Un exe mono bloc de 15Mo, je ne suis pas fan, mais bon, pq pas...

Dans quel environnement est développé pLoader? Est ce open source comme pwigo? J ai pas trouvé où...

Par ailleurs, pouquoi l install demande des droits admin sous Windows? J utilise la version Win sous XP SP3 en "power user"...

Hors ligne

  •  » Outils
  •  » pLoader pour Windows, préparer et transférer ses photos

Pied de page des forums

Propulsé par FluxBB

github twitter newsletter Faire un don Piwigo.org © 2002-2022 · Contact