Annonce

#16 2009-02-27 09:04:39

Pilou bis
Membre
2008-02-15
143

Re: Migration 1.7.3 à 2.0.0

VDigital a écrit:

Elle arrive bientôt.


Je crois qu'elle est là...
Merci Pierrick.

Merci ;)

Hors ligne

#17 2009-03-04 17:41:28

Doursin
Membre
2008-09-26
31

Re: Migration 1.7.3 à 2.0.0

Et pour mon problème, vuos avez une idée?

J'ai tout refait depuis le départ grâce à mon backup et je suis retombé sur la même chose.

Précision : Pour l'upgrade, à la demande du compte Administrateur, il n'a pas l'air de le retrouver : mot de passe invalide

Dernière modification par Doursin (2009-03-04 17:41:54)

Hors ligne

#18 2009-03-04 18:48:54

P@t
Équipe Piwigo
Nice
2007-06-13
5694

Re: Migration 1.7.3 à 2.0.0

Doursin a écrit:

Et pour mon problème, vuos avez une idée?

J'ai tout refait depuis le départ grâce à mon backup et je suis retombé sur la même chose.

Précision : Pour l'upgrade, à la demande du compte Administrateur, il n'a pas l'air de le retrouver : mot de passe invalide

Il faut restaurer le fichier mysql.inc.php AVANT de lancer l'upgrade bien entendu...

Dernière modification par P@t (2009-03-04 18:49:02)


P@t

Hors ligne

#19 2009-03-05 09:53:28

Doursin
Membre
2008-09-26
31

Re: Migration 1.7.3 à 2.0.0

Déja fait ainsi que le fichier config_local.inc.php

Et au niveau de l'upgrade, il m'indique une upgrade de la 1.3.0 à 2.0.0 alors que d'origine je suis en 1.7.3

Dernière modification par Doursin (2009-03-05 09:58:05)

Hors ligne

#20 2009-03-05 21:08:10

ddtddt
Équipe Piwigo
Quetigny (21) - France
2007-07-27
15288

Re: Migration 1.7.3 à 2.0.0

Doursin a écrit:

VDigital a écrit:

Step 5 - ...

Dans tous les cas, NE PAS supprimer (ou restaurer immédiatement):

include/mysql.inc.php
include/config_local.inc.php

J'avais restauré les deux fichiers. Voici pour mysql.inc.php :

<?php
$cfgBase = '****';
$cfgUser = '****';
$cfgPassword = '****';
$cfgHote = 'localhost';

$prefixeTable = 'Intranet_';

define('PHPWG_INSTALLED', true);
?>

Structure du fichier après upgrade:

<?php
$cfgBase = 'Nom de ta base';
$cfgUser = 'user de la base';
$cfgPassword = 'mots de passe de la base';
$cfgHote = 'localhost / adresse de la base';

$prefixeTable = '***_';

define('PHPWG_INSTALLED', true);
define('PWG_CHARSET', 'utf-8');
define('DB_CHARSET', 'utf8');
define('DB_COLLATE', '');

?>


Vous aimez Piwigo alors n'hésitez pas à participer avec nous, plus d'infos sur la page "Contribuer à Piwigo". Si vous n'avez pas beaucoup de temps et que vous souhaitez nous soutenir vous pouvez aussi le faire par un don.

Hors ligne

#21 2009-03-06 09:24:27

Doursin
Membre
2008-09-26
31

Re: Migration 1.7.3 à 2.0.0

Doursin a écrit:

Suite à l'ajout des 3 instructions dans mysql.inc.php pour donner la valeur "utf-8" à PWG_charset et db_charset, j'ai un autre message d'erreur :

Fatal error: Call to undefined function get_language_filepath() in ******\plugins\download_multi\include\class.inc.php on line 140

Ce plugin devrait marcher?

Depuis le fichier class.inc.php, l'erreur vient de :

  // Chargement des fichiers langues
  function load_lang() {
    global $lang;
    include(get_language_filepath('plugin.lang.php', $this->plugin_path) );

Et suite à ce qu'a dit VDigital.....

doursin a écrit:

Après avoir virer du dossier plugins pas mal d'éléments, je suis arrivé à ma gallerie. Mais quelques messages d'avertissement en haut de la page sont apparues :

Notice: Undefined index: image_access_type in ********\include\functions_user.inc.php on line 1277

Notice: Undefined index: level in ********\include\functions_user.inc.php on line 1291

Notice: Undefined index: upload_user_access in ********\include\functions_category.inc.php on line 484

Notice: Undefined index: upload_link_everytime in *******\include\functions_category.inc.php on line 493

Est-ce normal ?

EDIT : Finalement, j'ai juste désinstallé multi_download. Avec les plug ins restant, j'accéde à la galerie, mais toujours avec ces erreurs.

Puis....

doursin a écrit:

Suite à mes problème et en vue de les résoudre, j'ai fait une synchro : Plus du tout de catégorie aussi bien au milieu de la page d'accueil que dans le menu de gauche. On m'indique juste le nombre d'éléments ainsi que d'autres erreurs:

Notice: Undefined index: level in **********\include\functions_user.inc.php on line 313


Warning:  [mysql error 1064] You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near '' at line 4

SELECT DISTINCT(id)
  FROM Intranet_images INNER JOIN Intranet_image_category ON id=image_id
  WHERE category_id NOT IN (0)
    AND level> in ********\include\functions.inc.php on line 919


Warning: mysql_fetch_array(): supplied argument is not a valid MySQL result resource in **********\include\functions.inc.php on line 937

Notice: Undefined index: level in **********\include\functions_user.inc.php on line 591


Warning:  [mysql error 1064] You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near 'GROUP BY c.id' at line 8
SELECT c.id cat_id, global_rank,
  MAX(date_available) date_last, COUNT(date_available) nb_images
FROM Intranet_categories as c
  LEFT JOIN Intranet_image_category AS ic ON ic.category_id = c.id
  LEFT JOIN Intranet_images AS i
    ON ic.image_id = i.id
      AND i.level<=
  GROUP BY c.id in **********\include\functions.inc.php on line 919


Warning: mysql_fetch_assoc(): supplied argument is not a valid MySQL result resource in ********\include\functions_user.inc.php on line 610


Warning:  [mysql error 1054] Unknown column 'cache_update_time' in 'field list'

INSERT INTO Intranet_user_cache
  (user_id, need_update, cache_update_time, forbidden_categories, nb_total_images,
    image_access_type, image_access_list)
  VALUES
  (1,'false',1235659284,'0',1915,"NOT IN","0")
; in *********\include\functions.inc.php on line 919


Notice: Undefined index: upload_user_access in *********\include\functions_category.inc.php on line 484

Notice: Undefined index: upload_link_everytime in ********\include\functions_category.inc.php on line 493

Et enfin j'ai remis mes fichiers de départ (mon backup de la 1.7.3) et refait la mise à jour : Même chose

Hors ligne

Pied de page des forums

Propulsé par FluxBB

github twitter newsletter Faire un don Piwigo.org © 2002-2020 · Contact