#1 2009-02-27 22:10:41

zoom
Membre
2008-02-29
154

Encore un problème d'exifs

Bonjour,
Installation de la realease 2.0.0 en local sur un QNAP 209.

Message à l'installation:

      La valeur de $conf['show_exif'] n'est pas correcte parce que l'exif n'est pas supporté
$conf['show_exif'] doit être mis à "false" dans votre fichier config_local.inc.php
Allez sur le forum ou le wiki pour plus d'informations
      La valeur de $conf['use_exif'] n'est pas correcte parce que l'exif n'est pas supporté$conf['use_exif'] doit être mis à "false" dans votre fichier config_local.inc.php

Allez sur le forum ou le wiki pour plus d'informations

Il semble que je dois activer (vu sur le forum avec réponse de VDigital)
extension=php_mbstring.dll
extension=php_exif.dll

Mais où?
Voici mon php.ini:

[PHP]
engine = On
short_open_tag = On
asp_tags = Off
precision    =  12
y2k_compliance = On
output_buffering = On
zlib.output_compression = Off
implicit_flush = Off
unserialize_callback_func=
serialize_precision = 100
allow_call_time_pass_reference = On
safe_mode = Off
safe_mode_gid = Off
safe_mode_include_dir =                               
safe_mode_exec_dir =
safe_mode_allowed_env_vars = PHP_
safe_mode_protected_env_vars = LD_LIBRARY_PATH
disable_functions =
disable_classes =
expose_php = On
max_execution_time = 700    ; Maximum execution time of each script, in seconds
max_input_time = 300    ; Maximum amount of time each script may spend parsing request data
memory_limit = 64MB     ; Maximum amount of memory a script may consume (8MB)
error_reporting  =  E_ALL & ~E_NOTICE
display_errors = On
display_startup_errors = Off
log_errors = Off
log_errors_max_len = 1024
ignore_repeated_errors = Off
ignore_repeated_source = Off
report_memleaks = On
track_errors = Off
variables_order = "EGPCS"
register_globals = Off
register_argc_argv = On
post_max_size = 12M
gpc_order = "GPC"
magic_quotes_gpc = On
magic_quotes_runtime = Off   
magic_quotes_sybase = Off
auto_prepend_file =
auto_append_file =
default_mimetype = "text/html"
doc_root =
user_dir =
extension_dir = /usr/local/apache/libexec
enable_dl = On
file_uploads = On
upload_max_filesize = 8M
allow_url_fopen = On
default_socket_timeout = 60

[gettext]
GetText Support enabled

[Syslog]
define_syslog_variables  = Off

[mail function]
SMTP = localhost
smtp_port = 25

[Java]

[SQL]
sql.safe_mode = Off

[ODBC]
odbc.allow_persistent = On
odbc.check_persistent = On
odbc.max_persistent = -1
odbc.max_links = -1
odbc.defaultlrl = 4096
odbc.defaultbinmode = 1

[MySQL]
mysql.allow_persistent = On
mysql.max_persistent = -1
mysql.max_links = -1
mysql.default_port =
mysql.default_socket =
mysql.default_host =
mysql.default_user =
mysql.default_password =
mysql.connect_timeout = 60
mysql.trace_mode = Off

[mSQL]
msql.allow_persistent = On
msql.max_persistent = -1
msql.max_links = -1

[PostgresSQL]
pgsql.allow_persistent = On
pgsql.auto_reset_persistent = Off
pgsql.max_persistent = -1
pgsql.max_links = -1
pgsql.ignore_notice = 0
pgsql.log_notice = 0

[Sybase]
sybase.allow_persistent = On
sybase.max_persistent = -1
sybase.max_links = -1
sybase.min_error_severity = 10
sybase.min_message_severity = 10
sybase.compatability_mode = Off

[Sybase-CT]
sybct.allow_persistent = On
sybct.max_persistent = -1
sybct.max_links = -1
sybct.min_server_severity = 10
sybct.min_client_severity = 10

[dbx]
dbx.colnames_case = "unchanged"

[bcmath]
bcmath.scale = 0

[browscap]

[Informix]
ifx.default_host =
ifx.default_user =
ifx.default_password =
ifx.allow_persistent = On
ifx.max_persistent = -1
ifx.max_links = -1
ifx.textasvarchar = 0
ifx.byteasvarchar = 0
ifx.charasvarchar = 0
ifx.blobinfile = 0
ifx.nullformat = 0

[Session]
session.save_handler = files
session.use_cookies = 1
session.name = PHPSESSID
session.auto_start = 0
session.cookie_lifetime = 0
session.cookie_path = /
session.cookie_domain =
session.serialize_handler = php
session.gc_probability = 1
session.gc_divisor     = 100
session.gc_maxlifetime = 1440
session.bug_compat_42 = 1
session.bug_compat_warn = 1
session.referer_check =
session.entropy_length = 0
session.entropy_file =
session.cache_limiter = nocache
session.cache_expire = 180
session.use_trans_sid = 0
url_rewriter.tags = "a=href,area=href,frame=src,input=src,form=,fieldset="

[MSSQL]
mssql.allow_persistent = On
mssql.max_persistent = -1
mssql.max_links = -1
mssql.min_error_severity = 10
mssql.min_message_severity = 10
mssql.compatability_mode = Off
mssql.secure_connection = Off

[Assertion]

[Ingres II]
ingres.allow_persistent = On
ingres.max_persistent = -1
ingres.max_links = -1
ingres.default_database =
ingres.default_user =
ingres.default_password =

[Verisign Payflow Pro]
pfpro.defaulthost = "test-payflow.verisign.com"
pfpro.defaultport = 443
pfpro.defaulttimeout = 30

[com]

[Printer]

[mbstring]

[FrontBase]

[Crack]

[exif]
EXIF Support enabled


[iconv]
iconv support enabled

[eaccelerator]

extension = eaccelerator.so
eaccelerator.shm_size = 16
eaccelerator.cache_dir = /.eaccelerator.tmp
eaccelerator.enable = 1
eaccelerator.optimizer = 1
eaccelerator.check_mtime = 1
eaccelerator.debug = 0
eaccelerator.filter =
eaccelerator.shm_max = 1M
eaccelerator.shm_ttl = 0
eaccelerator.shm_prune_period = 3600
eaccelerator.shm_only = 0
eaccelerator.compress = 1
eaccelerator.compress_level = 9


; End:

J'avais rajouté avec la RC3
[exif]
EXIF Support enabled

Et pas de résultats

Sinon il me reste la possibilité de creer dans ./include/config_local.inc.php :
<?php
$conf['show_exif'] = false;
$conf['use_exif'] = false;
?>

Sauf que j'aimerai comprendre la différence entre ces deux solutions  peut être vaudrait-il mieux activer les exifs sur le php.ini?
Qu'est ce que cela m'apportera de plus? le transfert des infos de la photo?

Merci de votre aide.
Cordialement vôtre.
zoom

Dernière modification par zoom (2009-02-27 23:05:07)


Bien cordialement, Zoomy
Version Piwigo:2.8.1
Hébergeur O2switch; PHP: 5.6.20; MySQL: 5.6.29-76.2
url: http://zoomyphoto.fr

Hors ligne

#2 2009-02-28 02:46:11

Eric
Équipe Piwigo
VALENCE (FR)
2005-03-25
4579

Re: Encore un problème d'exifs

Salut.

Je ne connais pas le QNAP 209 mais il me semble qu'il manque la section "extensions" dans ton php.ini. En tous cas, elle existe chez moi, sous WampServer (serveur apache) et sous IIS avec implémentation php.

Vérifies aussi si tu as le fichier php_exif dans ton dossier /usr/local/apache/libexec.

zoom a écrit:

Sinon il me reste la possibilité de creer dans ./include/config_local.inc.php :
<?php
$conf['show_exif'] = false;
$conf['use_exif'] = false;
?>

Sauf que j'aimerai comprendre la différence entre ces deux solutions  peut être vaudrait-il mieux activer les exifs sur le php.ini?
Qu'est ce que cela m'apportera de plus? le transfert des infos de la photo?

Quelles "deux solutions" ?

Si ton php accepte l'extension exif, tu peux laisser $conf['show_exif'] et $conf['use_exif'] à "true". Cela permettra d'avoir les informations exif de tes photos dans ta galerie.

Si tu n'arrives pas à intégrer exif, alors il te reste la solution IPTC (donc passer  $conf['show_exif'] et $conf['use_exif'] à "false" et  $conf['show_iptc'] et $conf['use_iptc'] à "true"). Mais cela t'obligeras à saisir manuellement les informations que tu souhaites pour chaque photo avec ton logiciel de traitement d'images favori.

Hors ligne

#3 2009-02-28 18:05:49

zoom
Membre
2008-02-29
154

Re: Encore un problème d'exifs

Merci Eric de ta réponse.
Comment je peux accéder à /usr/local/apache/libexec. ?
amicalement
PS:Pourrais-tu me donner le script de ton php.ini au niveau de "extension" STP je vais le rentrer sur mon php.ini auquel j'ai accés pour voir si cela fonctionne.
Je suppose que cela commence par
[extensions]
....

Dernière modification par zoom (2009-02-28 18:08:35)


Bien cordialement, Zoomy
Version Piwigo:2.8.1
Hébergeur O2switch; PHP: 5.6.20; MySQL: 5.6.29-76.2
url: http://zoomyphoto.fr

Hors ligne

#4 2009-03-01 01:14:59

Eric
Équipe Piwigo
VALENCE (FR)
2005-03-25
4579

Re: Encore un problème d'exifs

zoom a écrit:

Comment je peux accéder à /usr/local/apache/libexec. ?

Là, désolé mais aucune idée. Il s'agit d'un chemin linux et moi, je bosse sous Windows. Donc rien à voir et je ne connais que très (trop) peu Linux pour t'aider sur ce point.

zoom a écrit:

PS:Pourrais-tu me donner le script de ton php.ini au niveau de "extension" STP je vais le rentrer sur mon php.ini auquel j'ai accés pour voir si cela fonctionne.
Je suppose que cela commence par
[extensions]

C'est bien ainsi que commence "normalement" la section des extensions de php.ini. Ensuite, il suffit d'ajouter ceci :

Code:

extension=php_exif.dll

Mais il faut que le fichier php_exif.dll soit présent dans /usr/local/apache/libexec et redémarrer les services associés (apache et php) pour que cela fonctionne. Te donner la totalité de ma config php ne te servirait à rien puisque je n'utilise pas la même configuration que toi.

Hors ligne

#5 2009-03-01 19:38:46

loren
Membre
2009-01-26
13

Re: Encore un problème d'exifs

Même problème sur QNAP 109 Pro II.

Hors ligne

#6 2009-03-01 23:30:32

zoom
Membre
2008-02-29
154

Re: Encore un problème d'exifs

loren a écrit:

Même problème sur QNAP 109 Pro II.

Ce qui est surprenant c'est que dans Qmultimedia les exifs des images sont très bien renseignés...
J'ai essayé de modifier le php.ini et pas de résultats.
Il n'y a rien dans le dossier /usr/local/apache/libexec ( vu avec putty).

Je ne sais pas trop comment régler le problème alors j'ai mis le config_local.inc.php dans include.
Dommage...


Bien cordialement, Zoomy
Version Piwigo:2.8.1
Hébergeur O2switch; PHP: 5.6.20; MySQL: 5.6.29-76.2
url: http://zoomyphoto.fr

Hors ligne

#7 2009-03-02 18:13:48

zoom
Membre
2008-02-29
154

Re: Encore un problème d'exifs

loren a écrit:

Même problème sur QNAP 109 Pro II.

http://forum.qnap.com/search.php?keywor … mit=Search
C'est à ne rien y comprendre...je ne dis pas ça pour l'anglais mais pour le fait que le dernier firmware du QNAP rend l'exif opérationnel.
Donc il va falloir essayer.
Mon ami Vincent alias VDigital, pourrais-tu nous éclairer STP ?
Comment je peux vérifier sur Piwigo si l'exif est pris en compte?
Je suppose que pour tester il faut que je vire le fichier /include/config_local.inc.php que j'ai créé mais aprés?
Merci à vous tous.
Cordialement
zoom


Bien cordialement, Zoomy
Version Piwigo:2.8.1
Hébergeur O2switch; PHP: 5.6.20; MySQL: 5.6.29-76.2
url: http://zoomyphoto.fr

Hors ligne

#8 2009-03-03 00:05:53

zoom
Membre
2008-02-29
154

Re: Encore un problème d'exifs

Je crains que la lumière de nos teams ne soit pas là ce soir...


Bien cordialement, Zoomy
Version Piwigo:2.8.1
Hébergeur O2switch; PHP: 5.6.20; MySQL: 5.6.29-76.2
url: http://zoomyphoto.fr

Hors ligne

#9 2009-03-03 07:50:39

ddtddt
Équipe Piwigo
Quetigny (21) - France
2007-07-27
14593

Re: Encore un problème d'exifs

zoom a écrit:

Je suppose que pour tester il faut que je vire le fichier /include/config_local.inc.php que j'ai créé mais aprés?
Merci à vous tous.
Cordialement
zoom

Le mieux c'est d'essayer (tu gardes un sauvegarde de ton fichier)

Tu fait une syncro qui va bien et tu observes ;-)


Vous aimez Piwigo alors n'hésitez pas à participer avec nous, plus d'infos sur la page "Contribuer à Piwigo". Si vous n'avez pas beaucoup de temps et que vous souhaitez nous soutenir vous pouvez aussi le faire par un don.

Hors ligne

Pied de page des forums

Propulsé par FluxBB

github twitter facebook newsletter Faire un don Piwigo.org © 2002-2019 · Contact