Annonce

  •  » Utilisation
  •  » [Résolu] Connection admin impossible

#1 2022-06-19 17:04:46

diaph
Membre
Provence
2017-03-19
67

[Résolu] Connection admin impossible

Bonjour/Bonsoir,

Impossible de me connecter à mon administration : j'ai tenté de renouveller mon mot de passe : je clique sur le lien de renouvellement et je reçois un message d'erreur : Code d’erreur : SSL_ERROR_RX_RECORD_TOO_LONG

Voici le lien que j'ai reçu : https://leysar.eu:80/password.php?key=............. (Je précise que je suis en SSL)

Mon hébergeur LWS me dit qu'il faut revoir le code de la page qui syntaxe le lien car le port 80 ne devrai pas figurer.

Avez vous une idée ?

Merci d'avance

Version de Piwigo: la dernière ou pas loin !
Version de PHP: 7.3
Version de MySQL:
URL Piwigo: http://leysar.eu

Dernière modification par diaph (2022-06-19 17:08:55)


Piwigo 12.2.0
PHP: 7.4.30 - Hébergement : LWS - Mutualisé Linux
MySQL: 5.5.5-10.3.34-MariaDB-0+deb10u1
Bibliothèque graphique: ImageMagick 6.9.11-60

Hors ligne

#2 2022-06-19 18:08:29

ddtddt
Équipe Piwigo
Quetigny (21) - France
2007-07-27
16208

Re: [Résolu] Connection admin impossible

Bonjour

Change le mot de passe dans la base de données ?


Vous aimez Piwigo alors n'hésitez pas à participer avec nous, plus d'infos sur la page "Contribuer à Piwigo". Si vous n'avez pas beaucoup de temps et que vous souhaitez nous soutenir vous pouvez aussi le faire par un don.

Hors ligne

#3 2022-06-19 18:31:08

polowigo
Membre
2019-04-11
129

Re: [Résolu] Connection admin impossible

Bonsoir,

L'idée est de suivre les conseils de ton hébergeur en utilisant un lien formé ainsi : https://leysar.eu/password.php?key=.............
avec la clé que tu as reçu.

Effectivement, la présence du port est curieuse.

Bonne chance.

Hors ligne

#4 2022-06-20 16:12:17

diaph
Membre
Provence
2017-03-19
67

Re: [Résolu] Connection admin impossible

Merci pour vos réponses.

ddtddt a écrit:

Change le mot de passe dans la base de données ?

Je suis SUR de mon mot de passe: je l'ai changé récemment je me suis déjà connecté plusieurs fois avec...


polowigo a écrit:

L'idée est de suivre les conseils de ton hébergeur en utilisant un lien formé ainsi : https://leysar.eu/password.php?key=.............
avec la clé que tu as reçu.

Le lien affiche "Clef invalide".

Je vais essayer en supprimant mon certificat SSL payant et le remplacer provisoirement par un Let's Encrypt... Pour voir ! Je vous tiens au courant !

Dernière modification par diaph (2022-06-20 16:33:34)


Piwigo 12.2.0
PHP: 7.4.30 - Hébergement : LWS - Mutualisé Linux
MySQL: 5.5.5-10.3.34-MariaDB-0+deb10u1
Bibliothèque graphique: ImageMagick 6.9.11-60

Hors ligne

#5 2022-06-20 16:53:02

diaph
Membre
Provence
2017-03-19
67

Re: [Résolu] Connection admin impossible

Voilà, j'ai supprimer mon certificat SSL payant et remplacé par un Let's Encrypt.
Le résultat est le même.
je suis donc revenu à mon certificat payant...

J'ai été sur ma base de donnée : le mot de passe est chiffré ! Je ne vois pas comment le changer en clair...


Piwigo 12.2.0
PHP: 7.4.30 - Hébergement : LWS - Mutualisé Linux
MySQL: 5.5.5-10.3.34-MariaDB-0+deb10u1
Bibliothèque graphique: ImageMagick 6.9.11-60

Hors ligne

#6 2022-06-20 17:02:15

dreamer
Membre
St Cyr/mer (83)
2006-02-26
902

Re: [Résolu] Connection admin impossible

Salut

J'ai eu ce problème du :80 sur tous mes albums à cause du certificat SSL, j'ai du modifier un fichier pour que cela fonctionne /*****/include/functions_url.inc.php à la ligne 57

Tuas normalement ceci

Code:

$url .= $_SERVER['HTTP_HOST'];

if ( (!$is_https && $_SERVER['SERVER_PORT'] != 80)

||($is_https && $_SERVER['SERVER_PORT'] != 443))

{

$url_port = ':'.$_SERVER['SERVER_PORT'];

if (strrchr($url, ':') != $url_port)

{

$url .= $url_port;

}

}

Tu remplaces par cela

Code:

if ( (!$is_https && $_SERVER['SERVER_PORT'] != 80)

||($is_https && $_SERVER['SERVER_PORT'] != 443))

{

$url_port = ':443';

if (strrchr($url, ':') != $url_port)

{

$url .= ':443';

}

}

Bon, cela a marché pour moi, à toi d'essayer

A+


beauxvoyages.fr/photos (photos), beauxvoyages.fr/jukebox (musiques) et tout nouveau beauxvoyages.fr/camping (camping-car) le tout en version 12.2

Hors ligne

#7 2022-06-20 17:08:15

polowigo
Membre
2019-04-11
129

Re: [Résolu] Connection admin impossible

Et sinon

diaph a écrit:

polowigo a écrit:

L'idée est de suivre les conseils de ton hébergeur en utilisant un lien formé ainsi : https://leysar.eu/password.php?key=.............
avec la clé que tu as reçu.

Le lien affiche "Clef invalide".

Il est probable que la clé ait expiré.
Refais la demande de renouvellement de mot de passe pour obtenir une nouvelle clé.
Et n'oublie pas ensuite de supprimer le port dans le lien pour continuer la procédure.

Hors ligne

#8 2022-06-20 20:03:41

diaph
Membre
Provence
2017-03-19
67

Re: [Résolu] Connection admin impossible

polowigo a écrit:

Il est probable que la clé ait expiré..

La clé n'était pas expirée : je venais de la demander...

Un GRAND MERCI à dreamer, ta solution est la bonne : ça marche aussi pour moi !
Donc cela vient bien du code comme la suggéré LWS.

Bonne soirée à tous et encore merci de votre participation.


Piwigo 12.2.0
PHP: 7.4.30 - Hébergement : LWS - Mutualisé Linux
MySQL: 5.5.5-10.3.34-MariaDB-0+deb10u1
Bibliothèque graphique: ImageMagick 6.9.11-60

Hors ligne

#9 2022-06-21 07:20:06

ddtddt
Équipe Piwigo
Quetigny (21) - France
2007-07-27
16208

Re: [Résolu] Connection admin impossible

diaph a écrit:

polowigo a écrit:

Il est probable que la clé ait expiré..

La clé n'était pas expirée : je venais de la demander...

Un GRAND MERCI à dreamer, ta solution est la bonne : ça marche aussi pour moi !
Donc cela vient bien du code comme la suggéré LWS.

Bonne soirée à tous et encore merci de votre participation.

Bonjour

ou un réglage exotique de leurs serveurs qui ne réagient pas comme attendu ...


Vous aimez Piwigo alors n'hésitez pas à participer avec nous, plus d'infos sur la page "Contribuer à Piwigo". Si vous n'avez pas beaucoup de temps et que vous souhaitez nous soutenir vous pouvez aussi le faire par un don.

Hors ligne

  •  » Utilisation
  •  » [Résolu] Connection admin impossible

Pied de page des forums

Propulsé par FluxBB

github twitter newsletter Faire un don Piwigo.org © 2002-2022 · Contact