Annonce

  •  » Utilisation
  •  » bug dans l'expédition de courrier?

#1 2013-10-31 09:51:43

jdd
Membre
Toulouse
2009-12-20
387

bug dans l'expédition de courrier?

en voulant envoyer un courrier à un (gros) groupe d'utilisateurs, je recois bien le courrier, mais vide et avec ça dans le source voir plus bas).

ma gallerie est là:
http://dodin.info/piwigo/index.php

merci de vos conseils
jdd


Code:

Return-Path: <wwwrun@nemo.dodin.info>
X-Original-To: c1d2009@dodin.org
Delivered-To: c1d2009@dodin.org
Received: from nemo.dodin.info (dodin.info [188.165.211.22])
  by dodin.org (Postfix) with ESMTP id C61363051
  for <c1d2009@dodin.org>; Thu, 31 Oct 2013 09:40:30 +0100 (CET)
Received: by nemo.dodin.info (Postfix, from userid 30)
  id 5EE6E986D; Thu, 31 Oct 2013 09:49:24 +0100 (CET)
To: 
Subject: [Galerie de Jean-Daniel Dodin (jdd)] Venez visiter l'album Videos-autres-auteurs
X-PHP-Originating-Script: 30:functions_mail.inc.php
From: "Galerie de Jean-Daniel Dodin (jdd)" <jdd@dodin.org>
Reply-To: "Galerie de Jean-Daniel Dodin (jdd)" <jdd@dodin.org>
Content-Type: multipart/alternative;
  boundary="---=xu7DIeZ3wTq86Giqds4AQTP35Tv6Z99Z";
  reply-type=original
MIME-Version: 1.0
X-Mailer: Piwigo Mailer
Message-Id: <20131031084924.5EE6E986D@nemo.dodin.info>
Date: Thu, 31 Oct 2013 09:49:24 +0100 (CET)


Warning: Smarty error: unable to read resource: "header.tpl" in /home/data/srv/www/htdocs/piwigo/include/smarty/libs/Smarty.class.php on line 1093

Warning: Smarty error: unable to read resource: "cat_group_info.tpl" in /home/data/srv/www/htdocs/piwigo/include/smarty/libs/Smarty.class.php on line 1093

Warning: Smarty error: unable to read resource: "footer.tpl" in /home/data/srv/www/htdocs/piwigo/include/smarty/libs/Smarty.class.php on line 1093

-----=xu7DIeZ3wTq86Giqds4AQTP35Tv6Z99Z--

Warning: Smarty error: unable to read resource: "header.tpl" in /home/data/srv/www/htdocs/piwigo/include/smarty/libs/Smarty.class.php on line 1093

Warning: Smarty error: unable to read resource: "cat_group_info.tpl" in /home/data/srv/www/htdocs/piwigo/include/smarty/libs/Smarty.class.php on line 1093

Warning: Smarty error: unable to read resource: "footer.tpl" in /home/data/srv/www/htdocs/piwigo/include/smarty/libs/Smarty.class.php on line 1093

-----=xu7DIeZ3wTq86Giqds4AQTP35Tv6Z99Z--

Dernière modification par jdd (2013-10-31 09:52:03)

Hors ligne

#2 2013-10-31 11:50:16

flop25
Équipe Piwigo
2006-07-06
6544

Re: bug dans l'expédition de courrier?

Bonjour
quel thème utilisez vous
Comme indiqué, il ya un problème de lecture des fichiers cités: soit un problème d'existence soit de permission

Hors ligne

#3 2013-10-31 12:19:17

jdd
Membre
Toulouse
2009-12-20
387

Re: bug dans l'expédition de courrier?

flop25 a écrit:

Bonjour
quel thème utilisez vous
Comme indiqué, il ya un problème de lecture des fichiers cités: soit un problème d'existence soit de permission

par défaut "clear", mais il y en a d'autres (selon les utilisateurs)

et je me doute bien qu'il y a un problème avec les fichiers, mais la ligne 1093 d'où vient l'erreur est

Code:

trigger_error("Smarty error: $error_msg", $error_type);

pas très parlant :-(

en fait je ne trouve de "header.tpl" que dans la template "default" (ou smart pocket), mais comment l'activer (il n'est pas dans la liste des templates de la config?)

merci
jdd

Hors ligne

#4 2013-10-31 13:20:50

flop25
Équipe Piwigo
2006-07-06
6544

Hors ligne

#5 2013-10-31 15:01:44

jdd
Membre
Toulouse
2009-12-20
387

Re: bug dans l'expédition de courrier?

oui, tout à fait, uniquement dans themes/default.... (rien dans clear)

oui, et c'est  lisible

Code:

ls -l html
total 24
-rw-r--r-- 1 root root  247 25 juin  13:00 cat_group_info.tpl
-rw-r--r-- 1 root root  602 25 juin  13:00 footer.tpl
-rw-r--r-- 1 root root  762 25 juin  13:00 global-mail-css.tpl
-rw-r--r-- 1 root root  608 25 juin  13:00 header.tpl
-rw-r--r-- 1 root root 1765 25 juin  13:00 index.php
-rw-r--r-- 1 root root 2063 25 juin  13:00 notification_by_mail.tpl

merci
jdd

Hors ligne

#6 2013-10-31 15:07:02

flop25
Équipe Piwigo
2006-07-06
6544

Re: bug dans l'expédition de courrier?

Est ce que root est aussi le propriétaire des tpl de  http://piwigo.org/dev/browser/branches/ … t/template ?

Hors ligne

#7 2013-10-31 15:10:07

jdd
Membre
Toulouse
2009-12-20
387

Re: bug dans l'expédition de courrier?

flop25 a écrit:

Est ce que root est aussi le propriétaire des tpl de  http://piwigo.org/dev/browser/branches/ … t/template ?

oui, tous les fichiers ont les mêmes permissions, avec execute en plus pour les répertoires.

merci
jdd

Hors ligne

#8 2013-10-31 15:13:09

flop25
Équipe Piwigo
2006-07-06
6544

Re: bug dans l'expédition de courrier?

Hmm.......
vous pouvez toujours réuploader tous els fichiers de votre version de Piwigo, ça ne fera pas de mal... mais bon je doute que ça chanegra quoique ce soit
J'avoue sécher

Hors ligne

#9 2013-10-31 15:20:54

jdd
Membre
Toulouse
2009-12-20
387

Re: bug dans l'expédition de courrier?

flop25 a écrit:

Hmm.......
vous pouvez toujours réuploader tous els fichiers de votre version de Piwigo, ça ne fera pas de mal... mais bon je doute que ça chanegra quoique ce soit
J'avoue sécher

je viens juste de faire la dernière mise à jour, mais je n'avais jamais utilisé cette fonction... elle marche chez vous?

Piwigo 2.5.3

j'ai toujours eu des problèmes de permissions, parce que je me connecte par ssh/fish (avec Dolphin/Kde) le plus souvent - ca fonctionne à la base comme ftp

http://dodin.info/wiki/index.php?n=Phot … DeFichiers

merci
jdd

Dernière modification par jdd (2013-10-31 15:21:24)

Hors ligne

#10 2013-10-31 15:25:32

flop25
Équipe Piwigo
2006-07-06
6544

Re: bug dans l'expédition de courrier?

"cette fonction"? l'upload par ftp/sftp ? oui ça marche ^^
Par contre vu que vous avez les fichiers appartenant à root, je pense qu'il vaudrait mieux vous connecter sous sftp en root. Mais j'ose espérer que Apache ou le erveur web ne tourne pas avec des droits root?

Hors ligne

#11 2013-10-31 15:25:52

jdd
Membre
Toulouse
2009-12-20
387

Re: bug dans l'expédition de courrier?

il y a les mêmes permissions dans le fichier zip que je viens de télécharger (pas le même propriétaire, évidemment) - il n'attends pas un exécute?

Code:

ls -l
total 24
-rw-r--r-- 1 jdd users  247 28 sept.  2010 cat_group_info.tpl
-rw-r--r-- 1 jdd users  602 23 mars   2010 footer.tpl
-rw-r--r-- 1 jdd users  762  7 avril  2010 global-mail-css.tpl
-rw-r--r-- 1 jdd users  608 13 mars   2010 header.tpl
-rw-r--r-- 1 jdd users 1765  1 janv.  2013 index.php
-rw-r--r-- 1 jdd users 2063 17 janv.  2011 notification_by_mail.tpl

Hors ligne

#12 2013-10-31 15:47:19

jdd
Membre
Toulouse
2009-12-20
387

Re: bug dans l'expédition de courrier?

flop25 a écrit:

"cette fonction"? l'upload par ftp/sftp ? oui ça marche ^^
Par contre vu que vous avez les fichiers appartenant à root, je pense qu'il vaudrait mieux vous connecter sous sftp en root. Mais j'ose espérer que Apache ou le serveur web ne tourne pas avec des droits root?

je me connecte en root pour les copies, et je ne passe pas par Apache :-)

meci
jddd

Hors ligne

#13 2013-10-31 15:48:30

jdd
Membre
Toulouse
2009-12-20
387

Re: bug dans l'expédition de courrier?

flop25 a écrit:

"cette fonction"? l'upload par ftp/sftp ? oui ça marche ^^

non, le mail... celle qui bogue chez moi :-)

jdd

Hors ligne

#14 2013-10-31 15:48:45

flop25
Équipe Piwigo
2006-07-06
6544

Re: bug dans l'expédition de courrier?

Ma remarque était dissocié de l'utilisation de commande par ssh, ou d'envoir par sftp/ftp : elle portait sur le processus d'apache en lui-même

Dernière modification par flop25 (2013-10-31 15:49:00)

Hors ligne

#15 2013-10-31 15:53:25

flop25
Équipe Piwigo
2006-07-06
6544

Re: bug dans l'expédition de courrier?

L'envoi de mails marche parfaitement chez moi ^^ Oui Et sans rien chercher à paramétrer dans Piwigo

Dernière modification par flop25 (2013-10-31 15:54:01)

Hors ligne

  •  » Utilisation
  •  » bug dans l'expédition de courrier?

Pied de page des forums

Propulsé par FluxBB

github twitter newsletter Faire un don Piwigo.org © 2002-2022 · Contact