•  » Installation
  •  » [Résolu] Upgrade impossible suite migration 2.4.7 vers 2.5.0

#1 2013-03-05 16:02:59

Nicosss
Invité

[Résolu] Upgrade impossible suite migration 2.4.7 vers 2.5.0

Bonjour,

Suite à la migration manuelle de la version 2.4.7 vers 2.5.0 le mot de passe admin pour faire l'upgrade est donné comme incorrect. J'ai vérifié dans la base SQL il n'y a pas de problème de mot de passe. Un retour en 2.4.7 s'est imposé et ne pose pas de problème pour la connexion en admin.

Pour information j'ai opéré la mise à jour en automatique sur un serveur perso (2.4.7 vers 2.5.0) et il n'y a pas eu de problème. Je ne peux pas procéder de la même manière sur ce site car il est encore hébergé chez Free.

La différence notable entre ces 2 installations est dans la structure de la base de donnée.
Sur Free elle est à base de phpwebgallery_ et sur mon serveur à base de piwigo_ mais il n'y a pas de raison.

Avez-vous une piste ou ce bug a-t-il déjà été rapporté ?

Merci

#2 2013-03-05 17:41:21

plg
Équipe Piwigo
Nantes, France, Europe
2002-04-05
12345

Re: [Résolu] Upgrade impossible suite migration 2.4.7 vers 2.5.0

Bonjour Nicosss,

As-tu une configuration locale ? (si oui, que contient-elle ?)


Dernier billet du blog Piwigo.com (20 juin 2019) Modus, nouveau thème par défaut sur Piwigo.com

Hors ligne

#3 2013-03-05 19:19:27

Nicosss
Invité

Re: [Résolu] Upgrade impossible suite migration 2.4.7 vers 2.5.0

Bonsoir plg,

Je ne suis pas sûr de savoir ce que tu appelles configuration locale. S'il s'agit de ../local il contient :
un répertoire combined, config, css, Gthumb et language ainsi qu'un fichier index.php

En l’occurrence ../local/config contient les fichiers config.inc.php, database.inc.php et index.php

Contenu de ../local/config/config.inc.php

Code:

<?php
$conf['gallery_url'] = 'http://<nomdedomaine>.free.fr';
$conf['template_combine_files'] = false;
?>

Contenu de ../local/config/database.inc.php

Code:

<?php
$conf['dblayer'] = 'mysql';
$conf['db_base'] = '<db_name>';
$conf['db_user'] = '<db_user>';
$conf['db_password'] = '<db_password>';
$conf['db_host'] = 'sql.free.fr';

$prefixeTable = 'phpwebgallery_';

define('PHPWG_INSTALLED', true);
define('PWG_CHARSET', 'utf-8');
define('DB_CHARSET', 'utf8');
define('DB_COLLATE', '');
?>

En espérant avoir répondu à ta question.

#4 2013-03-06 10:17:47

plg
Équipe Piwigo
Nantes, France, Europe
2002-04-05
12345

Re: [Résolu] Upgrade impossible suite migration 2.4.7 vers 2.5.0

OK, le problème est maintenant connu [Bugtracker, ticket 2861, fixed] invalid password on manual upgrade et je l'ai corrigé. Je n'ai pas publié la 2.5.1 par contre j'ai modifié la 2.5.0, exceptionnellement en "procédure d'urgence". Je n'ai modifié que le fichier include/functions_user.inc.php donc tu peux télécharger à nouveau piwigo-2.5.0.zip et ne transférer sur ton site que ce fichier PHP.


Dernier billet du blog Piwigo.com (20 juin 2019) Modus, nouveau thème par défaut sur Piwigo.com

Hors ligne

#5 2013-03-06 11:49:07

Nicosss
Invité

Re: [Résolu] Upgrade impossible suite migration 2.4.7 vers 2.5.0

Je te confirme que ton patch fonctionne. J'espère que ça ne t'a pas gâché la nuit. L'upgrade a été très rapide pour ma part.

J'ai juste aperçu des messages d'erreur après la première identification suite à l'upgrade mais j'ai été redirigé automatiquement pour m'identifier à nouveau et là aucun problème (pour info la galerie était verrouillée à ce moment là).

Merci pour ton travail et continue tes conférences quand tu peux, c'est toujours très intéressant.

Je regarderais ta modif pour ma culture personnelle.

Bonne continuation !

PS : Merci de passer le sujet en Résolu, en tant qu'invité je pense que je ne peux pas.

#6 2013-03-06 11:55:37

plg
Équipe Piwigo
Nantes, France, Europe
2002-04-05
12345

Re: [Résolu] Upgrade impossible suite migration 2.4.7 vers 2.5.0

Nicosss a écrit:

Je te confirme que ton patch fonctionne. J'espère que ça ne t'a pas gâché la nuit.

J'ai très bien dormi merci :-) C'est surtout une notification ce matin de la part de l'équipe Softaculous (qui intègre Piwigo dans leur installeur de scripts PHP) qui m'a mis la puce à l'oreille : de leur côté, cela ne peut pas être un problème de transfert FTP.

En faisant une tentative d'upgrade manuel sur une session admin expirée, j'ai tout de suite reproduit le bug et le bug n'était pas très compliqué à comprendre.

Nicosss a écrit:

Merci pour ton travail et continue tes conférences quand tu peux, c'est toujours très intéressant.

Il va y en avoir une à Lyon prochainement (mais pas par moi, quand ce sera plus précis, on le dira sur le forum) Je vais contacter Parinux pour une conf sur Paris prochainement.

Nicosss a écrit:

PS : Merci de passer le sujet en Résolu, en tant qu'invité je pense que je ne peux pas.

C'est fait.


Dernier billet du blog Piwigo.com (20 juin 2019) Modus, nouveau thème par défaut sur Piwigo.com

Hors ligne

#7 2013-03-10 10:19:25

Manu
Invité

Re: [Résolu] Upgrade impossible suite migration 2.4.7 vers 2.5.0

Hello,

J'ai fait également la mise à jour manuelle, et ne peut plus m'authentifier à ma gallerie.

J'ai donc écrasé le fichier include/functions_user.inc.php (j'ai même supprimé l'original avant de recopier le fichier) et pourtant pas mieux ... j'ai droit au mot de passe invalide, et ce même après reset du mot de passe.

Ma gallerie est hébérgée chez free.fr je ne sais pas si ça change quelque chose, et je n'ai rien modifié depuis la version précédente qui fonctionnait parfaitement.

A noter que c'est le même problème avec tous les comptes à priori pas uniquement le compte admin

#8 2013-03-11 14:08:31

laspirale04
Invité

Re: [Résolu] Upgrade impossible suite migration 2.4.7 vers 2.5.0

Salut à tous et merci pour votre travail, j'ai le même problème que Manu lors de la migration manuelle chez free, mot de passe invalide. Merci

#9 2013-03-11 15:04:24

laspirale04
Invité

Re: [Résolu] Upgrade impossible suite migration 2.4.7 vers 2.5.0

laspirale04 a écrit:

Salut à tous et merci pour votre travail, j'ai le même problème que Manu lors de la migration manuelle chez free, mot de passe invalide. Merci

Edit: Rectification, cela fonctionne bien sur 2 de mes sites, donc cela doit venir de moi, je vais chercher, merci.

#10 2013-03-13 19:44:57

manuel.flury
Membre
2005-09-30
33

Re: [Résolu] Upgrade impossible suite migration 2.4.7 vers 2.5.0

Ouais ben j'ai toujours le même problème, j'ai furtivement vu des messages d'erreur php, mais je n'ai pas le temps de les lire/noter et n'ai pas trouvé dans les options de debug comment stocker dans un fichier/db ces erreurs.

Pas eu trop le temps de creuser non plus, mais si quelqu'un a un tuyau je prends, merci  ^^

Hors ligne

#11 2013-03-13 20:11:22

flop25
Équipe Piwigo
2006-07-06
6475

Re: [Résolu] Upgrade impossible suite migration 2.4.7 vers 2.5.0

normalement un fichier error_log se crée : à checker par ftp

Hors ligne

#12 2013-03-13 21:20:15

manuel.flury
Membre
2005-09-30
33

Re: [Résolu] Upgrade impossible suite migration 2.4.7 vers 2.5.0

Merci pour l'info, mais je ne l'ai pas trouvé.

Est-ce que je peux mettre à jour une table pour désactiver les plugins ?

.. en même temps free.fr a des soucis en ce moment, mais bon aucun rapport :

[mysql error 2013] Lost connection to MySQL server at 'reading initial communication packet', system error: 113
Can't connect to server

Hors ligne

  •  » Installation
  •  » [Résolu] Upgrade impossible suite migration 2.4.7 vers 2.5.0

Pied de page des forums

Propulsé par FluxBB

github twitter facebook newsletter Faire un don Piwigo.org © 2002-2019 · Contact