Annonce

  •  » Outils
  •  » [Résolu] Erreurs sur permissions albums

#1 2012-01-02 08:30:18

sbastien7566
Membre
2012-01-02
24

[Résolu] Erreurs sur permissions albums

Bonjour,
Je commence à utiliser Piwigo et j'ai un problème lorsque je souhaite gérer les permissions des albums :


Notice: Undefined index: 0 in /homepages/40/d314154761/htdocs/piwigo/admin/include/functions.php on line 2143

Notice: Undefined index: 0 in /homepages/40/d314154761/htdocs/piwigo/admin/include/functions.php on line 2143

Warning: Cannot modify header information - headers already sent by (output started at /homepages/40/d314154761/htdocs/piwigo/admin/include/functions.php:2143) in /homepages/40/d314154761/htdocs/piwigo/include/page_header.php on line 103






Si je continue, et que je valide un  modification, voici ce qui apparait :


Notice: Undefined index: grant_users in /homepages/40/d314154761/htdocs/piwigo/admin/cat_perm.php on line 153


Warning:  [mysql error 1064] You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near ')' at line 6

SELECT
    user_id,
    cat_id
  FROM piwigo_user_access
  WHERE cat_id IN (1,2,4,5,6,7,8,9,10,11,12,13,14)
    AND user_id IN ()
; in /homepages/40/d314154761/htdocs/piwigo/include/dblayer/functions_mysql.inc.php on line 767


Warning: mysql_fetch_assoc(): supplied argument is not a valid MySQL result resource in /homepages/40/d314154761/htdocs/piwigo/include/dblayer/functions_mysql.inc.php on line 153


Warning:  [mysql error 1062] Duplicate entry '0-1' for key 1

INSERT  INTO piwigo_user_access
  (user_id,cat_id)
  VALUES(NULL,'1')
  , (NULL,'2')
  , (NULL,'4')
  , (NULL,'5')
  , (NULL,'6')
  , (NULL,'7')
  , (NULL,'8')
  , (NULL,'9')
  , (NULL,'10')
  , (NULL,'11')
  , (NULL,'12')
  , (NULL,'13')
  , (NULL,'14') in /homepages/40/d314154761/htdocs/piwigo/include/dblayer/functions_mysql.inc.php on line 767


Notice: Undefined index: 0 in /homepages/40/d314154761/htdocs/piwigo/admin/include/functions.php on line 2143

Notice: Undefined index: 0 in /homepages/40/d314154761/htdocs/piwigo/admin/include/functions.php on line 2143

Warning: Cannot modify header information - headers already sent by (output started at /homepages/40/d314154761/htdocs/piwigo/admin/cat_perm.php:153) in /homepages/40/d314154761/htdocs/piwigo/include/page_header.php on line 103




Je suis donc obligé de gérer les permissions de chaque sous album, ce qui est très long…
D'autre part, est-il possible que chaque nouveau sous-album bénéficie par défaut et automatiquement des permissions de l'album parent?


Merci pour votre aide,
Sébastien

Hors ligne

#2 2012-01-02 10:29:28

flop25
Équipe Piwigo
2006-07-06
6544

Re: [Résolu] Erreurs sur permissions albums

Bonjour vous avez quelle version de piwigo ?

Hors ligne

#3 2012-01-02 10:34:36

sbastien7566
Membre
2012-01-02
24

Re: [Résolu] Erreurs sur permissions albums

La version 2.3.2

Hors ligne

#4 2012-01-02 10:43:15

flop25
Équipe Piwigo
2006-07-06
6544

Re: [Résolu] Erreurs sur permissions albums

avez-vous bien : http://fr.piwigo.org/releases/2.3.0#per … sub_albums ?
pour partir sur une bonne base, je vous propose de réenvoyer par ftp Piwigo 2.3.2

Hors ligne

#5 2012-01-02 12:43:18

sbastien7566
Membre
2012-01-02
24

Re: [Résolu] Erreurs sur permissions albums

Je vous joins une copie d'écran de la fenêtre concernant le dossier parent.

Que vont devenir les photos et albums si je renvois Piwigo par ftp?

Merci
Sébastien

Dernière modification par sbastien7566 (2012-01-02 12:43:45)

Hors ligne

#6 2012-01-02 12:53:12

flop25
Équipe Piwigo
2006-07-06
6544

Re: [Résolu] Erreurs sur permissions albums

sbastien7566 a écrit:

Je vous joins une copie d'écran de la fenêtre concernant le dossier parent.

Que vont devenir les photos et albums si je renvois Piwigo par ftp?

Merci
Sébastien

vous avez un utilisateur fantôme ! Vous voyez les 2 cases à cocher l'une à coté de l'autre avant administrateur ? c’est ça à mon avis
allez donc le supprimer

Hors ligne

#7 2012-01-02 12:58:19

sbastien7566
Membre
2012-01-02
24

Re: [Résolu] Erreurs sur permissions albums

Oui j'avais bien remarqué mais je pensais que ça faisait partie du bug.
Je vous envoie une copie d'écran des utilisateurs, je ne crois pas qu'il y ait un fantôme, ils sont tous nommés à priori.

Hors ligne

#8 2012-01-02 13:02:49

Gotcha
Equipe Piwigo
Pierrelatte (26)
2007-03-14
13331

Re: [Résolu] Erreurs sur permissions albums

Alors il va falloir jouer avec Firebug pour trouver l'origine de cette case à cocher.
Si vous ne voyez pas de quoi je veux parler, pas d'affolement, il vous suffira de m'envoyer un courriel avec l'adresse de votre galerie et un compte webmaster associé pour m'y connecter ;-)

[EDIT]
On peut aussi trouver l'ID associé via Internet Explorer et la touche F12


Ayez comme premier réflexe de consulter le wiki.
Ensuite, veuillez effectuer une recherche sur le forum avant de poser votre question.

LE FAIRE EST LE REVELATEUR DE L'ETRE

Hors ligne

#9 2012-01-02 13:02:55

flop25
Équipe Piwigo
2006-07-06
6544

Re: [Résolu] Erreurs sur permissions albums

sbastien7566 a écrit:

Oui j'avais bien remarqué mais je pensais que ça faisait partie du bug.
Je vous envoie une copie d'écran des utilisateurs, je ne crois pas qu'il y ait un fantôme, ils sont tous nommés à priori.

faites aussi ce que dit Gotcha
puis allez voir dans la base de donnée, la table piwigo_users (via phpmyadmin) : y a-t-il qqchose d'anormal ?

Dernière modification par flop25 (2012-01-02 13:04:32)

Hors ligne

#10 2012-01-02 13:06:47

sbastien7566
Membre
2012-01-02
24

Re: [Résolu] Erreurs sur permissions albums

Et voici

Je n'avais pas vu Gotcha, je m'en occupe

Dernière modification par sbastien7566 (2012-01-02 13:14:57)

Hors ligne

#11 2012-01-02 13:10:42

flop25
Équipe Piwigo
2006-07-06
6544

Re: [Résolu] Erreurs sur permissions albums

sbastien7566 a écrit:

Et voici

Je n'avais pas vu Gotcha, je m'en occupe

heu on est pas obligé de voir les emails .... enfin c'est pour eux ! Donc pas d'utilisateur suplémentaire, mais toujours un fantôme !
sinon avec l'id obtenu par la méthode Gotcha (^^) allez dans la table piwigo_user_access et voyez si dans la colonne id, il n'y aurait une valeur avec cet id précédemment obtenu (j'espère être clair)

Dernière modification par flop25 (2012-01-02 13:11:12)

Hors ligne

#12 2012-01-02 13:15:40

sbastien7566
Membre
2012-01-02
24

Re: [Résolu] Erreurs sur permissions albums

J'ai envoyé un email à gotcha, c'est mieux comme ça je crois!!!

Hors ligne

#13 2012-01-02 13:48:56

plg
Équipe Piwigo
Nantes, France, Europe
2002-04-05
12539

Re: [Résolu] Erreurs sur permissions albums

Je signale que j'ai rencontré le même problème sur une galerie la semaine dernière, sans réussir à comprendre l'origine du problème (je n'arrive pas à reproduire).

Pour corriger, j'ai simplement fait un :

Code:

DELETE FROM piwigo_user_access where user_id is null or user_id=0;

sur la base de données.


Historiquement, premier utilisateur connu de Piwigo ;-)

Hors ligne

#14 2012-01-02 13:55:41

sbastien7566
Membre
2012-01-02
24

Re: [Résolu] Erreurs sur permissions albums

Et je rentre ça où?

Merci!!!

Hors ligne

#15 2012-01-02 15:53:14

flop25
Équipe Piwigo
2006-07-06
6544

Re: [Résolu] Erreurs sur permissions albums

sbastien7566 a écrit:

Et je rentre ça où?

Merci!!!

dans phpmyadmin

@plg : avec 2 utilisateurs on va peut être trouver le dénominateur commun
d'abord quelles extensions ?
avez vous utilisé la fonction appliquer aux sous albums ? ou supprimé/ajouté un utilisateur manuellement ?

Hors ligne

  •  » Outils
  •  » [Résolu] Erreurs sur permissions albums

Pied de page des forums

Propulsé par FluxBB

github twitter newsletter Faire un don Piwigo.org © 2002-2022 · Contact