Annonce

  •  » Plugins
  •  » [plugin] GThumb+

#61 2012-02-17 23:19:58

P@t
Équipe Piwigo
Nice
2007-06-13
5695

Re: [plugin] GThumb+

lbkari a écrit:

Est-il possible de paramétrer le plugin GThumb+ en fonction des albums. J'utilise le plugin NBC theme changer et j'aurai souhaité avoir la possibilité d'utiliser GThumb+ en fonction des thèmes choisis.
Je n'ai vu aucune possibilités dans ce sens. Si j'ai bon est-ce une évolution envisagée et/ou envisagée ?

Non, désolé, pas dans l'immédiat...


P@t

Hors ligne

#62 2012-02-18 22:37:44

lbkari
Membre
2011-08-28
19

Re: [plugin] GThumb+

Tant pis je continuerai à l'utiliser quand même. Ce sera pour tous les albums, cela donne une présentation vraiment sympa.

Merci pour la réponse

lbkari

Hors ligne

#63 2012-02-19 14:41:31

arno
Membre
2011-01-14
64

Re: [plugin] GThumb+

Hello,

merci pour ce plugin, le rendu est somptueux !

petite question, j'ai une miniature qui n'a visiblement pas été rendue,
avec une image cassée dans le listing des images, et un message en haut de page :
Notice: getimagesize(): Read error! in /var/www/clients/client1/web7/web/plugins/GThumb/main.inc.php on line 157
(je laisse volontairement les warning sur mon php),
ce qui casse accessoirement le rendu de toute la page,

URL : http://piwigo.cumulodata.com/index.php?/category/31

du coup, une idée pour la regénérer ?
Est-ce qu'il y a un mécanisme de 'retry' quelconque, ou est ce que GThumb+ considere que la miniature est là une fois qu'il a fait le process ?

merci !

- Arnaud

Hors ligne

#64 2012-02-19 20:31:38

joetap
Membre
2007-10-22
118

Re: [plugin] GThumb+

Bonjour

Dans le panneau de configuration du plugin, les paramètres sont remplacés par des "a". Si j'enregistre d'autres paramètres et que je réouvre cette page les paramètres rebasculent avec des 'a'.
Je suis le seul dans ce cas ?

@+

Dernière modification par joetap (2012-02-19 20:37:04)

Hors ligne

#65 2012-02-19 21:03:56

P@t
Équipe Piwigo
Nice
2007-06-13
5695

Re: [plugin] GThumb+

arno a écrit:

petite question, j'ai une miniature qui n'a visiblement pas été rendue,
avec une image cassée dans le listing des images, et un message en haut de page :
Notice: getimagesize(): Read error! in /var/www/clients/client1/web7/web/plugins/GThumb/main.inc.php on line 157

En effet, le fichier a l'air vide... supprime manuellement le fichier en question et voit si il se régénère correctement:
local/GThumb/200/86e6adf74919126f15db696f103cb9dd.jpg


P@t

Hors ligne

#66 2012-02-19 21:05:20

P@t
Équipe Piwigo
Nice
2007-06-13
5695

Re: [plugin] GThumb+

joetap a écrit:

Dans le panneau de configuration du plugin, les paramètres sont remplacés par des "a". Si j'enregistre d'autres paramètres et que je réouvre cette page les paramètres rebasculent avec des 'a'.
Je suis le seul dans ce cas ?

J'ai déjà rencontré ce problème... c'est une incompatibilité avec un autre plugin (il me semble que c'est Random Header).


P@t

Hors ligne

#67 2012-02-19 21:44:41

joetap
Membre
2007-10-22
118

Re: [plugin] GThumb+

P@t a écrit:

joetap a écrit:

Dans le panneau de configuration du plugin, les paramètres sont remplacés par des "a". Si j'enregistre d'autres paramètres et que je réouvre cette page les paramètres rebasculent avec des 'a'.
Je suis le seul dans ce cas ?

J'ai déjà rencontré ce problème... c'est une incompatibilité avec un autre plugin (il me semble que c'est Random Header).

En effet, je viens de tester en désactivant Random Header et du coup GThumb+ refonctionne correctement.
@ +

Hors ligne

#68 2012-02-20 12:04:56

arno
Membre
2011-01-14
64

Re: [plugin] GThumb+

P@t a écrit:

arno a écrit:

petite question, j'ai une miniature qui n'a visiblement pas été rendue,
avec une image cassée dans le listing des images, et un message en haut de page :
Notice: getimagesize(): Read error! in /var/www/clients/client1/web7/web/plugins/GThumb/main.inc.php on line 157

En effet, le fichier a l'air vide... supprime manuellement le fichier en question et voit si il se régénère correctement:
local/GThumb/200/86e6adf74919126f15db696f103cb9dd.jpg

Je confirme , c'est tout bon !
Merci

on va dire qu'un vent solaire a fait partir un electron dans la mauvaise direction.
Si ca se reproduit je te fais signe.

Suggestion pour une V32: pour rajouter un peu de dynamisme,
on pourrait imaginer rajouter une 2e photo en double taille dans le flux, à mi-hauteur, du coté droit ;)

- Arnaud

Hors ligne

#69 2012-03-03 08:56:30

joetap
Membre
2007-10-22
118

Re: [plugin] GThumb+

P@t a écrit:

joetap a écrit:

Dans le panneau de configuration du plugin, les paramètres sont remplacés par des "a". Si j'enregistre d'autres paramètres et que je réouvre cette page les paramètres rebasculent avec des 'a'.
Je suis le seul dans ce cas ?

J'ai déjà rencontré ce problème... c'est une incompatibilité avec un autre plugin (il me semble que c'est Random Header).

Bonjour
Est-il prévu de rendre compatible les 2 plugins entre eux?

Joetap

Dernière modification par joetap (2012-03-03 09:58:26)

Hors ligne

#70 2012-03-03 11:57:12

P@t
Équipe Piwigo
Nice
2007-06-13
5695

Re: [plugin] GThumb+

joetap a écrit:

Est-il prévu de rendre compatible les 2 plugins entre eux?

Ce n'est pas grand chose à faire, il faut juste que je prenne le temps


P@t

Hors ligne

#71 2012-03-03 14:30:31

Jacques Martin
Invité

Re: [plugin] GThumb+

Bonjour,

j'ai comme une personne plus haut dans ce topic le pb suivant
Warning: Division by zero in /volume1/web/piwigo/admin/include/image.class.php on line 166 ...
j'ai essayé avec GThumb+ comme seul plugin ça ne change rien.

cette erreur ne touche pas l'ensemble de mes répertoires mais seulement certains et pour un répertoire donné est systématique

pour m'aider dans ma recherche, ce plugin redimensionne t'il l'image thumbnail ou l'image taille normale (j'ai aussi chaque image en version high)

et quelles meta va t'il chercher dans l'image à redimensionner ?


log complète :
Warning: Division by zero in /volume1/web/piwigo/admin/include/image.class.php on line 166
Warning: Division by zero in /volume1/web/piwigo/admin/include/image.class.php on line 176
Warning: Division by zero in /volume1/web/piwigo/admin/include/image.class.php on line 182
Warning: Division by zero in /volume1/web/piwigo/admin/include/image.class.php on line 183
Warning: imagecreatetruecolor(): Invalid image dimensions in /volume1/web/piwigo/admin/include/image.class.php on line 547
Warning: imagealphablending() expects parameter 1 to be resource, boolean given in /volume1/web/piwigo/admin/include/image.class.php on line 549
Warning: imagesavealpha() expects parameter 1 to be resource, boolean given in /volume1/web/piwigo/admin/include/image.class.php on line 550
Warning: imageantialias() expects parameter 1 to be resource, boolean given in /volume1/web/piwigo/admin/include/image.class.php on line 553
Warning: imagecopymerge() expects parameter 1 to be resource, boolean given in /volume1/web/piwigo/admin/include/image.class.php on line 556
Warning: imagecreatetruecolor(): Invalid image dimensions in /volume1/web/piwigo/admin/include/image.class.php on line 591
Warning: imagealphablending() expects parameter 1 to be resource, boolean given in /volume1/web/piwigo/admin/include/image.class.php on line 593
Warning: imagesavealpha() expects parameter 1 to be resource, boolean given in /volume1/web/piwigo/admin/include/image.class.php on line 594
Warning: imageantialias() expects parameter 1 to be resource, boolean given in /volume1/web/piwigo/admin/include/image.class.php on line 597
Warning: imagesx() expects parameter 1 to be resource, boolean given in /volume1/web/piwigo/admin/include/image.class.php on line 537
Warning: imagesy() expects parameter 1 to be resource, boolean given in /volume1/web/piwigo/admin/include/image.class.php on line 542
Warning: imagecopyresampled() expects parameter 1 to be resource, boolean given in /volume1/web/piwigo/admin/include/image.class.php on line 600
Warning: imagedestroy() expects parameter 1 to be resource, boolean given in /volume1/web/piwigo/admin/include/image.class.php on line 604
Warning: imagejpeg() expects parameter 1 to be resource, boolean given in /volume1/web/piwigo/admin/include/image.class.php on line 628
Warning: filesize(): stat failed for ./local/GThumb/410/81c1a93bb722fef9005d04091296ff54.jpg in /volume1/web/piwigo/admin/include/image.class.php on line 268
Warning: imagedestroy() expects parameter 1 to be resource, boolean given in /volume1/web/piwigo/admin/include/image.class.php on line 634

#72 2012-03-03 14:46:22

Jacques Martin
Invité

Re: [plugin] GThumb+

j'ai isolé une image qui provoque ce problème
j'ai vu qu'elle n'avait aucune données exif, à part ça, je ne détecte rien d'inhabituel

#73 2012-03-03 15:10:21

Jacques Martin
Invité

Re: [plugin] GThumb+

Bizarrement , mon bug a disparu
pour isoler le pb j'avais vidé un album et remis une par une les images. j'avais isolé une image suspect et maintenant même avec cette image je ne reproduit plus le pb. J'ai pourtant vidé N fois le cache et remis le catalogue comme au départ.

bon... désolé du dérangement :)

#74 2012-03-06 14:10:26

AgatheGuillaume
Invité

Re: [plugin] GThumb+

Bonjour à tous et merci pour ce super plugin.

J'ai cependant un problème sur ma galerie. La génération des thumbs se passe bien sur les images qui sont en local sur le serveur mais j'utilise la fonctionnalité de sites distants (environ 6000 photos à distance) et pour celles ci, la génération échoue et rend l'album non visitable avec l'erreur suivante :
[External ImageMagick] Corrupt image

Est-ce que cette possibilité sera rendue possible ?
Est-ce possible de déplacer les photos des sites distants vers l’hébergement local sans perdre toute les informations (nb visites, commentaires...)

Merci par avance pour vos réponses

Guillaume (www.agathe-guillaume.fr)

Pour info :

Version de Piwigo
        Piwigo 2.3.3
Environnement
        Système d'exploitation: Linux
        PHP: 5.2.17 (Montrer les informations) [2012-03-06 14:06:10]
        mysql: 5.1.49-3-log [2012-03-06 14:06:10]
        Bibliothèque graphique: External ImageMagick 6.3.7
Base de données
        6513 photos (première photo ajoutée le Lundi 05 Mars 2007)
        254 albums dont 244 physiques et 10 virtuels (6772 associations)

#75 2012-03-07 12:47:48

P@t
Équipe Piwigo
Nice
2007-06-13
5695

Re: [plugin] GThumb+

AgatheGuillaume a écrit:

Bonjour à tous et merci pour ce super plugin.

J'ai cependant un problème sur ma galerie. La génération des thumbs se passe bien sur les images qui sont en local sur le serveur mais j'utilise la fonctionnalité de sites distants (environ 6000 photos à distance) et pour celles ci, la génération échoue et rend l'album non visitable avec l'erreur suivante :
[External ImageMagick] Corrupt image

Est-ce que cette possibilité sera rendue possible ?
Est-ce possible de déplacer les photos des sites distants vers l’hébergement local sans perdre toute les informations (nb visites, commentaires...)

Il faut changer la bibliothèque graphique en GD.
Pour cela, dans LocalFiles Editor, premier onglet, insère la ligne suivante:

$conf['graphics_library'] = 'gd';

Attention, les sites distants disparaitront en 2.4


P@t

Hors ligne

  •  » Plugins
  •  » [plugin] GThumb+

Pied de page des forums

Propulsé par FluxBB

github twitter newsletter Faire un don Piwigo.org © 2002-2022 · Contact