Annonce

  •  » Outils
  •  » [Résolu] tag avec geosetter

#1 2011-05-17 14:00:59

cdurand
Membre
2011-05-13
22

[Résolu] tag avec geosetter

Bonjour,

Je en sais pas si je suis dans la bonne catégorie du forum (si ce n'est pas le cas désolé).
J'ai un problème avec geosetter et l'affichage des tag dans piwigo.
J'aimerais connaître la procédure que vous utilisez.
Comme je l'énonçait dans un autre post, je tente l'utilisation de piwigo dans un intranet et c'est un un peu un casse tête étant donné que certaines fonctions ne sont accessible que par un administrateur :/
J'ai commencé à vouloir utiliser le plugin UserTag mais celui-ci ne fonctionne pas avec cette version de piwigo et mes utilisateur ne peuvent donc pas taguer les images.
Je me suis donc dit qu'ils pourraient utiliser Geosetter (je pensait l'utiliser pour la géolocalisation avec le plugin RV maps and earth donc cela ferait d'une pierre deux coup).
Cependant lorsque j'edite les métadata avec geosetter, je n'ai pas de champs "tag" mais un champs "mot clé", je rentre mes mots clé à cet endroit enregistre mes modifications. Le problème est que quand j'ajoute la photo à piwigo, le tag n'est pas trouvé....
Si j'active le plugin "advanced meta datas" et que jécide d'afficher les mots clés, je vois bien les mots clés que j'ai ajouté via geosetter mais ceux-ci ne se mettent pas en tant que tag.

Ce qui me vient à me poser cette question :
Comment procédez vous pour la gestion des tag avec Geosetter ?

Merci d'avance pour vos réponse

Hors ligne

#2 2011-05-17 15:37:26

Gotcha
Equipe Piwigo
Pierrelatte (26)
2007-03-14
13331

Re: [Résolu] tag avec geosetter

Bonjour,
Il y a aussi le plugin Gmaps qui fonctionne bien. Il est juste beaucoup plus gourmand en place dans la BDD ^_^;

Sinon, votre soucis n'est pas lié à GeoSetter (du moins je ne pense pas) mais au fait que vous n'avez pas synchronisé les méta-données des photos une fois les fichiers remplacés.
Et pour synchroniser, vous pouvez le faire avec le gestionnaire par lot ou bien, si vous ajoutez vos photos via FTP (chargement manuel donc) en passant par la page d'outils : Synchroniser.

:-)


Ayez comme premier réflexe de consulter le wiki.
Ensuite, veuillez effectuer une recherche sur le forum avant de poser votre question.

LE FAIRE EST LE REVELATEUR DE L'ETRE

Hors ligne

#3 2011-05-17 16:20:03

cdurand
Membre
2011-05-13
22

Re: [Résolu] tag avec geosetter

Bonjour,

Merci pour votre réponse.
En fait c'est une nouvelle photo et non la modification d'une photo existante.
J'ai tout de même tenté d'effectuer une synchronisation mais sans résultat.
Si je n'active pas le plugin Advanced Meta Data je n'ai aucun des mot clé que j'ai mis dans Geosetter.
Si j'active le plugin je vois les mots clé mais dans la rubrique "mot clé" des infos IPTC. Hors l'idéal serait que cela apparaisse dans "tag".
J'utilise la dernière version de geosetter et la dernière version d'exiftool (utilisé par geosetter).
De votre coté lorsque vous ajoutez une nouvelle photo que vous avez tagué avec geosetter, cela apparaît bien dans "Tag" ?

Merci par avance.

Hors ligne

#4 2011-05-17 16:27:47

Gotcha
Equipe Piwigo
Pierrelatte (26)
2007-03-14
13331

Re: [Résolu] tag avec geosetter

cdurand a écrit:

De votre coté lorsque vous ajoutez une nouvelle photo que vous avez tagué avec geosetter, cela apparaît bien dans "Tag" ?

Tout à fait.
Je regarde de mon coté comment reproduire.


Ayez comme premier réflexe de consulter le wiki.
Ensuite, veuillez effectuer une recherche sur le forum avant de poser votre question.

LE FAIRE EST LE REVELATEUR DE L'ETRE

Hors ligne

#5 2011-05-17 16:42:10

cdurand
Membre
2011-05-13
22

Re: [Résolu] tag avec geosetter

Super merci.
Voici ce que je fais :

- Ouverture de Geosetter.exe (j'utilise le zip)
- Dans Geosetter je sélectionne ma photo (photo encore jamais mise sur piwigo)
- Ensuite je vais dans Images puis je clic sur "Editez les métadonnées"
- Je vais dans l'onglet "Catégorie/Mot clefs"
- Puis j'ajoute 3 mots dans la colonne "Mot clefs".
- Je clic enfin sur OK
- Je refais images puis "Enregistrer les modifications"
- Je ferme Geosetter et ouvre Piwigo
- Je clic directement sur "Ajoutez des photos" (grace qu plugin community)
- Je choisi un album existant (pour mon test l'album est Photos/test1)
- Je sélectionne la photo précédemment tagué avec Geosetter
- Puis je clic enfin sur Ajout
- Ensuite je vais dans ma galerie Photos/test1 pour voir si l'import de ma photo a fonctionné, j'ai bien la photo mais aucun tag ne lui ai associé....

Encore merci pour votre aide

Hors ligne

#6 2011-05-17 16:44:07

Gotcha
Equipe Piwigo
Pierrelatte (26)
2007-03-14
13331

Re: [Résolu] tag avec geosetter

Je ne parviens pas à reproduire chez moi.

Pourriez-vous :
- Coller ici le contenu de votre fichier de configuration locale [ Administration >> Plugins >> LocalFiles Editor >> Onglet "Configuration locale" ]
- Renommer une de vos photos taggée avec GeoSetter en "sample.jpg" La placer dans ./piwigo/tools Puis lancer ./piwigo/tools/metadata.php
- Coller ici le résultat de l'opération précédente.

Merci.


Ayez comme premier réflexe de consulter le wiki.
Ensuite, veuillez effectuer une recherche sur le forum avant de poser votre question.

LE FAIRE EST LE REVELATEUR DE L'ETRE

Hors ligne

#7 2011-05-17 16:45:50

Gotcha
Equipe Piwigo
Pierrelatte (26)
2007-03-14
13331

Re: [Résolu] tag avec geosetter

Une précision : Est-ce que votre serveur local accepte l'extension php : exif ??? Si ce n'est pas le cas, vous devriez avoir un message sur la page d'administration de votre galerie.


Ayez comme premier réflexe de consulter le wiki.
Ensuite, veuillez effectuer une recherche sur le forum avant de poser votre question.

LE FAIRE EST LE REVELATEUR DE L'ETRE

Hors ligne

#8 2011-05-17 19:02:01

grum
Former Piwigo Team
50% Nantes - 50% Paris
2007-09-10
2502

Re: [Résolu] tag avec geosetter

juste comme çà, je ne connais pas Géosetter, mais si après màj de la géolocalisation les infos apparaissent dans les mots-clefs, c'est que les informations ne sont pas enregistrées au bon endroit dans l'image.

Il n'y a que deux endroits ou des données GPS peuvent être enregistrées pour être reconnues en tant que tel : dans les données GPS, situées dans les exif ou dans les XMP.


Mes photos avec Piwigo évidemment !
[ www.grum.fr ] [ photos.grum.fr ]

Hors ligne

#9 2011-05-18 09:02:27

cdurand
Membre
2011-05-13
22

Re: [Résolu] tag avec geosetter

Bonjour,

Navré pour cette réponse tardive.

Pour [ Administration >> Plugins >> LocalFiles Editor >> Onglet "Configuration locale" ] je n'ai rien modifié donc j'ai ceci :

<?php

/* Dans cette fenêtre, écrivez les informations pour configurer votre galerie Piwigo. */




?>

Dois je vous coller le config_default.inc.php ?

Sinon pour le test avec le sample.jpg :

Informations are read from sample.jpg


IPTC Fields in sample.jpg

2#000 = 
2#055 = 20100119
2#060 = 154522+0100


EXIF Fields in sample.jpg

Array
(
    [FileName] => sample.jpg
    [FileDateTime] => 1305557290
    [FileSize] => 1736283
    [FileType] => 2
    [MimeType] => image/jpeg
    [SectionsFound] => ANY_TAG, IFD0, THUMBNAIL, EXIF, GPS, INTEROP
    [COMPUTED] => Array
        (
            [html] => width="2576" height="1932"
            [Height] => 1932
            [Width] => 2576
            [IsColor] => 1
            [ByteOrderMotorola] => 1
            [ApertureFNumber] => f/2.8
            [Thumbnail.FileType] => 2
            [Thumbnail.MimeType] => image/jpeg
        )

    [Make] => EASTMAN KODAK COMPANY
    [Model] => KODAK Z7590 ZOOM DIGITAL CAMERA
    [Orientation] => 1
    [XResolution] => 230/1
    [YResolution] => 230/1
    [ResolutionUnit] => 2
    [DateTime] => 2010:01:19 15:45:22
    [YCbCrPositioning] => 1
    [Exif_IFD_Pointer] => 224
    [GPS_IFD_Pointer] => 3216
    [THUMBNAIL] => Array
        (
            [Compression] => 6
            [Orientation] => 1
            [XResolution] => 72/1
            [YResolution] => 72/1
            [ResolutionUnit] => 2
            [JPEGInterchangeFormat] => 3516
            [JPEGInterchangeFormatLength] => 3899
        )

    [ExposureTime] => 1/30
    [FNumber] => 28/10
    [ExposureProgram] => 6
    [ISOSpeedRatings] => 140
    [ExifVersion] => 0221
    [DateTimeOriginal] => 2010:01:19 15:45:22
    [DateTimeDigitized] => 2010:01:19 15:45:22
    [ComponentsConfiguration] => �
    [ShutterSpeedValue] => 49/10
    [ApertureValue] => 3/1
    [ExposureBiasValue] => 0/3
    [MaxApertureValue] => 3/1
    [MeteringMode] => 5
    [LightSource] => 0
    [Flash] => 16
    [FocalLength] => 63/10
    [MakerNote] => KDK0102IZ7590   

..... là il y a toute une série de caractère "cabalistique" :-D ....

    [FlashPixVersion] => 0100
    [ColorSpace] => 1
    [ExifImageWidth] => 2576
    [ExifImageLength] => 1932
    [InteroperabilityOffset] => 3186
    [ExposureIndex] => 140/1
    [SensingMethod] => 2
    [FileSource] => 
    [SceneType] => 
    [CustomRendered] => 0
    [ExposureMode] => 0
    [WhiteBalance] => 0
    [DigitalZoomRatio] => 0/100
    [FocalLengthIn35mmFilm] => 38
    [SceneCaptureType] => 0
    [GainControl] => 1
    [Contrast] => 0
    [Saturation] => 0
    [Sharpness] => 0
    [SubjectDistanceRange] => 0
    [GPSVersion] => ��
    [GPSLatitudeRef] => N
    [GPSLatitude] => Array
        (
            [0] => 48/1
            [1] => 5/1
            [2] => 40043/6495
        )

    [GPSLongitudeRef] => W
    [GPSLongitude] => Array
        (
            [0] => 1/1
            [1] => 51/1
            [2] => 51427/1003
        )

    [GPSTimeStamp] => Array
        (
            [0] => 14/1
            [1] => 45/1
            [2] => 22/1
        )

    [GPSMapDatum] => WGS-84
    [GPSDateStamp] => 2010:01:19
    [InterOperabilityIndex] => R98
    [InterOperabilityVersion] => 0100
)


Donc si je comprend bien ce test, mes mot clé ne sont pas vu .... seul Advanced metadata les voit....


Je n'ai pas de message sur la page d'administration donc j'en conclue que mon serveur accepte l'extension php exif ....

@grum : J'ai dut mal m'expliquer.... en fait les infos de géolocalisations fonctionnent très bien, mon problème est que les tag que j'aimerais ajouter depuis geosetter ne s'affiche pas sur piwigo (pour les donnée GPS aucun soucis ça ça fonctionne du tonnerre).

Merci pour votre aide


Edit : j'ai installé geosetter sur ma machine (comme précisé avant j'utilisait le zip). J'ai relancé le metada.php et miracle .... au début du code j'ai :

Informations are read from sample.jpg


IPTC Fields in sample.jpg

2#000 = 
2#025 = animaux,chien,loulou,mordelles
2#055 = 20100119
2#060 = 154522+0100



On peut donc voir mes mots clés (animaux,chien,loulou,mordelles)... par contre toujours pas de tag affiché dans piwigo... :-(

Dernière modification par cdurand (2011-05-18 09:11:47)

Hors ligne

#10 2011-05-18 17:46:07

Zaphod
Former Piwigo Team
Toulouse
2006-11-13
2422

Re: [Résolu] tag avec geosetter

Sous Local Files Editor, il faut que tu actives dans le fichier de config le mapping IPTC.

Pas besoin d'y coller ce qu'il y a dans la conf par défaut, en revanche il faut mettre par exemple :

Code:

$conf['use_iptc'] = true;
$conf['use_iptc_mapping'] = array(
  'name'            => '2#005',
  'keywords'        => '2#025',
  'author'          => '2#080',
  'comment'         => '2#120'
  );

L'important ce sont les mots clés.
Le nom, auteur, commentaire, c'est à voir en fonction de ce que tu vas renseigner.

En gros, cette fonction indique à Piwigo qu'il faut prendre le champ IPTC #25 et l'affecter aux mots clés piwigo.

Hors ligne

#11 2011-05-19 08:41:42

cdurand
Membre
2011-05-13
22

Re: [Résolu] tag avec geosetter

Merci !!!

Tout simplement génial.

Encore merci.

Hors ligne

#12 2011-05-19 09:18:07

plg
Équipe Piwigo
Nantes, France, Europe
2002-04-05
12539

Re: [Résolu] tag avec geosetter

Autant sur le titre de la photo ou l'auteur, il n'y a pas de consensus entre les logiciels qui écrivent les IPTC, autant sur les tags (keywords) et la description (comment) c'est toujours 2#025 et 2#120, ça deviendra de la configuration standard en 2.3 je pense.


Historiquement, premier utilisateur connu de Piwigo ;-)

Hors ligne

#13 2011-05-19 11:59:51

Zaphod
Former Piwigo Team
Toulouse
2006-11-13
2422

Re: [Résolu] tag avec geosetter

Moi j'aurais dit l'inverse, que c'était toujours pareil pour le titre et l'auteur, et qu'en revanche pour la description ça changeait ;)

Les mots clés, c'est toujours 2#025.

De toutes façons l'important c'est d'avoir quelque chose qui colle le plus aux normes et à la majorité des softs.
Ensuite, l'utilisateur peut toujours changer s'il veut.


Après, certains softs n'utilisent plus les IPTC mais les XMP qui sont plus libres (les champs n'ont plus de limite de caractères, alors que ça peut être génant avec les IPTC).
Pour l'instant c'est une minorité mais ça peut devenir de plus en plus courant... car les champs ITPC sont "legacy", ils ne sont gardés qu'à des fins de compatibilité, ils peuvent donc disparaitre...

Hors ligne

  •  » Outils
  •  » [Résolu] tag avec geosetter

Pied de page des forums

Propulsé par FluxBB

github twitter newsletter Faire un don Piwigo.org © 2002-2022 · Contact