Annonce

#1 2011-01-01 21:16:43

Emmanuelle
Invité

[Résolu] Gestion des tags

Bonjour,

   J'ai besoin d'aide sur la gestion des tags. D'après ce que j'ai compris, lors de la synchronisation des photos, les tags devraient être automatiquement créés en foction des mots-clés EXIF. Est correct, car cela ne fonctionne pas chez moi? Ca a fonctionné lors de ma première synchronisation, mais plus rien!

   Pour info:
   - Le site est hébergé chez Free.
   - J'ai installé la version Piwigo  2.1.3
   - Mes photos n'ont pas de données IPTC, mais par contre, elles ont des données EXIF.

   En trainant un peu sur le forum, j'ai trouvé certains points.
   - J'ai modifié le fichier "config_default.inc" avec
          $conf['use_exif_mapping'] = array(
                 'date_creation' => 'DateTimeOriginal',
                 'keywords'      => 'exif_field_XPKeywords' );
   - J'ai vu qu'il fallait que le fichier PHP soit modifié pour que les données EXIF soient synchronisées. Je n'y ai pas accès pas d'après les infos sur la page d'accueil d'administration la propriété "EXIF Support" est activé.

   Voilà, toute personne pouvant m'aider sera la bienvenue.

Bonne année 2011

#2 2011-01-01 21:19:09

LucMorizur
Membre
Vienne (Isère, 38)
2009-03-01
1969

Hors ligne

#3 2011-01-01 21:24:20

Emmanuelle
Invité

Re: [Résolu] Gestion des tags

Oui, en long, en large et en travers!!

Je pense avoir suivi les instructions à la lettre, mais ça ne marche pas.

#4 2011-01-01 22:59:07

LucMorizur
Membre
Vienne (Isère, 38)
2009-03-01
1969

Re: [Résolu] Gestion des tags

OK, bon. Alors.

Emmanuelle a écrit:

En trainant un peu sur le forum, j'ai trouvé certains points.
   - J'ai modifié le fichier "config_default.inc" avec
          $conf['use_exif_mapping'] = array(
                 'date_creation' => 'DateTimeOriginal',
                 'keywords'      => 'exif_field_XPKeywords' );
   - J'ai vu qu'il fallait que le fichier PHP soit modifié pour que les données EXIF soient synchronisées. Je n'y ai pas accès pas d'après les infos sur la page d'accueil d'administration la propriété "EXIF Support" est activé.

   Voilà, toute personne pouvant m'aider sera la bienvenue.

Bonne année 2011

Tout d'abord, il ne vaut vraiment mieux pas modifier include/config_default.inc.php , mais créer un fichier local/config/config.inc.php . C'est très facile avec le plugin LocalFiles Editor (onglet "Configuration locale", bien sûr). include/config_default.inc.php est exécuté avant local/config/config.inc.php , c'est donc les informations de ce dernier qui sont retenues en fin de compte. local/config/config.inc.php n'est pas touché lors d'une mise à jour, tandis que include/config_default.inc.php peut l'être ; utiliser local/config/config.inc.php permet ainsi de faire les mises à jour sans se soucier de sauvegarder ses personnalisations.

Bon.

Ensuite, dans local/config/config.inc.php , mettre :

$conf['show_exif'] = true;

afin que les infos EXIF soient affichées ;

$conf['show_exif_fields'] = array(
là, choisir les champs EXIF que l'on veut afficher ; voir la page du wiki citée dans mon précédent post pour plus de détails
  );


$conf['use_exif'] = true;

afin que les infos EXIF soient synchronisées au moment de l'ajout d'images (quelle méthode utilses-tu d'ailleurs ? FTP, pLoader, Jiwigo, ou "Ajouter des photos" dans l'admin ?) ;

$conf['use_exif_mapping'] = array(
là aussi, voir la page du wiki citée dans mon précédent post pour plus de détails -- je sais plus vraiment comment ça s'utilise, celui-là, déjà ! :-/
);


Voilà. Qu'est-ce que ça donne, maintenant ?

À bientôt :-) !

Dernière modification par LucMorizur (2011-01-01 23:00:04)

Hors ligne

#5 2011-01-01 23:21:56

Emmanuelle
Invité

Re: [Résolu] Gestion des tags

Merci pour ton aide et merci pour l'astuce des deux fichiers. Je ne comprenais pas pourquoi localfileeditor m'indiquait que le fichier n'existait pas, maintenant j'ai compris!

Pour le reste, tout avait été fait, voilà l'extrait de mon fichier

$conf['show_exif'] = true;
$conf['show_exif_fields'] = array(
  'Make',
  'Model',
  'DateTimeOriginal',
  'COMPUTED;ApertureFNumber',
  'Keywords'   // Ajouté
  );
$conf['use_exif'] = true;
conf['use_exif_mapping'] = array(
  'date_creation' => 'DateTimeOriginal',
  'keywords'      => 'exif_field_XPKeywords'    // Ajouté
  );

L'affichage des Keywords fonctionne correctement et contient des valeurs. Par contre, aucun tag créé!

#6 2011-01-02 10:24:14

Emmanuelle
Invité

Re: [Résolu] Gestion des tags

J'ai oublié de répondre à une question: J'ajoute mes photos via FTP

#7 2011-01-02 10:36:06

LucMorizur
Membre
Vienne (Isère, 38)
2009-03-01
1969

Re: [Résolu] Gestion des tags

OK ; as-tu effectué une synchronisation (Admin > Outils > Synchroniser) en cochant :

    * Répertoires + fichiers

       Synchroniser les méta-données (filesize, width, height, high_filesize, date_creation, keywords, date_creation, author, name, comment)
    * Même les éléments déjà synchronisés
    * Ecraser les données existantes avec des données vides

    * Rechercher dans les sous-catégories

et en décochant
    * Simuler uniquement (aucun changement ne sera fait dans la base de données)


et ce après avoir configuré local/config/config.inc.php comme tu l'as indiqué ?

Hors ligne

#8 2011-01-02 12:01:10

Emmanuelle
Invité

Re: [Résolu] Gestion des tags

Aux problèmes incompréhensibles, il faut employer les grands moyens.

J'ai donc désinstaller Piwigo pour réinstaller la nouvelle version. J'ai donc une installation toute neuve en 2.1.5.
J'ai modifié le fichier local/config/config.inc.php comme indiqué précédemment (et sans toucher le fichier include/config_default.inc.php)

J'ai ajouté de nouvelles photos via FTP puis fait une synchronisation comme tu l'as indiqué, mais toujours pas de TAG!!!

C'est à s'arracher les cheveux!

#9 2011-01-02 12:45:50

LucMorizur
Membre
Vienne (Isère, 38)
2009-03-01
1969

Re: [Résolu] Gestion des tags

Emmanuelle a écrit:

Aux problèmes incompréhensibles, il faut employer les grands moyens.

J'ai donc désinstaller Piwigo pour réinstaller la nouvelle version. J'ai donc une installation toute neuve en 2.1.5.
J'ai modifié le fichier local/config/config.inc.php comme indiqué précédemment (et sans toucher le fichier include/config_default.inc.php)

J'ai ajouté de nouvelles photos via FTP puis fait une synchronisation comme tu l'as indiqué, mais toujours pas de TAG!!!

C'est à s'arracher les cheveux!

Euh, tout d'abord, restons calme :-) .

Question bête : appuies-tu sur le bouton http://fr.piwigo.org/demo/themes/Sylvia/icon/metadata.png "Montrer les méta-données du fichier", dans la page image, afin de voir les méta-données en question ?

Et sinon, peux-tu donner une adresse pour ta galerie, que j'y aille voir par moi-même ? En MP si tu préfères.

Hors ligne

#10 2011-01-02 13:03:01

Emmanuelle
Invité

Re: [Résolu] Gestion des tags

Tout d'abord, merci pour ton aide et ta patience.

J'appuie, sur le bouton, j'ai bien mes mots-clés, mais aucun tag associé à l'image.

Tu peux aller voir sur http://egicquello.free.fr/photos

#11 2011-01-02 16:52:24

LucMorizur
Membre
Vienne (Isère, 38)
2009-03-01
1969

Re: [Résolu] Gestion des tags

Emmanuelle a écrit:

Tout d'abord, merci pour ton aide et ta patience.

Bah, de rien ; c'est que moi jamais personne ne m'a aidé sur ce forum, je me suis toujours débrouillé tout seul, tout seul, tout seul :'-(( ....

:-D

Emmanuelle a écrit:

J'appuie, sur le bouton, j'ai bien mes mots-clés, mais aucun tag associé à l'image.

Tu peux aller voir sur http://egicquello.free.fr/photos

?!?!?

On ne doit pas parler de la même chose alors : les EXIF sont bien là, voir l'image attachée...

Hors ligne

#12 2011-01-02 16:57:53

LucMorizur
Membre
Vienne (Isère, 38)
2009-03-01
1969

Re: [Résolu] Gestion des tags

OK, alors en fait tu parles des tags "mots-clés".

Pour Piwigo, il s'agit d'une donnée récupérée dans les métadonnées IPTC, pas les EXIF. En effet, les EXIF sont ajoutés par l'appareil (type de l'appareil, caractéristiques de la prise de vue...), car l'appareil les connaît.

Pour ce qui est des mots-clés, comme aussi le titre de la photo, le lieu où la photo est prise, etc ; ce sont des données qui sont a priori dépendantes du sujet, et donc rajoutées après la prise de vue, à la main.

Je ne vois donc pas quels "tags" dans les EXIF tu voudrais utiliser comme "tags (mots-clés)" pour Piwigo ?

Hors ligne

#13 2011-01-02 17:03:36

Emmanuelle
Invité

Re: [Résolu] Gestion des tags

Je suis d'accord que les EXIFS sont bien là. Mais la ligne Tag (représentant l'élément TAG PIWIGO) aux dessus des données EXIF est vide.

D'après ce que j'avais compris, les TAGS PIWIGO pouvaient être créés et associés automatiquement en fonction des mots clés EXIF. Je m'attendais donc sur la capture d'écran que tu as mise que les tags "Lumière" et "Bougies" soient automatiquement créés et liés à la photo.

#14 2011-01-02 17:16:29

LucMorizur
Membre
Vienne (Isère, 38)
2009-03-01
1969

Re: [Résolu] Gestion des tags

Emmanuelle a écrit:

Je suis d'accord que les EXIFS sont bien là. Mais la ligne Tag (représentant l'élément TAG PIWIGO) aux dessus des données EXIF est vide.

D'après ce que j'avais compris, les TAGS PIWIGO pouvaient être créés et associés automatiquement en fonction des mots clés EXIF. Je m'attendais donc sur la capture d'écran que tu as mise que les tags "Lumière" et "Bougies" soient automatiquement créés et liés à la photo.

Alors je ne sais plus où cela est configuré, mais les tags pour Piwigo sont récupérés dans les données IPTC, pas EXIF (enfin du moins pour autant que je sache pour l'instant ; s'il est possible de les récupérer dans les EXIF, ça ne doit pas être compliqué à voir).

Ensuite dans la photo que j'ai regardé, on voit "Lumi�res/Bougies". (Le "�" montre un problème de jeu de caractèresur le "è" de "Lumière" ; voir ma prochaine question.) La métadonnée en question est donc bien récupérée par Piwigo, simplement elle n'est pas utilisée en tant que tag mais juste en tant qu'information affichée dans les métadonnées.

Il faut donc, soit :
_ que tu entres les métadonnées de tag dans les IPTC ;
_ que soit trouvé comment faire utiliser les métadonnées EXIF "keywords" en tant que tag, par Piwigo.

Mais je suis assez étonné que tu utilises les EXIF pour associer des mots-clés à tes photos ; pourquoi pas les IPTC ? Et comment d'ailleurs entres-tu ces mots-clés EXIF dans les photos, quel logiciel utilises-tu pour ça (ce qui sera utile pour voir comment utiliser un jeu de caractère correct) ?

Hors ligne

#15 2011-01-02 18:40:33

Emmanuelle
Invité

Re: [Résolu] Gestion des tags

J'utilise la Galerie Windows Live pour saisir les mots-clés. L'ensemble des informations sont saisies dans les données EXIF et les données IPTC sont vides.

D'après ce que j'avais compris, à partir du moment où l'on récupère quelquechose dans "keywords" les tags devraient se créer.

Pied de page des forums

Propulsé par FluxBB

github twitter newsletter Faire un don Piwigo.org © 2002-2021 · Contact