•  » Installation
  •  » [Résolu] Probleme migration 1.7.0 vers 2.1.2

#1 2010-08-05 14:57:25

nicofree77
Membre
2010-08-05
11

[Résolu] Probleme migration 1.7.0 vers 2.1.2

Bonjour,

Étant très novice je me permets de solliciter votre aide. J'ai installé (avec succès) phpwebgallery 1.7.0 il y déjà quelque temps.
Aujourd'hui je souhaitais faire la dernière mise à jour avec le tutoriel. Malgré celui-ci, et après avoir mis le fichier update téléchargé au préalable dans le repertoire "plugin", je ne le vois pas sur mon site ???
Je précise que j'ai vérifié et que ma configuration remplie bien les spécificités techniques demandées (PHP5 et MySQL 5).

Par ailleurs lorsque je veux "vérifier les mises à jour" ou "Autres plugins disponibles" depuis mon site, j'ai le message suivant : En rouge : "Impossible de se connecter au serveur " et tout en haut de la page "Warning: krsort() expects parameter 1 to be array, boolean given in /mnt/167/sda/4/e/albumsnico/plugins/PluginsManager/include/plugins.class.php on line 298"

Pour être franc là je suis complètement perdu... c'est du chinois.

En espérant ne pas m'être trompé de rubrique, merci par avance pour votre aide.

Hors ligne

#2 2010-08-05 15:55:39

nicofree77
Membre
2010-08-05
11

Re: [Résolu] Probleme migration 1.7.0 vers 2.1.2

Bon, problème de fichiers résolu... (problème de connexion !).

J'avance !!!

Hors ligne

#3 2010-08-05 16:03:26

nicofree77
Membre
2010-08-05
11

Re: [Résolu] Probleme migration 1.7.0 vers 2.1.2

Maintenant après avoir installé Piwigo AutoUpdate (la dernière version) je ne peux plus me logger en administrateur.

J'ai un écran blanc avec le message suivant :

"Fatal error: Call to undefined function load_language() in /mnt/167/sda/4/e/albumsnico/plugins/autoupdate/main.inc.php on line 22"

J'suis mal !!! Je ne sais plus du tout comment faire maintenant que je n'ai plus accès...

Merci pour votre aide.

Hors ligne

#4 2010-08-05 17:24:28

Gotcha
Equipe Piwigo
Pierrelatte (26)
2007-03-14
13324

Re: [Résolu] Probleme migration 1.7.0 vers 2.1.2

nicofree77 a écrit:

Maintenant après avoir installé Piwigo AutoUpdate (la dernière version) je ne peux plus me logger en administrateur.

J'ai un écran blanc avec le message suivant :

"Fatal error: Call to undefined function load_language() in /mnt/167/sda/4/e/albumsnico/plugins/autoupdate/main.inc.php on line 22"

J'suis mal !!! Je ne sais plus du tout comment faire maintenant que je n'ai plus accès...

Merci pour votre aide.

Première des choses, rendez-vous dans votre Base De Données (BDD) et trouvez la table piwigo_plugins. Les tables sont visibles sur la colonne de gauche.
Là, trouvez la ligne concernant autoupdate.
Editez la ligne.
A la place de "active" saisissez "inactive".

Ça doit résoudre ce problème.

Je vous conseille de supprimer le plugin en question (via votre page d'administration) et de le réinstaller (toujours via votre page d'administration).


Ayez comme premier réflexe de consulter le wiki.
Ensuite, veuillez effectuer une recherche sur le forum avant de poser votre question.

LE FAIRE EST LE REVELATEUR DE L'ETRE

Hors ligne

#5 2010-08-05 18:03:13

nicofree77
Membre
2010-08-05
11

Re: [Résolu] Probleme migration 1.7.0 vers 2.1.2

Tout d'abord merci pour votre aide : j'ai résolu mon problème en installant une version inférieure de PiwigoAuto Update (justement prévue pour ma version 1.7.0).

Piwigo me propose la mise à jour que je lance :

- sauvegarde de "template"
- sauvegarde de "database.sql"
- mise à jour

et là un écran blanc (décidement !) type internet mais qui ne "travaille plus"...

Je ressort pour me logger à nouveau et là je tombe sur un écran complètement désordonné (je le met en pièce jointe) avec marqué en haut : "Bad status for user "guest", default status will be used. Please notify the webmaster."

Mes identifiants et mot de passe ne fonctionnent pas.

A nouveau coinçé...

Hors ligne

#6 2010-08-05 19:14:13

nicofree77
Membre
2010-08-05
11

Re: [Résolu] Probleme migration 1.7.0 vers 2.1.2

Voici les infos qui apparaissent précisément :

Warning:  [mysql error 1146] Table 'albumsnico.phpwebgallery_themes' doesn't exist

SELECT
    ui.*,
    uc.*,
    t.name AS theme_name
  FROM phpwebgallery_user_infos AS ui
    LEFT JOIN phpwebgallery_user_cache AS uc ON ui.user_id = uc.user_id
    LEFT JOIN phpwebgallery_themes AS t ON t.id = ui.theme
  WHERE ui.user_id = 2
; in /mnt/167/sda/4/e/albumsnico/include/dblayer/functions_mysql.inc.php on line 651


Warning: mysql_fetch_assoc(): supplied argument is not a valid MySQL result resource in /mnt/167/sda/4/e/albumsnico/include/dblayer/functions_mysql.inc.php on line 155

Warning: array_merge() [function.array-merge]: Argument #2 is not an array in /mnt/167/sda/4/e/albumsnico/include/functions_user.inc.php on line 330

Warning: Invalid argument supplied for foreach() in /mnt/167/sda/4/e/albumsnico/include/functions_user.inc.php on line 332



Warning:  [mysql error 1064] You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near '' at line 3

SELECT cat_id
  FROM phpwebgallery_user_access
  WHERE user_id =
; in /mnt/167/sda/4/e/albumsnico/include/dblayer/functions_mysql.inc.php on line 651


Warning: mysql_fetch_assoc(): supplied argument is not a valid MySQL result resource in /mnt/167/sda/4/e/albumsnico/include/dblayer/functions_mysql.inc.php on line 202



Warning:  [mysql error 1064] You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near '' at line 4

SELECT cat_id
  FROM phpwebgallery_user_group AS ug INNER JOIN phpwebgallery_group_access AS ga
    ON ug.group_id = ga.group_id
  WHERE ug.user_id =
; in /mnt/167/sda/4/e/albumsnico/include/dblayer/functions_mysql.inc.php on line 651


Warning: mysql_fetch_assoc(): supplied argument is not a valid MySQL result resource in /mnt/167/sda/4/e/albumsnico/include/dblayer/functions_mysql.inc.php on line 202



Warning:  [mysql error 1064] You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near '' at line 4

SELECT DISTINCT(id)
  FROM phpwebgallery_images INNER JOIN phpwebgallery_image_category ON id=image_id
  WHERE category_id NOT IN (30,32,33,34,35,36,37,38,39,40,41,42,43,44,46,47,48,49,50,51,52,53,54,55,59,60,61,62,63,64,65,66,67,68,69,70,71,72,73,74,76,77,78,79,80,82,83,84,85)
    AND level> in /mnt/167/sda/4/e/albumsnico/include/dblayer/functions_mysql.inc.php on line 651


Warning: mysql_fetch_assoc(): supplied argument is not a valid MySQL result resource in /mnt/167/sda/4/e/albumsnico/include/dblayer/functions_mysql.inc.php on line 202



Warning:  [mysql error 1064] You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near 'WHERE c.id NOT IN (30,32,33,34,35,36,37,38,39,40,41,42,43,44,46,47,48,49,50,51,5' at line 8
SELECT c.id cat_id, global_rank,
  MAX(date_available) date_last, COUNT(date_available) nb_images
FROM phpwebgallery_categories as c
  LEFT JOIN phpwebgallery_image_category AS ic ON ic.category_id = c.id
  LEFT JOIN phpwebgallery_images AS i
    ON ic.image_id = i.id
      AND i.level<=
  WHERE c.id NOT IN (30,32,33,34,35,36,37,38,39,40,41,42,43,44,46,47,48,49,50,51,52,53,54,55,59,60,61,62,63,64,65,66,67,68,69,70,71,72,73,74,76,77,78,79,80,82,83,84,85)
  GROUP BY c.id, c.global_rank in /mnt/167/sda/4/e/albumsnico/include/dblayer/functions_mysql.inc.php on line 651


Warning: mysql_fetch_assoc(): supplied argument is not a valid MySQL result resource in /mnt/167/sda/4/e/albumsnico/include/dblayer/functions_mysql.inc.php on line 155



Warning:  [mysql error 1064] You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near '' at line 2

DELETE FROM phpwebgallery_user_cache_categories
  WHERE user_id =  in /mnt/167/sda/4/e/albumsnico/include/dblayer/functions_mysql.inc.php on line 651



Warning:  [mysql error 1064] You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near '' at line 2

DELETE FROM phpwebgallery_user_cache
  WHERE user_id =  in /mnt/167/sda/4/e/albumsnico/include/dblayer/functions_mysql.inc.php on line 651



Warning:  [mysql error 1064] You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near ''false',1281028339,'30,32,33,34,35,36,37,38,39,40,41,42,43,44,46,47,48,49,50,51,' at line 5

INSERT INTO phpwebgallery_user_cache
  (user_id, need_update, cache_update_time, forbidden_categories, nb_total_images,
    image_access_type, image_access_list)
  VALUES
  (,'false',1281028339,'30,32,33,34,35,36,37,38,39,40,41,42,43,44,46,47,48,49,50,51,52,53,54,55,59,60,61,62,63,64,65,66,67,68,69,70,71,72,73,74,76,77,78,79,80,82,83,84,85',0,'NOT IN','0') in /mnt/167/sda/4/e/albumsnico/include/dblayer/functions_mysql.inc.php on line 651



Warning:  [mysql error 1054] Unknown column 'theme' in 'field list'

UPDATE phpwebgallery_user_infos
  SET theme = 'Sylvia'
  WHERE user_id = '2' in /mnt/167/sda/4/e/albumsnico/include/dblayer/functions_mysql.inc.php on line 651



Warning:  [mysql error 1146] Table 'albumsnico.phpwebgallery_languages' doesn't exist

SELECT id, name
  FROM phpwebgallery_languages
  ORDER BY name ASC
; in /mnt/167/sda/4/e/albumsnico/include/dblayer/functions_mysql.inc.php on line 651


Warning: mysql_fetch_assoc(): supplied argument is not a valid MySQL result resource in /mnt/167/sda/4/e/albumsnico/include/dblayer/functions_mysql.inc.php on line 155

Warning: Cannot modify header information - headers already sent by (output started at /mnt/167/sda/4/e/albumsnico/include/dblayer/functions_mysql.inc.php:650) in /mnt/167/sda/4/e/albumsnico/include/page_header.php on line 98

Hors ligne

#7 2010-08-06 08:08:09

Gotcha
Equipe Piwigo
Pierrelatte (26)
2007-03-14
13324

Re: [Résolu] Probleme migration 1.7.0 vers 2.1.2

nicofree77 a écrit:

Voici les infos qui apparaissent précisément :

Décidément... :-/ Vous cumulez les problèmes.

Bon bon bon.
La mise à jour ne s'est pas bien passé :-(
Essayez de relancer upgrade.php


Ayez comme premier réflexe de consulter le wiki.
Ensuite, veuillez effectuer une recherche sur le forum avant de poser votre question.

LE FAIRE EST LE REVELATEUR DE L'ETRE

Hors ligne

#8 2010-08-06 08:30:40

nicofree77
Membre
2010-08-05
11

Re: [Résolu] Probleme migration 1.7.0 vers 2.1.2

Voilà les messages d'erreurs après relance de upgrade.php

Warning: include() [function.include]: Unable to access ./include/template.php in /mnt/167/sda/4/e/albumsnico/upgrade.php on line 32

Warning: include(./include/template.php) [function.include]: failed to open stream: No such file or directory in /mnt/167/sda/4/e/albumsnico/upgrade.php on line 32

Warning: include() [function.include]: Failed opening './include/template.php' for inclusion (include_path='/mnt/167/sda/4/e/albumsnico/include:.:/usr/php5/lib/php') in /mnt/167/sda/4/e/albumsnico/upgrade.php on line 32

Warning: include() [function.include]: Unable to access ./include/mysql.inc.php in /mnt/167/sda/4/e/albumsnico/upgrade.php on line 34

Warning: include(./include/mysql.inc.php) [function.include]: failed to open stream: No such file or directory in /mnt/167/sda/4/e/albumsnico/upgrade.php on line 34

Warning: include() [function.include]: Failed opening './include/mysql.inc.php' for inclusion (include_path='/mnt/167/sda/4/e/albumsnico/include:.:/usr/php5/lib/php') in /mnt/167/sda/4/e/albumsnico/upgrade.php on line 34
Could not connect to database server


J'ai essayé diverses opérations hier mais sans succès... j'ai peut-être fait plus de dégâts qu'autre choses vue mes maigres compétences.

Sinon je repart de 0 avec une nouvelle installation de la dernière version ?

Merci pour votre aide

Hors ligne

#9 2010-08-06 08:46:47

Gotcha
Equipe Piwigo
Pierrelatte (26)
2007-03-14
13324

Re: [Résolu] Probleme migration 1.7.0 vers 2.1.2

Dans ce cas, il est temps de faire l'inventaire de ce qui va être à sauver.
Questions :
- Lors de votre première tentative de mise à jour, le plugin AutoUpdate a dû vous demandez de faire une sauvegarde de votre Base De Données. Est-ce que vous l'avez faite ?
- Ensuite, sur votre galerie, avez-vous modifié certains fichiers, comme par exemple des fichiers de thèmes etc ?


Ayez comme premier réflexe de consulter le wiki.
Ensuite, veuillez effectuer une recherche sur le forum avant de poser votre question.

LE FAIRE EST LE REVELATEUR DE L'ETRE

Hors ligne

#10 2010-08-06 09:10:13

nicofree77
Membre
2010-08-05
11

Re: [Résolu] Probleme migration 1.7.0 vers 2.1.2

J'ai un fichier "template.zip" et un fichier "database.sql"...

Sinon je n'ai rien modifié, ou alors de manière involontaire en essayant de comprendre et de réparer.

A la limite, si il est encore possible de sauver les galeries et de les réintégrer dans la nouvelle version, cela serait parfait. Le reste était assez basique, je n'avais pas trop poussé la personnalisation autour.

Merci

Hors ligne

#11 2010-08-06 10:22:32

Gotcha
Equipe Piwigo
Pierrelatte (26)
2007-03-14
13324

Re: [Résolu] Probleme migration 1.7.0 vers 2.1.2

*** Courriel envoyé ***


Ayez comme premier réflexe de consulter le wiki.
Ensuite, veuillez effectuer une recherche sur le forum avant de poser votre question.

LE FAIRE EST LE REVELATEUR DE L'ETRE

Hors ligne

#12 2010-08-06 10:36:07

Gotcha
Equipe Piwigo
Pierrelatte (26)
2007-03-14
13324

Re: [Résolu] Probleme migration 1.7.0 vers 2.1.2

Essayez maintenant la mise à jour manuel.

http://fr.piwigo.org/basics/upgrade_manual


Ayez comme premier réflexe de consulter le wiki.
Ensuite, veuillez effectuer une recherche sur le forum avant de poser votre question.

LE FAIRE EST LE REVELATEUR DE L'ETRE

Hors ligne

#13 2010-08-06 10:38:55

nicofree77
Membre
2010-08-05
11

Re: [Résolu] Probleme migration 1.7.0 vers 2.1.2

Depuis l'étape 1 ? ou bien certaines opérations ont déjà été intégrées ?

Hors ligne

#14 2010-08-06 10:42:23

Gotcha
Equipe Piwigo
Pierrelatte (26)
2007-03-14
13324

Re: [Résolu] Probleme migration 1.7.0 vers 2.1.2

Faites les toutes afin d'être sûre que tout est bien fait ;-)


Ayez comme premier réflexe de consulter le wiki.
Ensuite, veuillez effectuer une recherche sur le forum avant de poser votre question.

LE FAIRE EST LE REVELATEUR DE L'ETRE

Hors ligne

#15 2010-08-06 11:09:55

nicofree77
Membre
2010-08-05
11

Re: [Résolu] Probleme migration 1.7.0 vers 2.1.2

Lors de cette étape :

Ouvrez prep21up.php depuis votre navigateur web http://exemple.com/photos/prep21up.php et vous recevrez une archive "upgrade21.zip"


j'ai le message d'erreur suivant :

You must be connected as webmaster to run this script

???

Hors ligne

  •  » Installation
  •  » [Résolu] Probleme migration 1.7.0 vers 2.1.2

Pied de page des forums

Propulsé par FluxBB

github twitter facebook newsletter Faire un don Piwigo.org © 2002-2019 · Contact