Annonce

  •  » Outils
  •  » Crash pLoader pour Linux quand on choisit le français ?

#1 2010-06-01 08:01:09

tosca
Former Piwigo Team
Cévennes (Gard)
2006-09-23
3818

Crash pLoader pour Linux quand on choisit le français ?

Contexte : 1ère utilisation de pLoader sous Linux (Ubuntu 9.10 64 bits)
J'avais déjà sélectionné 3 photos et demandé la création d'un nouvel album (le 1er).
J'étais en train de passer en revue et régler toutes les préférences dans leur ordre d'affichage, de la 1ère ligne à la dernière.
Lorsque j'ai passé le choix de langue à Français, pLoader s'est terminé sans préavis.

Crash reproductible : pLoader relancé se termine systématiquement lorsque je choisis le français :/

Hors ligne

#2 2010-06-01 08:10:49

tosca
Former Piwigo Team
Cévennes (Gard)
2006-09-23
3818

Re: Crash pLoader pour Linux quand on choisit le français ?

En essayant de lancer le transfert vers la galerie (sans changer la langue) des 3 photos sélectionnées, j'obtiens ceci dans le terminal :

resize thread threads=SCALAR(0x1e8e188)
Undefined subroutine &Uploader::GUI::App::shared_clone called at Uploader/GUI/App.pm line 1416.

... et le transfert ne s'effectue apparemment pas.

Hors ligne

#3 2010-06-01 09:32:10

ron
Former Piwigo Team
2008-09-30
211

Re: Crash pLoader pour Linux quand on choisit le français ?

Bonjour tosca,

Cette version de pLoader utilise des threads et il faut mettre à jour les modules perl. Il faut utiliser l'utilitaire en ligne de commande cpan.

depuis le terminal :

Code:

cpan

puis

Code:

cpan>install threads

puis

Code:

cpan>install threads::shared

puis

Code:

cpan>install Thread::Queue

Hors ligne

#4 2010-06-01 10:10:20

tosca
Former Piwigo Team
Cévennes (Gard)
2006-09-23
3818

Re: Crash pLoader pour Linux quand on choisit le français ?

J'ai lancé tout ça sans trop chercher à comprendre ... mais je constate quelques messages d'erreur (liste pas forcément exhaustive car le log est touffu !)
A la fin de l'étape 2, j'ai :

Failed during this command:
JDHEDDEN/threads-shared-1.33.tar.gz          : install NO

Et comme je ne l'avais pas vu tout de suite, j'ai enchaîné sur la dernière étape qui s'est terminée par :

Failed during this command:
JDHEDDEN/Thread-Queue-2.11.tar.gz            : install NO

C'est grave, docteur ?

Et puis, je ne sais pas comment sortir de ce truc ... ça m'affiche :

Code:

cpan[4]>

Dernière modification par tosca (2010-06-01 10:11:34)

Hors ligne

#5 2010-06-01 10:34:14

ron
Former Piwigo Team
2008-09-30
211

Re: Crash pLoader pour Linux quand on choisit le français ?

plg vient de m'indiquer les paquets debian :

Code:

apt-get install libthreads-perl libthreads-shared-perl

Hors ligne

#6 2010-06-01 10:37:12

tosca
Former Piwigo Team
Cévennes (Gard)
2006-09-23
3818

Re: Crash pLoader pour Linux quand on choisit le français ?

Ron, je crois que je vais laisser tomber ... maintenant que je sais que je peux alimenter la galerie par le plugin PiwigoExport de Digikam (je pensais que pLoader était incontournable pour une galerie piwigo.com)

Hors ligne

  •  » Outils
  •  » Crash pLoader pour Linux quand on choisit le français ?

Pied de page des forums

Propulsé par FluxBB

github twitter newsletter Faire un don Piwigo.org © 2002-2022 · Contact