Annonce

  •  » Plugins
  •  » [Résolu] Problème login admin register fluBB

#1 2010-03-23 16:12:55

dragonballed
Membre
2010-02-25
72

[Résolu] Problème login admin register fluBB

Voilà, depuis que j'ai activé ce plugin, tout va bien, les inscription se font sur la galerie et le forum en même temps. Seulement je n'arrive plus à me connecter sur le forum avec mon login administrateur. Une idée?

Hors ligne

#2 2010-03-23 16:17:20

dragonballed
Membre
2010-02-25
72

Re: [Résolu] Problème login admin register fluBB

oubliez ca, il m'a suffit de lancer une resynchronisation à partir de la config du plugin, et c'est tout bon! ^^

Hors ligne

#3 2010-03-23 17:57:25

Eric
Équipe Piwigo
VALENCE (FR)
2005-03-25
4579

Re: [Résolu] Problème login admin register fluBB

Ceci dit, j'ai remarqué des phénomènes de perte de synchro entre les tables users de FluxBB et Piwigo. J'ai identifié le problème : FluxBB utilise un hash SHA1 par défaut et se replie en MD5 si la fonction n'existe pas. Piwigo utilise MD5 par défaut. Parfois, sans vraiment savoir pourquoi, une connexion au forum FluxBB met à jour le mot de passe du compte qui se connecte en le transformant en SHA1.

Un SHA1 d'une clé MD5 = Mot de passe invalide.

J'ai modifié en son temps le comportement du plugin Register_FluxBB pour que les mots de passe saisis par les utilisateurs qui s'inscrivent soit transmis en SHA1 vers la table users de FluxBB. Mes tests avaient montrés que cela semblait résoudre le problème... Mais finalement, pas complètement. :-(

Lorsque j'aurais du temps, je me replongerai dans ce plugin surtout que la future 1.4 de FluxBB montre son nez. Mais là, j'ai tout juste le temps de lire quelques posts sur ce forum et faire une ou deux réponses...

[edit] [Bugtracker] ticket 1532 [/edit]

Dernière modification par Eric (2010-03-23 18:02:41)

Hors ligne

  •  » Plugins
  •  » [Résolu] Problème login admin register fluBB

Pied de page des forums

Propulsé par FluxBB

github twitter newsletter Faire un don Piwigo.org © 2002-2022 · Contact