•  » Styles
  •  » [Résolu] Meta Data / Simple Grey

#1 2009-12-01 21:49:18

grbaues
Membre
2009-12-01
50

[Résolu] Meta Data / Simple Grey

Hello

je suis totalement nouveau sur le sujet et le forum en plus :-)  Bon j'ai mis en place un
petit site base sur piwigo et le thème simple grey qui me plait beaucoup!

J'ai cherche un peu partout mais pas trouve la réponse au sujet des metadata a afficher a cote d'une photo : Ou est-ce que je
peux configurer les éléments a afficher ? Installe tel quel e.g. il me manque l'exposition; Je suis sur c'est simple mais il faut trouver
le bon endroit ...


Deuxième point ( ev a mettre dans un autre thread ) c'est language switcher : il m'affiche une longe liste avec tout les drapeau
au lieu d'en avoir ce joli fenetre avec les drapeau quand je mets la souris sur le drapeau de la langue active.


Merci pour votre aide et bientôt

Gregor


____________________________________________________________________________
Ma gallérie: http://www.desinstantscommeca.info
La photographie est une brève complicité entre la prévoyance et le hasard. - J.S. Mill

Hors ligne

#2 2009-12-07 22:31:34

saimon
Membre
2006-12-04
367

Re: [Résolu] Meta Data / Simple Grey

grbaues a écrit:

Ou est-ce que je peux configurer les éléments a afficher ? Installe tel quel e.g. il me manque l'exposition; Je suis sur c'est simple mais il faut trouver
le bon endroit ...

il me semble que c'est un truc à configurer dans le fichier de config (confic_local.inc.php ?).

grbaues a écrit:

Deuxième point ( ev a mettre dans un autre thread ) c'est language switcher : il m'affiche une longe liste avec tout les drapeau
au lieu d'en avoir ce joli fenetre avec les drapeau quand je mets la souris sur le drapeau de la langue active.

pourrais-tu donner l'adresse de ta galerie pour voir le soucis ?

Hors ligne

#3 2009-12-07 22:37:42

grbaues
Membre
2009-12-01
50

Re: [Résolu] Meta Data / Simple Grey

Voila le lien avec le pb du language switcher.
C'est en construction pas grand chose a voir pour l'instant : http://www.desinstantscommeca.info/
Le pb est le meme sous FF355 et IE8.

Je vais regarder dans le config file si je peux changer les infos exif/ipct


Thx pour la reponse!

Gregor

Dernière modification par grbaues (2009-12-07 22:41:39)


____________________________________________________________________________
Ma gallérie: http://www.desinstantscommeca.info
La photographie est une brève complicité entre la prévoyance et le hasard. - J.S. Mill

Hors ligne

#4 2009-12-07 23:10:03

saimon
Membre
2006-12-04
367

Re: [Résolu] Meta Data / Simple Grey

pour language switcher, le problème vient d'un fichier CSS qui n'est pas chargé dans le header, mais je ne sais pas pourquoi ...
peux-tu vérifier que tu as bien ce code à la fin du bloc <head> (dans header.tpl, mais vu que tu as rajouté une bannière tu dois savoir où ca se trouve ;-)):

Code:

  {if not empty($head_elements)}
  {foreach from=$head_elements item=elt}{$elt}{/foreach}
  {/if}

à moins que je me trompe c'est ce bout de code qui permet aux plugins d'ajouter des fchiers css / js (à confirmer).

Hors ligne

#5 2009-12-07 23:22:49

grbaues
Membre
2009-12-01
50

Re: [Résolu] Meta Data / Simple Grey

C'est du rapide :-))) Grand merci

Pour la banniere j'utilise PWG stuffs ou j'ai mis un bout de code dans le contenu d'un block juste au dessus
du bloc principale. 

Le code dans ton dernier post est bien présent dans le fichier header.tpl. Tu sais c'est quel ficher css qui manque ?
Juste pour vérifier qu'il est bien présent dans l'installation et pas corrompu ...
et accessoirement je peux bricoler un peu pour le forcer de se charger et ainsi confirmer le diagnostic ( sans soigner
le pb pour autant ... )

Gregor


____________________________________________________________________________
Ma gallérie: http://www.desinstantscommeca.info
La photographie est une brève complicité entre la prévoyance et le hasard. - J.S. Mill

Hors ligne

#6 2009-12-07 23:29:04

saimon
Membre
2006-12-04
367

Re: [Résolu] Meta Data / Simple Grey

le fichier manquant c'est language_switch.css, il devrait être inclus dans le bloc <head> mais il n'y est pas, je ne sais pas pourquoi ...
si jamais un gourou des plugins passe par là ;-)

Hors ligne

#7 2009-12-08 14:20:07

grbaues
Membre
2009-12-01
50

Re: [Résolu] Meta Data / Simple Grey

Concernant l'EXIF c'est bien dans le fichier config_default.inc.php ! Merci je vais modifier les données par la. Tu sais si il y a ev. un  plugin qui permet de faire cela sans ecrire directement a la "main" dans le fichier de config ?

Les fichiers css pour le language switcher sont bien la j'ai vérifie ... je vais ouvrir un topic cote plugins sur le sujet

Encore merci et ton thème est vraiment super allant a l'essentiel !!


Gregor


____________________________________________________________________________
Ma gallérie: http://www.desinstantscommeca.info
La photographie est une brève complicité entre la prévoyance et le hasard. - J.S. Mill

Hors ligne

#8 2009-12-08 14:37:00

Gotcha
Equipe Piwigo
Pierrelatte (26)
2007-03-14
13324

Re: [Résolu] Meta Data / Simple Grey

grbaues a écrit:

Concernant l'EXIF c'est bien dans le fichier config_default.inc.php ! Merci je vais modifier les données par la. Tu sais si il y a ev. un  plugin qui permet de faire cela sans ecrire directement a la "main" dans le fichier de config ?

STOP tout de suite ^_^

D'accord tu peux trouver des informations dans le fichier default mais ce n'est pas du tout ce qu'il faut faire.
La réponse à ta question se trouve dans la documentation, et si tu souhaite affiner l'affichage des métadata, il existe un MOD.
Je planche en ce moment sur la documentation (wiki) qui sera bientôt plus pratique à consulter et l'adaptation du MOD en question sera mon prochain objectif. Un peu de patience donc ;-)


Ayez comme premier réflexe de consulter le wiki.
Ensuite, veuillez effectuer une recherche sur le forum avant de poser votre question.

LE FAIRE EST LE REVELATEUR DE L'ETRE

Hors ligne

#9 2009-12-08 14:54:21

grbaues
Membre
2009-12-01
50

Re: [Résolu] Meta Data / Simple Grey

J'étais presque sur que ce n'est pas le bon endroit mais en défaut d'avoir trouve mieux ... et le irréparable n'étais pas encore commis :-). Je vais chercher dans la doc!

Merci pour le lien en tous cas. Gotcha est-ce que tu auras une idee sur la question du language switcher ou le survol ne marche pas la faute apparemment il y a un fichier css manquant ( il est bien physiquement sur le serveur ) ?

Gregor


____________________________________________________________________________
Ma gallérie: http://www.desinstantscommeca.info
La photographie est une brève complicité entre la prévoyance et le hasard. - J.S. Mill

Hors ligne

#10 2009-12-08 14:54:46

repie38
Équipe Piwigo
grenoble
2006-05-23
678

Re: [Résolu] Meta Data / Simple Grey

random header est activé ? si oui, essai de désactiver et regarde si language switch se comporte normalement ;)

Hors ligne

#11 2009-12-08 14:55:59

VDigital
Former Piwigo Team
Paris (FR)
2005-05-04
15124

Re: [Résolu] Meta Data / Simple Grey

saimon a écrit:

Code:

  {if not empty($head_elements)}
  {foreach from=$head_elements item=elt}{$elt}{/foreach}
  {/if}

à moins que je me trompe c'est ce bout de code qui permet aux plugins d'ajouter des fchiers css / js (à confirmer).

Exact.


Vincent -« Plus vidéaste averti que photographe amateur... »
La galerie - Le blog   

Piwigo est une application libre de gestion de photos en ligne.

Hors ligne

#12 2009-12-08 14:59:59

repie38
Équipe Piwigo
grenoble
2006-05-23
678

Re: [Résolu] Meta Data / Simple Grey

edit : je m'ai trompé :p
la suite plus bas ;)

Dernière modification par repie38 (2009-12-08 15:46:57)

Hors ligne

#13 2009-12-08 15:03:23

grbaues
Membre
2009-12-01
50

Re: [Résolu] Meta Data / Simple Grey

repie38 a écrit:

random header est activé ? si oui, essai de désactiver et regarde si language switch se comporte normalement ;)

Oui il étais actif et en désactivant le random header le pb du language switcher a disparu !!  Merci :-)) 
Quel est l'interaction entre les deux ?

merci encore :-)) ça fait beaucoup mieux tout de suite ...

Gregor


____________________________________________________________________________
Ma gallérie: http://www.desinstantscommeca.info
La photographie est une brève complicité entre la prévoyance et le hasard. - J.S. Mill

Hors ligne

#14 2009-12-08 15:38:47

repie38
Équipe Piwigo
grenoble
2006-05-23
678

Re: [Résolu] Meta Data / Simple Grey

eureka!
le souci viendrai de

Code:

  {if not empty($head_elements)}
  {foreach from=$head_elements item=elt}{$elt}{/foreach}
  {/if}

dans header.tpl. la solution :

Code:

{if not empty($head_elements)}
  {foreach from=$head_elements item=elt}{$elt}
  {/foreach}
{/if}

encore une regle de syntaxe smarty que je ne comprends pas trop ...

j'en profite aussi pour dire, mais je le redirais dans le sujet adéquat, que random header ne pourra pas marcher avec simple grey car il n'y a pas de div "theHeader", mais une div "header"

Hors ligne

#15 2009-12-08 23:00:32

saimon
Membre
2006-12-04
367

Re: [Résolu] Meta Data / Simple Grey

ok, encore merci à toi ;-)

Hors ligne

  •  » Styles
  •  » [Résolu] Meta Data / Simple Grey

Pied de page des forums

Propulsé par FluxBB

github twitter facebook newsletter Faire un don Piwigo.org © 2002-2019 · Contact