Annonce

Écrire une réponse

Veuillez écrire votre message et l'envoyer

Cliquez dans la zone sombre de l'image pour envoyer votre message.

Retour

Résumé de la discussion (messages les plus récents en premier)

Katryne
2021-06-09 15:16:36

Hello K5 !
Qu'est-ce que tu veux dire ? Qu'il faut que je change l'encodage ?
Mais celui où le plugin fonctionne a le même encodage que l'autre.
C'est un Piwigo 11.4 installé tout neuf. Avec une BDD MariaDB.

Celui où ça marche pas est un Piwigo 11.5 mis à jour. Avec une BDD Mysql.

k5
2021-06-09 15:02:28

Bonjour,
ici
https://i.imgur.com/dhKcY5p.png
A très vite

Katryne
2021-06-08 06:53:01

Ah si, j'ai trouvé l'accès à la BDD, ! l'encodage est le même que chez Ionos : utf8mb4_unicode_ci.

Katryne
2021-06-08 06:43:12

Bonjour !
Ah, là où ça marche, c'est sur un autre hébergement, avec Legtux qui est hébergé chez OVH, je crois. Et c'est en Piwigo 11.4 : https://revest.legtux.org/
Je n'y ai pas accès à la gestion de la BDD. Et je ne sais pas comment y vérifier l'encodage.

Piwigo 11.4.0
Système d'exploitation: Linux
PHP: 7.4.18 (Montrer les informations) [2021-06-08 06:31:25]
MySQL: 5.5.5-10.3.27-MariaDB-0+deb10u1 [2021-06-08 06:31:25]
Bibliothèque graphique: ImageMagick 6.9.10-23

ddtddt
2021-06-08 06:16:11

Bonjour,

oui c'est cela la question
et ton site ou cela fonctionne ?

logiquement il devrait être en utf8_general_ci

Katryne
2021-06-07 20:58:06

utf8mb4_unicode_ci  si c'est ça que tu demandes ...

ddtddt
2021-06-07 20:47:00

Bonjour,

base de données encodé en quoi ?

Katryne
2021-06-07 18:35:32

Coucou ddtddt,
Non ça marchait pas avant (en 11.5) et ça marche pas mieux avec la modif. La table n'est pas créée parce que c'est un site qui a subi (!) une maj de 2.10 vers 11.5, avec maj de la BDD aussi.
Sur un autre site créé d'origine en 11.x (je sais plus), la table s'est bien créée et le plugin fonctionne sans message intempestif.

Quand je dis que ça marche pas, c'est pas seulement les commentaires qui sont impossibles, ce sont toutes les pages Album et l'accueil de l'admin qui sont toutes blanches (sauf pour le message d'avertissement si j'active l'affichage des messages) Là, je les cache via LFE.

ddtddt
2021-06-07 18:27:52

Katryne a écrit:

Bonjour !
La modif de K5 ne marche pas très beaucoup. Ma version de MySQL: 5.5.60-0+deb7u1-log.

Bonjour,

et sans la modif cela ne fonctionne pas ?

Katryne
2021-06-07 17:03:52

Bonjour !
La modif de K5 ne marche pas très beaucoup. Ma version de MySQL: 5.5.60-0+deb7u1-log.

ddtddt
2021-05-12 12:49:46

Bonjour,

oui j'ai bien compris
Il faut regarder à partir de quel version de MySql now() fonctionne, la version courante

k5
2021-05-12 10:39:34

Bonjour,

Explication
1.installation piwigo 11.x
2.installation du plugin "comments on albums" à partir de la liste "Autre plugins disponible"
Il ne crée pas sa table et ses structures à cause de now() de date datatime comme valeur de defaut défini, ca fait erreur syntaxique.
je propose une des solutions de changer le now() en nombre digital "1970-01-01 00:00:00"

A très vite

k5
2021-05-10 15:31:00

Bonjour,
[Github] Piwigo-Comments-on-Albums file maintain.class.php@L22
en remplaçant par

Code:

`date` datetime NOT NULL DEFAULT "1970-01-01 00:00:00",

A très vite

ddtddt
2021-05-10 14:24:28

Bonjour

propose la déjà sur le forum en réponse à ce post

k5
2021-05-10 12:07:49

Bonjour,
j'ai trouvé le bug :) j'ai la solution :) je fais comment pour le partager ?
A très vite

Pied de page des forums

Propulsé par FluxBB

github twitter newsletter Faire un don Piwigo.org © 2002-2022 · Contact