Annonce

Écrire une réponse

Veuillez écrire votre message et l'envoyer

Cliquez dans la zone sombre de l'image pour envoyer votre message.

Retour

Résumé de la discussion (messages les plus récents en premier)

Katryne
2021-02-09 21:54:33

Non, ça a dû être racheté : si je teste l'url https://freegeoip.net , c'est redirigé vers https://ipstack.com/

Mais là, faut donner des infos pour ouvrir un compte, et obtenir une API.
Si je remplace l'url dans le fichier, ça me donne le même résultat si je veux utiliser les filtres.

Mais je ne sais toujours pas comment je peux configurer l'historique dans le Piwigo tout nu, sans Whois online.

ddtddt
2021-02-09 21:34:45

Bonjour

ou temporairement HS
si tu met https à la place de http cela résout le problème ?

Katryne
2021-02-09 10:19:20

Hello ddtddt, voici les lignes 58 à 61 de wo_admin_functions.inc.php

Code:

 {
    $url = 'http://freegeoip.net/json/' . $trace['IP'];
  
    if (fetchRemote($url, $result) and $geo_data = @json_decode($result, true))

Il est possible que cela corresponde à un service d'identification d'IP qui ne serait plus en service ?

ddtddt
2021-02-09 07:11:28

Bonjour

et il y a quoi sur cette ligne dans le fichier ?

Katryne
2021-02-08 22:23:17

Merci K5 mais ...
Si je n'active pas le plugin, je n'ai pas de config de l'historique.
Si j'active le plugin, la config apparait via l'icône à côté de du lien de menu Historique (même chose que dans la config du plugin). Mais la page recherche donne un message d'erreur ou un avertissement (notice) quand on clique sur un filtre.

Fatal error: Uncaught Error: Call to undefined function fetchRemote() in /homepages/1/xxx/htdocs/imagesdocsnew/plugins/whois_online/include/wo_admin_functions.inc.php:61 Stack trace: #0 /homepages/1/xxx/htdocs/imagesdocsnew/plugins/whois_online/reload.php(104): whois_country(Array, false) #1 {main} thrown in /homepages/1/xxx/htdocs/imagesdocsnew/plugins/whois_online/include/wo_admin_functions.inc.php on line 61

k5
2021-02-08 21:21:30

Bonjour,
c'est vrai que l'aide n'est pas à jour, dans les anciennes versions de piwigo, il fallait faire cette méthode
Maintenant l'historique est dans l'onglet "outils"
Pour activer la configuration de "whoisonline" , 1 clic sur "plugins" et 1 clic sur "outils". et on voit un petit dessin à côté de historique.
je ne comprends pas pourquoi la config est à côté de "historique" alors qu'il y a la possibilité de configurer à partir du "plugins" et j'ai une erreur 500 sur l'onglet "radar" que je vais regarder.
Cordialement
k5

Katryne
2021-02-08 19:33:04

Bonjour !
Sur mes Piwigos 2.10.2 ou 11, je cherche à configurer le mode d'enregistrement de l'historique. Parce que la recherche ne donne jamais rien. Et cette page de recherche dans l'historique n'a pas bougé entre les 2 versions.
Je clique sur l'aide de cette page d'admin et je lis :

Ces écrans permettent de suivre l'historique de navigation dans Piwigo suivant les options que vous avez déterminées dans - Administration » Configuration » Options » Onglet "Historique".

Mais je n'ai pas d'onglet "Historique" dans aucune de mes versions de Piwigo.

Ai-je besoin de nouvelles lunettes ? J'ai désactivé le plugin Whois online qui comporte une partie de configuration et je retrouve un peu plus de résultats pour mes recherches. Mais je ne sais toujours pas où se cache l'onglet Historique dans la config.

Pied de page des forums

Propulsé par FluxBB

github twitter newsletter Faire un don Piwigo.org © 2002-2022 · Contact