Annonce

Écrire une réponse

Veuillez écrire votre message et l'envoyer

Cliquez dans la zone sombre de l'image pour envoyer votre message.

Retour

Résumé de la discussion (messages les plus récents en premier)

Pedrocorse
2021-01-25 13:08:55

Merci

plg
2021-01-24 18:35:12

rightclick, je suis sûr à 99% qu'il sera compatible d'emblée, vu qu'il n'y a pas de page de configuration, juste un impact côté galerie (qui a très peu bougé en version 11).

extension:216 en revanche, va falloir que son auteur s'y penche :-)

Pedrocorse
2021-01-24 17:24:41

Merci encore de ton aide,

il manque plus que la compatibilité des plugins tel que UserAdvManager ou RightClick ;-) pour que la Version 11.1.0 de piwigo soit au top.

Pedro

plg
2021-01-24 15:44:48

Pedrocorse a écrit:

J'ai la réponse. [...] Les albums se sont à cause de ça.

Ouf ! Heureusement que Piwigo ne sort pas des albums de son chapeau :-)

Pedrocorse
2021-01-24 12:03:15

J'ai la réponse.

La personne qui à chargé les photos (le président de l'association) ma dit qu'un repertoire comportait un accent qu'il n'a pas vu et au lieux de faire une simulation avant la synchro, il n'a pas fait la simulation. Les albums se sont à cause de ça.

Merci

plg
2021-01-24 11:46:44

Pedrocorse a écrit:

et pour mes 1300 albums créés, est ce que c'est normal ?

Bien sûr que ce n'est pas normal. D'où sortent ces albums ?!?  Normalement Piwigo ne créé pas d'albums tout seul ! Tu n'as pas lancé une synchro ? As-tu le plugin community activé, configuré avec les "albums utilisateur" et les noms d'album correspondent au nom de tes utilisateurs ?

Pedrocorse a écrit:

PS :Autre chose, j'avais déjà un compte sur le forum (Pseudo : Pedro) mais j'ai posté mes message sans me connecter (je pensais ne pas avoir de compte), peux-tu attribuer mes posts sur mon pseudo Pedro ou ce n'ai pas la peine et on laisse comme ça ?

On laisse comme ça.

Pedrocorse
2021-01-23 14:03:51

Impeccable ça fonctionne,

et pour mes 1300 albums créés, est ce que c'est normal ?

J'ai fais la mise à jour vers la version 11.1

Merci de ton aide
Pedro


PS :Autre chose, j'avais déjà un compte sur le forum (Pseudo : Pedro) mais j'ai posté mes message sans me connecter (je pensais ne pas avoir de compte), peux-tu attribuer mes posts sur mon pseudo Pedro ou ce n'ai pas la peine et on laisse comme ça ?

plg
2021-01-22 12:03:05
plg
2021-01-22 12:01:56

OK, j'ai partiellement réécrit l'algorithme pour limiter la conso mémoire (et améliorer globalement les perfs). C'est de l'optimisation "d'hôpital de guerre". Plus tard, le patient repassera à l'hôpital pour une opération plus optimale.

Note : j'ai testé la nouvelle version du tableau de bord sur ton Piwigo. Du coup ça marche...

plg
2021-01-22 10:27:29

J'ai dupliqué ta table piwigo_activity sur mon environnement de dev et boom, exactement le même problème de limite de mémoire atteinte. C'est une bonne chose. Comme on dit chez les développeur :

> problème reproduit à moitié corrigé

plg
2021-01-22 10:21:29

OK, tu as 275952 lignes dans la table piwigo_activity (jamais vu aussi gros, mais c'est bien, il faut que Piwigo sache gérer ça). Mon petit doigt me dit que l'algorithme qui fabrique les chiffres à afficher pour le nouveau graphe d'activités n'est pas optimisé pour limiter la conso mémoire... j'investigue !

Pedrocorse
2021-01-21 22:50:54

plg a écrit:

La 11.1.0 va corriger :

* le problème du popen [Github] Piwigo issue #1290
* le problème du "infinite loop?" [Github] Piwigo issue #1284

Par contre, le "Fatal error: Allowed memory size" je ne comprends pas pourquoi. Je n'arrive pas à accéder à ce dont j'ai besoin sur ton site, donc difficile de faire un diagnostic précis (je t'ai envoyé un email à l'instant). En tout cas je vois très peu de photos publiques sur ton Piwigo, donc je doute que tu aies un historique énorme (et donc une conso mémoire démesurée lors du calcul des statistiques).

Je t'ai envoyé un mail.
Le site est en preparation pour une ouverture prochaine donc effectivement pour le moment personne ne le visite. Le site actuellement en production est sur un autre domaine mais comme le nombre de photo est limité, on va transférer le site sur un autre domaine qui peut contenir une nombre de photo illimité.

on a donc un historique faible mais un nombre de photo énorme (actuellement 105 883 photos).

plg
2021-01-21 19:20:25

La 11.1.0 va corriger :

* le problème du popen [Github] Piwigo issue #1290
* le problème du "infinite loop?" [Github] Piwigo issue #1284

Par contre, le "Fatal error: Allowed memory size" je ne comprends pas pourquoi. Je n'arrive pas à accéder à ce dont j'ai besoin sur ton site, donc difficile de faire un diagnostic précis (je t'ai envoyé un email à l'instant). En tout cas je vois très peu de photos publiques sur ton Piwigo, donc je doute que tu aies un historique énorme (et donc une conso mémoire démesurée lors du calcul des statistiques).

tetraric
2021-01-20 15:31:46

Bonjour,

Ayant un message d'erreur semblable je me permets de poster ici, j'ai :

Warning: popen(): Unsupported in /var/www/sda/3/3/.../piwigo/admin/intro.php on line 395

Warning: fgets() expects parameter 1 to be resource, boolean given in /var/www/sda/3/3/.../piwigo/admin/intro.php on line 396

Warning: pclose(): Unsupported in /var/www/sda/3/3/.../piwigo/admin/intro.php on line 398

Warning: Cannot modify header information - headers already sent by (output started at /var/www/sda/3/3/.../piwigo/admin/intro.php:395) in /var/www/sda/3/3/.../piwigo/include/page_header.php on line 94

Cela n'apparait que sur la page Tableau de Bord
Il ne semble en rien gênant mais s'il est là c'est qu'il y a des soucis...

Environnement - pageperso Free
Piwigo 11.0.0 Dernière version ?
Système d'exploitation: Linux
PHP: 5.6.34 (Montrer les informations) [2021-01-20 15:28:20]
MySQL: 5.0.83 [2021-01-20 15:28:20]
Bibliothèque graphique: GD bundled (2.1.0 compatible)

Merci

Pedrocorse
2021-01-19 20:39:11

J'ai essayé de renvoyer tous les fichiers en FTP,

j'arrive (après avoir vidé le cache du navigateur) à me connecter une première fois sur la page admin mais les messages d'erreur suivants apparaissent :

Warning: popen() has been disabled for security reasons in /htdocs/admin/intro.php on line 395

Warning: fgets() expects parameter 1 to be resource, null given in /htdocs/admin/intro.php on line 396

Warning: pclose() expects parameter 1 to be resource, null given in /htdocs/admin/intro.php on line 398

Warning: A non-numeric value encountered in /htdocs/admin/intro.php on line 406

Ensuite je navigue correctement dans toutes les pages d'administration mais quand je clique sur "tableau de bord" je reviens à l'erreur PHP.

Je pense également qu'il doit y avoir un problème avec les stats

j'espère que plg pourra trouver d'où vient le problème

Bonne soirée

Pied de page des forums

Propulsé par FluxBB

github twitter newsletter Faire un don Piwigo.org © 2002-2022 · Contact