Annonce

Écrire une réponse

Veuillez écrire votre message et l'envoyer

Cliquez dans la zone sombre de l'image pour envoyer votre message.

Retour

Résumé de la discussion (messages les plus récents en premier)

PhilEPTB
2020-07-17 11:12:53

Solution apportée par l'équipe Piwigo ici https://github.com/Piwigo/Piwigo/pull/643/files (merci à eux) de laquelle j'ai été informé grâce à JLE67.
La solution fonctionne, le ticket peut être clos.

Dom59
2020-05-23 19:22:59

Bonjour, je ne sais pas si il y a un rapport mais j'ai remarqué un truc cette semaine.
J'utilise également XnView pour éditer mes metadata de mes photos et Notepad++ pour éditer mes fichiers txt, php, css etc
Par défaut j'ai configurer notepad pour encoder en UTF-8
Si tu mets les meta IPTC en UTF-8 dans XnView tu auras un soucis avec avec l'encodage des caractères latin à,é,ë etc etc
Sur XnView il faut envoyer du ANSI
https://superuser.com/questions/540286/ … fault-ones
Bon courage

PhilEPTB
2020-05-23 11:57:18

Bonjour,

Je viens d'éditer et de comparer le fichier téléchargé (qui ne s'affiche pas) avec le fichier original (qui s'affiche) avec notepad++.
Le fichier téléchargé a la 1ère ligne vide et alors qu'il devrait se terminer par FF D9, il se termine par FF.
Si je supprime la ligne vide et que j'écris D9 à la fin (FF D9 étant la fin d'un fichier jpg), le fichier s'affiche avec la visionneuse Windows.
Reste à savoir pourquoi cette transformation s'opère lors du téléchargement de fichier...
Quelqu'un a-t-il une idée ou arrive-t-il à reproduire le problème ?

En vous remerciant d'avance pour vos réponse.

PhilEPTB
2020-05-19 09:34:14

Bonjour et merci pour votre réactivité.

Comme je l'ai indiqué dans mon message, j'utilise PHP 7 sur le serveur.
D'autre part, si cela venait de Windows, pourquoi, sur mon serveur Linux, il y aurait le même comportement ?
Je rappelle que le fichier d'origine n'est visiblement pas altéré puisque j'arrive à l'ouvrir avec l'explorateur de fichier de Debian 9. C'est à travers l'application Piwigo que je n'y arrive plus (alors que ça fonctionnait avant !).
J'ai essayé sur Windows avec les navigateurs Firefox, Chrome et Opéra et j'obtiens le même comportement. J'ai essayé également avec des petits fichiers jpg, au cas où un timeout ou un filesizemax bloquerait mais c'est toujours pareil.

En vous remerciant d'avance pour vos réponses.

k5
2020-05-19 08:56:51

Bonjour,
Php 5 installé ?

ddtddt
2020-05-19 06:27:47

Bonjour

Windows ne télécharge pas l'extension ?

avec tous les navigateur ?

PhilEPTB
2020-05-18 18:27:36

Bonsoir,

Depuis environ 2 mois, lorsque je veux ouvrir une photo jpg téléchargée depuis l'interface de Piwigo, la visionneuse Windows affiche : "il semble que nous ne prenions pas en charge ce format de fichier".
J'ai fait la même expérience sur le serveur (linux Debian 9) : même résultat.
J'ai donc recherché le nom du fichier (en éditant la photo en mode administration). Si je vais ouvrir directement le fichier sur le serveur sans passer par l'application, il s'ouvre correctement.
Autre test : j'arrive à ouvrir ces jpg avec XnView.
Je précise que cela se produit avec toutes les photos. Je suis même allé jusqu'à remonté un piwigo sur un serveur tout neuf en http (mon serveur de prod est en https) et j'observe le même comportement.
J'avoue que j'en perds mon latin...
Si quelqu'un a une idée, je suis preneur !


Version de Piwigo: 2.10.2
Version de PHP: 7.0.33-0+deb9u7
Version de MySQL: 5.5.5-10.1.44-MariaDB-0+deb9u1
URL Piwigo: https://media.seinegrandslacs.fr

Pied de page des forums

Propulsé par FluxBB

github twitter newsletter Faire un don Piwigo.org © 2002-2020 · Contact